If I am bcc-ed, my reply goes to the wrong recipient

RESOLVED INVALID

Status

Thunderbird
Untriaged
RESOLVED INVALID
3 years ago
3 years ago

People

(Reporter: Andrew Barnes, Unassigned)

Tracking

31 Branch
x86_64
Windows 7

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

3 years ago
User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:35.0) Gecko/20100101 Firefox/35.0
Build ID: 20150122214805

Steps to reproduce:

I use Thunderbird.  Another Thunderbird user, email X, sends an email to email address Y, bcc-ing me.  If I reply to the email, my reply goes to the original recipient Y, whereas I believe that it should go to the originator X.


Actual results:

My reply goes to Y.


Expected results:

My reply should go to X.

Comment 1

3 years ago
Are X and Y both identities on your setup? Or do you have some auto-bcc, or auto-cc addresses set up?
If not, please attach a sample as .eml
(Reporter)

Comment 2

3 years ago
Created attachment 8557521 [details]
Blagdon Good Companions.eml - sample email showing the problem
(Reporter)

Comment 3

3 years ago
Hi Magnus.  Context is that I and a colleague co-edit our local parish magazine.  To that end, we each have a Thunderbird identity "Blagdon Parish Magazine" set up on our machines; on the "Copies & Folders" tab this identity is set up to bcc the other.

The attached eml was sent by John to "Chew Valley Gazette", and I was automatically bcc-ed.  If I reply to this email, my reply gets sent to "Chew Valley Gazette", whereas I believe it should go to John.

Thanks

Andrew

Comment 4

3 years ago
Ah yes. Replies to other identities are treated as a followup. There are few cases you'd actually want to mail yourself.
(Reporter)

Comment 5

3 years ago
Well I'm not emailing myself - I'm trying to reply to my colleague.  The eml file I sent you says:

...
Sender: John Harvey <jrharveyxyz@gmail.com>
Message-ID: <54BCD685.5090705@blagdon.org>
Date: Mon, 19 Jan 2015 10:03:49 +0000
From: Blagdon  Parish  Magazine <parishmagazine@blagdon.org>
Reply-To: parishmagazine@blagdon.org
Organization: Blagdon  Parish  Magazine
User-Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:31.0) Gecko/20100101 Thunderbird/31.4.0
MIME-Version: 1.0
To: Chew Valley Gazette <editorial@chewvalleygazette.co.uk>
...

- so why does my reply go to Chew Valley Gazette?

Andrew

Comment 6

3 years ago
yourself = any of your aliases. So, this mail was from "you", thus it is treated as a followup (reply-to-self).

IF your other identity address is in the To/CC that won't happen, but since BCC leaves no trace in the receiving end, thunderbird can't know it's not a mail from you.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → INVALID
(Reporter)

Comment 7

3 years ago
Ah - thank you - that's rather subtle (and if I may say so, decidedly counter-intuitive!).  It's also potentially dangerous/embarrassing - if I want to make some comment to my colleague about his email, and hit "reply" to do so, then unless I spot that it's going to the wrong place I could end up forwarding a comment that I wouldn't want the original recipient to see ... :-(.

Andrew
You need to log in before you can comment on or make changes to this bug.