Nexus 5 Lollipop compilation gives an error : "'mSharedDecoderManager' was not declared in this scope" in gecko/dom/media/mediasource/MediaSourceReader.cpp:406

RESOLVED FIXED in Firefox 36, Firefox OS v2.2

Status

Firefox OS
GonkIntegration
RESOLVED FIXED
3 years ago
3 years ago

People

(Reporter: nhirata, Assigned: nhirata)

Tracking

unspecified
2.2 S5 (6feb)
ARM
Gonk (Firefox OS)

Firefox Tracking Flags

(blocking-b2g:2.2+, firefox36 fixed, firefox37 fixed, firefox38 fixed, b2g-v2.2 fixed, b2g-master fixed)

Details

Attachments

(1 attachment)

Nexus 5 Lollipop compilation gives an error : "'mSharedDecoderManager' was not declared in this scope" in gecko/dom/media/mediasource/MediaSourceReader.cpp:406
Flags: needinfo?(kli)
Created attachment 8557458 [details] [diff] [review]
patch.diff
Attachment #8557458 - Flags: review?(kli)
Comment on attachment 8557458 [details] [diff] [review]
patch.diff

Review of attachment 8557458 [details] [diff] [review]:
-----------------------------------------------------------------

LGTM. As I know MOZ_FMP4 will not be enabled in b2g Lollipop build. So I think this patch is reasonable. Bug I can't review this patch.

Matt, Jya, Could you review this patch? Thanks!
Attachment #8557458 - Flags: review?(matt.woodrow)
Attachment #8557458 - Flags: review?(kli)
Attachment #8557458 - Flags: review?(jyavenard)
Attachment #8557458 - Flags: feedback+
Comment on attachment 8557458 [details] [diff] [review]
patch.diff

Review of attachment 8557458 [details] [diff] [review]:
-----------------------------------------------------------------

lgtm since in the header we have:
#ifdef MOZ_FMP4
  nsRefPtr<SharedDecoderManager> mSharedDecoderManager;
#endif
Attachment #8557458 - Flags: review?(jyavenard) → review+
https://hg.mozilla.org/integration/b2g-inbound/rev/6cb0a06f436d
Flags: needinfo?(kli)
https://hg.mozilla.org/mozilla-central/rev/6cb0a06f436d
Assignee: nobody → nhirata
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → FIXED
Attachment #8557458 - Flags: review?(matt.woodrow)
Comment on attachment 8557458 [details] [diff] [review]
patch.diff

Approval Request Comment
[Feature/regressing bug #]: MSE
[User impact if declined]: More difficult to backport fixes.
[Describe test coverage new/current, TreeHerder]: Landed on m-c.
[Risks and why]: Risk is minimal. Adds a missing guard with no functional change.
[String/UUID change made/needed]: None.
Attachment #8557458 - Flags: approval-mozilla-beta?
Attachment #8557458 - Flags: approval-mozilla-aurora?
Please also land to branch 2.2. Thanks.
blocking-b2g: --- → 2.2?
Comment on attachment 8557458 [details] [diff] [review]
patch.diff

NOTE: Please see https://wiki.mozilla.org/Release_Management/B2G_Landing to better understand the B2G approval process and landings.

[Approval Request Comment]
Bug caused by (feature/regressing bug #): compile error
User impact if declined: compile failed
Testing completed: verified on m/c
Risk to taking this patch (and alternatives if risky): low, only add compile flag to correct it.
String or UUID changes made by this patch: none
Attachment #8557458 - Flags: approval-mozilla-b2g37?

Updated

3 years ago
blocking-b2g: 2.2? → 2.2+

Updated

3 years ago
Attachment #8557458 - Flags: approval-mozilla-b2g37? → approval-mozilla-b2g37+
http://hg.mozilla.org/releases/mozilla-b2g37_v2_2/rev/11d93135c678
status-b2g-v2.2: --- → fixed
status-b2g-master: --- → fixed
Target Milestone: --- → 2.2 S5 (6feb)
Attachment #8557458 - Flags: approval-mozilla-beta?
Attachment #8557458 - Flags: approval-mozilla-beta+
Attachment #8557458 - Flags: approval-mozilla-aurora?
Attachment #8557458 - Flags: approval-mozilla-aurora+
In the future, it creates less work for everyone if you let the aurora/beta approval process play out before worrying about b2g37 approval. Aurora is merging to b2g37 during this cycle, so it would have landed there anyway if approved for aurora. Likewise for beta during the next cycle.
Flags: needinfo?(kli)
https://hg.mozilla.org/releases/mozilla-aurora/rev/8f3d1a85d073
status-firefox36: --- → affected
status-firefox37: --- → fixed
status-firefox38: --- → fixed
https://hg.mozilla.org/releases/mozilla-beta/rev/07cc8d56cde8
status-firefox36: affected → fixed
Noted.
Flags: needinfo?(kli)
You need to log in before you can comment on or make changes to this bug.