/build/mozilla/dom/base/nsGlobalWindow.h:112:7: error: forward declaration of 'class mozilla::dom::Promise'

RESOLVED DUPLICATE of bug 1127882

Status

--
blocker
RESOLVED DUPLICATE of bug 1127882
4 years ago
4 years ago

People

(Reporter: mkmelin+mozilla, Unassigned)

Tracking

({intermittent-failure, regression})

Trunk
x86
Linux
intermittent-failure, regression

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

4 years ago
https://treeherder.mozilla.org/logviewer.html#?job_id=8577&repo=comm-central

Happening on Linux debug (bug not on Linux x64 debug).

 from /builds/slave/tb-c-cen-lx-d-0000000000000000/build/objdir-tb/dom/bindings/UnifiedBindings1.cpp:2:
../../dist/include/nsRefPtr.h: In instantiation of 'nsRefPtr<T>::~nsRefPtr() [with T = mozilla::dom::Promise]':
../../dist/include/mozilla/dom/ServiceWorkerEvents.h:29:22: required from here
../../dist/include/nsRefPtr.h:60:7: error: invalid use of incomplete type 'class mozilla::dom::Promise'
In file included from ../../dist/include/mozilla/dom/PopupBlockedEventBinding.h:12:0,
from /builds/slave/tb-c-cen-lx-d-0000000000000000/build/objdir-tb/dom/bindings/PopupBlockedEventBinding.cpp:5,
from /builds/slave/tb-c-cen-lx-d-0000000000000000/build/objdir-tb/dom/bindings/UnifiedBindings1.cpp:50:
/builds/slave/tb-c-cen-lx-d-0000000000000000/build/mozilla/dom/base/nsGlobalWindow.h:112:7: error: forward declaration of 'class mozilla::dom::Promise'
In file included from ../../dist/include/nsAutoPtr.h:11:0,
from /builds/slave/tb-c-cen-lx-d-0000000000000000/build/mozilla/dom/svg/DOMSVGAnimatedLengthList.h:9,
from /builds/slave/tb-c-cen-lx-d-0000000000000000/build/mozilla/dom/svg/DOMSVGLengthList.h:9,
from /builds/slave/tb-c-cen-lx-d-0000000000000000/build/mozilla/dom/svg/DOMSVGLength.h:9,
from /builds/slave/tb-c-cen-lx-d-0000000000000000/build/objdir-tb/dom/bindings/SVGLengthBinding.cpp:3,
from /builds/slave/tb-c-cen-lx-d-0000000000000000/build/objdir-tb/dom/bindings/UnifiedBindings1.cpp:2:
../../dist/include/nsRefPtr.h: In instantiation of 'nsRefPtr<T>::nsRefPtr(const nsRefPtr<T>&) [with T = mozilla::dom::Promise]':
../../dist/include/mozilla/dom/ServiceWorkerEvents.h:69:27: required from here
../../dist/include/nsRefPtr.h:77:7: error: invalid use of incomplete type 'class mozilla::dom::Promise'
In file included from ../../dist/include/mozilla/dom/PopupBlockedEventBinding.h:12:0,
from /builds/slave/tb-c-cen-lx-d-0000000000000000/build/objdir-tb/dom/bindings/PopupBlockedEventBinding.cpp:5,
from /builds/slave/tb-c-cen-lx-d-0000000000000000/build/objdir-tb/dom/bindings/UnifiedBindings1.cpp:50:
/builds/slave/tb-c-cen-lx-d-0000000000000000/build/mozilla/dom/base/nsGlobalWindow.h:112:7: error: forward declaration of 'class mozilla::dom::Promise'
make[5]: *** [UnifiedBindings1.o] Error 1
make[5]: *** Waiting for unfinished jobs....
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
(Reporter)

Updated

4 years ago
Keywords: regression
Comment hidden (Treeherder Robot)

Updated

4 years ago
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1127882
You need to log in before you can comment on or make changes to this bug.