bugzilla.mozilla.org has resumed normal operation. Attachments prior to 2014 will be unavailable for a few days. This is tracked in Bug 1475801.
Please report any other irregularities here.

Pressing return key does not work on Google.com

RESOLVED INCOMPLETE

Status

()

Firefox
Untriaged
RESOLVED INCOMPLETE
4 years ago
3 years ago

People

(Reporter: lord.of.the.flies.0, Unassigned)

Tracking

35 Branch
x86
Mac OS X
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

4 years ago
Created attachment 8557526 [details]
Screenshot of the point where hitting enter does nothing to search.

User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.10; rv:35.0) Gecko/20100101 Firefox/35.0
Build ID: 20150122214805

Steps to reproduce:

1) Go to google.com
2) Type in search query
3) Hit enter to search


Actual results:

Nothing comes up. Instead of searching, Google displays an empty results page and the text "Press Enter to search." I can click the magnifying glass to trigger the search, but hitting enter does nothing. This bug does not occur on Safari, the only other browser I have tested it in. This is particularly annoying when a search query needs to be revised after using the browser's search bar.


Expected results:

The search should have been activated by pressing Enter.
(Reporter)

Comment 1

4 years ago
Just a note, this bug occurs on my Windows laptop as well, and has been occurring for as long as I can remember.
(Reporter)

Comment 2

4 years ago
I found a thread on the Firefox subreddit from 2 years ago detailing the same problem: https://www.reddit.com/r/firefox/comments/14ej7c/google_search_return_a_blank_page/

Comment 3

3 years ago
Hi,

I tested this issue on Mac OS X 10.10 with Firefox Nightly 46.0a1 and I can't reproduce it. Do you still have this problem?
Flags: needinfo?(lord.of.the.flies.0)

Comment 4

3 years ago
Hi,
Marking this as Resolved: Incomplete due to the lack of response from the reporter.
Reporter, please feel free to reopen it if you are still having this issue on the latest Firefox version.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 3 years ago
Flags: needinfo?(lord.of.the.flies.0)
Resolution: --- → INCOMPLETE
You need to log in before you can comment on or make changes to this bug.