Upgrade Bugzilla from v4.4.8 to Bugzilla 4.5.1 breaks on creation of FK constraint

RESOLVED DUPLICATE of bug 923865

Status

Testopia
General
RESOLVED DUPLICATE of bug 923865
3 years ago
3 years ago

People

(Reporter: Peter Florijn, Assigned: Greg Hendricks)

Tracking

Details

(Reporter)

Description

3 years ago
User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.10; rv:35.0) Gecko/20100101 Firefox/35.0
Build ID: 20150122214805

Steps to reproduce:

Upgraded from v4.4.8 to v4.5.1

sudo perl checksetup.pl
* This is Bugzilla 4.5.1 on perl 5.18.2


Actual results:

Adding new table email_bug_ignore...
New parameter: webservice_email_filter
Removing existing compiled templates...
Precompiling templates...done.
Fixing file permissions...
Adding salt separator to password hashes...
Dropping foreign key: bugs.component_id -> components.id...
Dropping foreign key: component_cc.component_id -> components.id...
Dropping foreign key: flagexclusions.component_id -> components.id...
Dropping foreign key: flaginclusions.component_id -> components.id...
Dropping foreign key: test_case_components.component_id ->
components.id...
Updating column id in table components ...
Old: smallint auto_increment PRIMARY KEY NOT NULL
New: mediumint auto_increment PRIMARY KEY NOT NULL
Updating column component_id in table flaginclusions ...
Old: smallint
New: mediumint
Updating column component_id in table flagexclusions ...
Old: smallint
New: mediumint
Updating column component_id in table bugs ...
Old: smallint NOT NULL
New: mediumint NOT NULL
Updating column component_id in table component_cc ...
Old: smallint NOT NULL
New: mediumint NOT NULL

Checking Testopia setup ...
Done checking Testopia setup.

Adding foreign key: bugs.component_id -> components.id...
Adding foreign key: component_cc.component_id -> components.id...
Adding foreign key: email_bug_ignore.user_id -> profiles.userid...
Adding foreign key: email_bug_ignore.bug_id -> bugs.bug_id...
Adding foreign key: flagexclusions.component_id -> components.id...
Adding foreign key: flaginclusions.component_id -> components.id...
Adding foreign key: test_case_components.component_id ->
components.id...
DBD::mysql::db do failed: Cannot add foreign key constraint [for Statement "ALTER TABLE test_case_components ADD 
     CONSTRAINT fk_test_case_components_component_id_components_id FOREIGN KEY (component_id)
     REFERENCES components(id)
      ON UPDATE CASCADE ON DELETE CASCADE"] at Bugzilla/DB.pm line 636.
	Bugzilla::DB::bz_add_fks('Bugzilla::DB::Mysql=HASH(0x7fa3766a2b10)', 'test_case_components', 'HASH(0x7fa375eedda8)', 'HASH(0x7fa378095758)') called at Bugzilla/DB.pm line 543
	Bugzilla::DB::bz_setup_foreign_keys('Bugzilla::DB::Mysql=HASH(0x7fa3766a2b10)') called at Bugzilla/Install/DB.pm line 730
	Bugzilla::Install::DB::update_table_definitions('HASH(0x7fa3722da2e0)') called at checksetup.pl line 169



Expected results:

Succesful upgrade even when Testopia extension is present
(Reporter)

Updated

3 years ago
Component: Extensions → Integrations
Product: Bugzilla → Testopia
Version: 5.0 → 2.5

Updated

3 years ago
Assignee: extensions → gregaryh
Status: UNCONFIRMED → RESOLVED
Last Resolved: 3 years ago
Component: Integrations → General
QA Contact: default-qa
Resolution: --- → DUPLICATE
Duplicate of bug: 923865
You need to log in before you can comment on or make changes to this bug.