:hover not working if cursor moved directly from UI to element

VERIFIED WORKSFORME

Status

()

Core
Event Handling
--
trivial
VERIFIED WORKSFORME
17 years ago
16 years ago

People

(Reporter: Jonas Jørgensen, Assigned: joki (gone))

Tracking

Trunk
mozilla1.2alpha
x86
Windows 2000
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

17 years ago
When you hover over an element, the element doesn't get :hover status if the
element is touching the very top/bottom of the page and you moved the mouse
cursor directly from the statusbar/toolbar/whatever to the element without
moving over other page content.
(Reporter)

Comment 1

17 years ago
Created attachment 59840 [details]
testcase
(Reporter)

Comment 2

17 years ago
To reproduce:
* Open the testcase
* Scroll so that one of the links is touching the top or bottom of the page
* Move the mouse cursor from the statusbar/toolbar to the link

Comment 3

17 years ago
I can reproduce this on Windows build 2001112310 (0.9.6 stable).
(Assignee)

Updated

16 years ago
Target Milestone: --- → mozilla1.2

Updated

16 years ago
QA Contact: madhur → rakeshmishra

Comment 4

16 years ago
See also bug 20022 and bug 150069, at least the latter of which is probably related.
(Reporter)

Comment 5

16 years ago
This now works for me on both branch and trunk. Nick, can you still reproduce this?
(Reporter)

Comment 6

16 years ago
This problem appears to have gone away.
Status: NEW → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → WORKSFORME
(Reporter)

Comment 7

16 years ago
v.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.