Last Comment Bug 1128293 - TEST-UNEXPECTED-FAIL | xpcshell-icaljs.ini:calendar/test/unit/test_alarmservice.js | test_addItems - [test_addItems : 12] false == true
: TEST-UNEXPECTED-FAIL | xpcshell-icaljs.ini:calendar/test/unit/test_alarmservi...
Status: RESOLVED FIXED
:
Product: Calendar
Classification: Client Software
Component: Internal Components (show other bugs)
: Trunk
: All All
-- normal (vote)
: 4.0.0.1
Assigned To: Geoff Lankow (:darktrojan)
:
:
Mentors:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2015-02-01 09:08 PST by Philipp Kewisch [:Fallen]
Modified: 2015-02-04 09:42 PST (History)
2 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---


Attachments
1128293-1.diff (5.05 KB, patch)
2015-02-01 14:32 PST, Geoff Lankow (:darktrojan)
philipp: review+
Details | Diff | Splinter Review

Description User image Philipp Kewisch [:Fallen] 2015-02-01 09:08:27 PST
I believe this may be a regression from the timezone service changes. Geoff, can you take a look?
Comment 1 User image Treeherder Robot 2015-02-01 09:09:31 PST
log: https://treeherder.mozilla.org/logviewer.html#?repo=comm-central&job_id=8701
repository: comm-central
start_time: 2015-02-01T05:11:10
who: mozilla[at]kewis[dot]ch
machine: t-snow-r4-0163
buildname: TB Rev4 MacOSX Snow Leopard 10.6 comm-central opt test xpcshell
revision: 338986d73c02

TEST-UNEXPECTED-FAIL | xpcshell-icaljs.ini:calendar/test/unit/test_alarmservice.js | xpcshell return code: 0
TEST-UNEXPECTED-FAIL | xpcshell-icaljs.ini:calendar/test/unit/test_alarmservice.js | test_addItems - [test_addItems : 12] false == true
TypeError: aComponent is null" {file: "file:///builds/slave/talos-slave/test/build/application/Daily.app/Contents/Resources/extensions/%7Be2fda1a4-762b-4020-b5ad-a41df1933103%7D/components/calTimezoneService.js" line: 722}]"
Return code: 1
Comment 2 User image Treeherder Robot 2015-02-01 09:09:33 PST
log: https://treeherder.mozilla.org/logviewer.html#?repo=comm-central&job_id=8703
repository: comm-central
start_time: 2015-02-01T05:11:10
who: mozilla[at]kewis[dot]ch
machine: talos-mtnlion-r5-036
buildname: TB Rev5 MacOSX Mountain Lion 10.8 comm-central opt test xpcshell
revision: 338986d73c02

TEST-UNEXPECTED-FAIL | xpcshell-icaljs.ini:calendar/test/unit/test_alarmservice.js | xpcshell return code: 0
TEST-UNEXPECTED-FAIL | xpcshell-icaljs.ini:calendar/test/unit/test_alarmservice.js | test_addItems - [test_addItems : 12] false == true
TypeError: aComponent is null" {file: "file:///builds/slave/talos-slave/test/build/application/Daily.app/Contents/Resources/extensions/%7Be2fda1a4-762b-4020-b5ad-a41df1933103%7D/components/calTimezoneService.js" line: 722}]"
Return code: 1
Comment 3 User image Treeherder Robot 2015-02-01 09:09:34 PST
log: https://treeherder.mozilla.org/logviewer.html#?repo=comm-central&job_id=8692
repository: comm-central
start_time: 2015-02-01T04:15:18
who: mozilla[at]kewis[dot]ch
machine: tst-linux32-spot-106
buildname: Ubuntu VM 12.04 comm-central opt test xpcshell
revision: 338986d73c02

TEST-UNEXPECTED-FAIL | xpcshell-icaljs.ini:calendar/test/unit/test_alarmservice.js | xpcshell return code: 0
TEST-UNEXPECTED-FAIL | xpcshell-icaljs.ini:calendar/test/unit/test_alarmservice.js | test_addItems - [test_addItems : 12] false == true
TypeError: aComponent is null" {file: "file:///builds/slave/test/build/application/thunderbird/extensions/%7Be2fda1a4-762b-4020-b5ad-a41df1933103%7D/components/calTimezoneService.js" line: 722}]"
Return code: 1
Comment 4 User image Treeherder Robot 2015-02-01 09:09:35 PST
log: https://treeherder.mozilla.org/logviewer.html#?repo=comm-central&job_id=8689
repository: comm-central
start_time: 2015-02-01T04:12:00
who: mozilla[at]kewis[dot]ch
machine: tst-linux64-spot-032
buildname: Ubuntu VM 12.04 x64 comm-central opt test xpcshell
revision: 338986d73c02

TEST-UNEXPECTED-FAIL | xpcshell-icaljs.ini:calendar/test/unit/test_alarmservice.js | xpcshell return code: 0
TEST-UNEXPECTED-FAIL | xpcshell-icaljs.ini:calendar/test/unit/test_alarmservice.js | test_addItems - [test_addItems : 12] false == true
TypeError: aComponent is null" {file: "file:///builds/slave/test/build/application/thunderbird/extensions/%7Be2fda1a4-762b-4020-b5ad-a41df1933103%7D/components/calTimezoneService.js" line: 722}]"
Return code: 1
Comment 5 User image Philipp Kewisch [:Fallen] 2015-02-01 09:20:07 PST
Try run with bug 1095119 backed out, to rule it out as a suspect.

https://treeherder.mozilla.org/#/jobs?repo=try-comm-central&revision=608c2b7ae919
Comment 6 User image Philipp Kewisch [:Fallen] 2015-02-01 09:23:17 PST
Oh actually, this is probably bug 1128070 which you are already working on. Sorry about that, I was too quick on filing the bug.

*** This bug has been marked as a duplicate of bug 1128070 ***
Comment 7 User image Geoff Lankow (:darktrojan) 2015-02-01 14:30:38 PST
I don't think what I'm working on there would fix this. Not sure why it's only showing up sometimes, although it does involve asynchronous code.
Comment 8 User image Geoff Lankow (:darktrojan) 2015-02-01 14:32:10 PST
Created attachment 8557655 [details] [diff] [review]
1128293-1.diff

This ensures the timezone service is ready before running the test. Also removed some needless QI'ing I added in some other tests nearby.
Comment 9 User image Philipp Kewisch [:Fallen] 2015-02-01 14:34:01 PST
Comment on attachment 8557655 [details] [diff] [review]
1128293-1.diff

Review of attachment 8557655 [details] [diff] [review]:
-----------------------------------------------------------------

r=philipp
Comment 10 User image Philipp Kewisch [:Fallen] 2015-02-02 09:58:01 PST
I believe you pushed this as https://hg.mozilla.org/comm-central/rev/f0194350ebf3

Unfortunately there is still a bustage. If its the same issue but for a different test again, maybe we should figure out if there is a way to lazy-init the timezone service without breaking synchronous functions. If that doesn't work, then I should upload my patch for adding a do_init_calendar() function that does the full startup service initialization.
Comment 11 User image Treeherder Robot 2015-02-02 09:58:38 PST
log: https://treeherder.mozilla.org/logviewer.html#?repo=comm-central&job_id=8738
repository: comm-central
start_time: 2015-02-02T04:23:23
who: mozilla[at]kewis[dot]ch
machine: tst-linux32-spot-1048
buildname: Ubuntu VM 12.04 comm-central opt test xpcshell
revision: f0194350ebf3

TEST-UNEXPECTED-FAIL | xpcshell-icaljs.ini:calendar/test/unit/test_bug343792.js | xpcshell return code: -11
PROCESS-CRASH | xpcshell-icaljs.ini:calendar/test/unit/test_bug343792.js | application crashed [@ 0xb081d4da]
TEST-UNEXPECTED-FAIL | xpcshell-icaljs.ini:calendar/test/unit/test_datetime.js | xpcshell return code: -11
PROCESS-CRASH | xpcshell-icaljs.ini:calendar/test/unit/test_datetime.js | application crashed [@ 0xaf36d341]
Return code: 1
Comment 12 User image Treeherder Robot 2015-02-02 09:58:40 PST
log: https://treeherder.mozilla.org/logviewer.html#?repo=comm-central&job_id=8723
repository: comm-central
start_time: 2015-02-01T15:42:08
who: mozilla[at]kewis[dot]ch
machine: tst-linux32-spot-746
buildname: Ubuntu VM 12.04 comm-central opt test xpcshell
revision: f0194350ebf3

"comments": "Bug 1128293 - Fix TEST-UNEXPECTED-FAIL in test_alarmservice.js_ r=Fallen",
TEST-UNEXPECTED-FAIL | xpcshell-icaljs.ini:calendar/test/unit/test_bug343792.js | xpcshell return code: -11
PROCESS-CRASH | xpcshell-icaljs.ini:calendar/test/unit/test_bug343792.js | application crashed [@ 0xaf6684da]
TEST-UNEXPECTED-FAIL | xpcshell-icaljs.ini:calendar/test/unit/test_datetime.js | xpcshell return code: -11
PROCESS-CRASH | xpcshell-icaljs.ini:calendar/test/unit/test_datetime.js | application crashed [@ 0xaf337341]
Return code: 1
Comment 13 User image Treeherder Robot 2015-02-02 10:05:38 PST
log: https://treeherder.mozilla.org/logviewer.html#?repo=comm-central&job_id=8740
repository: comm-central
start_time: 2015-02-02T04:31:06
who: mozilla[at]kewis[dot]ch
machine: t-xp32-ix-022
buildname: TB Windows XP 32-bit comm-central opt test xpcshell
revision: f0194350ebf3

TEST-UNEXPECTED-FAIL | xpcshell-icaljs.ini:calendar/test/unit/test_bug343792.js | xpcshell return code: 1
PROCESS-CRASH | xpcshell-icaljs.ini:calendar/test/unit/test_bug343792.js | application crashed [@ 0x948034a]
TEST-UNEXPECTED-FAIL | xpcshell-icaljs.ini:calendar/test/unit/test_datetime.js | xpcshell return code: 1
PROCESS-CRASH | xpcshell-icaljs.ini:calendar/test/unit/test_datetime.js | application crashed [@ 0xb900341]
Return code: 1
Comment 14 User image Treeherder Robot 2015-02-02 10:05:39 PST
log: https://treeherder.mozilla.org/logviewer.html#?repo=comm-central&job_id=8729
repository: comm-central
start_time: 2015-02-01T15:50:04
who: mozilla[at]kewis[dot]ch
machine: t-w732-ix-121
buildname: TB Windows 7 32-bit comm-central debug test xpcshell
revision: f0194350ebf3

"comments": "Bug 1128293 - Fix TEST-UNEXPECTED-FAIL in test_alarmservice.js_ r=Fallen",
TEST-UNEXPECTED-FAIL | xpcshell-icaljs.ini:calendar/test/unit/test_datetime.js | xpcshell return code: 1
PROCESS-CRASH | xpcshell-icaljs.ini:calendar/test/unit/test_datetime.js | application crashed [@ 0x1f11195a]
Return code: 1
Comment 15 User image Treeherder Robot 2015-02-02 10:05:40 PST
log: https://treeherder.mozilla.org/logviewer.html#?repo=comm-central&job_id=8742
repository: comm-central
start_time: 2015-02-02T04:31:06
who: mozilla[at]kewis[dot]ch
machine: t-w732-ix-026
buildname: TB Windows 7 32-bit comm-central opt test xpcshell
revision: f0194350ebf3

TEST-UNEXPECTED-FAIL | xpcshell-icaljs.ini:calendar/test/unit/test_bug343792.js | xpcshell return code: 1
PROCESS-CRASH | xpcshell-icaljs.ini:calendar/test/unit/test_bug343792.js | application crashed [@ 0x14be95da]
TEST-UNEXPECTED-FAIL | xpcshell-icaljs.ini:calendar/test/unit/test_datetime.js | xpcshell return code: 1
PROCESS-CRASH | xpcshell-icaljs.ini:calendar/test/unit/test_datetime.js | application crashed [@ 0x150e2491]
Return code: 1
Comment 16 User image Treeherder Robot 2015-02-02 10:06:32 PST
log: https://treeherder.mozilla.org/logviewer.html#?repo=comm-central&job_id=8727
repository: comm-central
start_time: 2015-02-01T15:50:03
who: mozilla[at]kewis[dot]ch
machine: t-xp32-ix-161
buildname: TB Windows XP 32-bit comm-central debug test xpcshell
revision: f0194350ebf3

"comments": "Bug 1128293 - Fix TEST-UNEXPECTED-FAIL in test_alarmservice.js_ r=Fallen",
TEST-UNEXPECTED-FAIL | xpcshell-icaljs.ini:calendar/test/unit/test_datetime.js | xpcshell return code: 1
PROCESS-CRASH | xpcshell-icaljs.ini:calendar/test/unit/test_datetime.js | application crashed [@ 0xd33195a]
TEST-UNEXPECTED-FAIL | mail/base/test/unit/test_viewWrapper_imapFolder.js | xpcshell return code: 1
PROCESS-CRASH | mail/base/test/unit/test_viewWrapper_imapFolder.js | application crashed [@ nsWeakReference::Release()]
TEST-UNEXPECTED-FAIL | mailnews/imap/test/unit/test_saveTemplate.js | xpcshell return code: 1
PROCESS-CRASH | mailnews/imap/test/unit/test_saveTemplate.js | application crashed [@ nsWeakReference::Release()]
Return code: 1
Comment 17 User image Geoff Lankow (:darktrojan) 2015-02-02 14:21:38 PST
This is something different. Something's causing a crash (!), and in test_datetime.js we've already ensured the timezone service is ready. Hmmm...
Comment 18 User image Geoff Lankow (:darktrojan) 2015-02-02 14:53:33 PST
I'm going to call this fixed and deal with the crashing in bug 1128731.

Note You need to log in before you can comment on or make changes to this bug.