Closed Bug 1128295 Opened 5 years ago Closed 5 years ago

Firefox crash in mozilla::TrackBuffer::AppendData(mozilla::LargeDataBuffer*, __int64)

Categories

(Core :: Audio/Video, defect, critical)

38 Branch
All
Windows 7
defect
Not set
critical

Tracking

()

RESOLVED DUPLICATE of bug 1128179

People

(Reporter: marcia, Unassigned)

References

(Blocks 1 open bug)

Details

(Keywords: crash)

Crash Data

This bug was filed from the Socorro interface and is 
report bp-38e57593-05d2-415a-ba8a-e949f2150131.
=============================================================

Seen while looking at crash stats - small volume crash which is present on trunk. Crashes started showing up in the 2015012803 build and have continued until yesterday. Almost all urls are youtube.com

All reports here: http://bit.ly/1Cnt5dO


Frame 	Module 	Signature 	Source
0 	xul.dll 	mozilla::TrackBuffer::AppendData(mozilla::LargeDataBuffer*, __int64) 	dom/media/mediasource/TrackBuffer.cpp
1 	xul.dll 	mozilla::dom::SourceBuffer::AppendData(mozilla::LargeDataBuffer*, double) 	dom/media/mediasource/SourceBuffer.cpp
2 	xul.dll 	mozilla::dom::AppendDataRunnable::Run() 	dom/media/mediasource/SourceBuffer.cpp
3 	xul.dll 	nsThread::ProcessNextEvent(bool, bool*) 	xpcom/threads/nsThread.cpp
4 	xul.dll 	mozilla::ipc::MessagePump::Run(base::MessagePump::Delegate*) 	ipc/glue/MessagePump.cpp
5 	xul.dll 	mozilla::ipc::MessagePumpForChildProcess::Run(base::MessagePump::Delegate*) 	ipc/glue/MessagePump.cpp
6 	xul.dll 	MessageLoop::RunHandler() 	ipc/chromium/src/base/message_loop.cc
7 	xul.dll 	MessageLoop::Run() 	ipc/chromium/src/base/message_loop.cc
8 	xul.dll 	nsBaseAppShell::Run() 	widget/nsBaseAppShell.cpp
9 	xul.dll 	nsAppShell::Run() 	widget/windows/nsAppShell.cpp
10 	xul.dll 	XRE_RunAppShell 	toolkit/xre/nsEmbedFunctions.cpp
11 	xul.dll 	mozilla::ipc::MessagePumpForChildProcess::Run(base::MessagePump::Delegate*) 	ipc/glue/MessagePump.cpp
12 	xul.dll 	MessageLoop::RunHandler() 	ipc/chromium/src/base/message_loop.cc
13 	xul.dll 	MessageLoop::Run() 	ipc/chromium/src/base/message_loop.cc
14 	xul.dll 	XRE_InitChildProcess 	toolkit/xre/nsEmbedFunctions.cpp
15 	plugin-container.exe 	content_process_main(int, char** const) 	ipc/contentproc/plugin-container.cpp
16 	plugin-container.exe 	wmain 	toolkit/xre/nsWindowsWMain.cpp
17 	plugin-container.exe 	__tmainCRTStartup 	f:/dd/vctools/crt/crtw32/startup/crt0.c:255
18 	kernel32.dll 	BaseThreadInitThunk 	
19 	plugin-container.exe 	fast_error_exit 	f:/dd/vctools/crt/crtw32/startup/crt0.c:322
Status: NEW → RESOLVED
Closed: 5 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1128179
You need to log in before you can comment on or make changes to this bug.