Closed Bug 1128312 Opened 6 years ago Closed 6 years ago

Firefox can send my ISP's IP adress to websites even if I use a tunnel

Categories

(Firefox :: Untriaged, defect)

35 Branch
x86_64
Linux
defect
Not set
normal

Tracking

()

RESOLVED DUPLICATE of bug 959893

People

(Reporter: georgeskesseler, Unassigned)

Details

User Agent: Mozilla/5.0 (X11; Linux x86_64; rv:35.0) Gecko/20100101 Firefox/35.0
Build ID: 20150108202552

Steps to reproduce:

I read heise news http://heise.de/-2534438


Actual results:

I clicked on https://diafygi.github.io/webrtc-ips/ and it showed my ISP's address despite me tunneling my requests through a ssh tunnel and remote squid proxy


Expected results:

no home adresses should be listed. I consider this a violation of my privacy.
Status: UNCONFIRMED → RESOLVED
Closed: 6 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 959893
You need to log in before you can comment on or make changes to this bug.