Undo after pasting MSWord-text inside a list item, removes more than what was pasted

RESOLVED DUPLICATE of bug 1235454

Status

Thunderbird
Message Compose Window
RESOLVED DUPLICATE of bug 1235454
3 years ago
11 months ago

People

(Reporter: Joris Debonnet, Unassigned)

Tracking

31 Branch
x86_64
Windows 7

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [dupme])

(Reporter)

Description

3 years ago
User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:35.0) Gecko/20100101 Firefox/35.0
Build ID: 20150122214805

Steps to reproduce:

1. Compose a new message
2. Type "This is a list item"
3. Make the current line into a list item
4. Copy some text from an MS Word document
5. Paste it at the end of the list item in the compose window
6. Press "Undo"


Actual results:

The entire list item is removed, including all text that was typed before pasting (even if you wrote half a book). It can't be recovered in any way (there is no "Redo", and any additional Undo's don't do anything). 


Expected results:

Only the pasted text should have been removed.
(Reporter)

Comment 1

3 years ago
The easiest fix might be to circumvent it by defaulting to plain-text-pasting any clipboard contents that come from Word, or at least cleaning the HTML up.

Updated

2 years ago
Whiteboard: [dupme]

Comment 2

11 months ago
dup of bug 1235454?
Flags: needinfo?(jsabash)

Comment 3

11 months ago
Sounds like a dup to me. However those that compose regularly would not depend on uno for anything reliable to happen. They would edit the html with an extension or other means. I wouldn't think any real changes to the undo function would be forthcoming any time soon
Flags: needinfo?(jsabash)

Updated

11 months ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 11 months ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1235454
You need to log in before you can comment on or make changes to this bug.