[FFOS7715 v2.1][Gaia_System_WindowMgmt] after monkey test, could not back to homescreen.

RESOLVED WONTFIX

Status

Firefox OS
Gaia::System::Window Mgmt
RESOLVED WONTFIX
3 years ago
4 months ago

People

(Reporter: ben.song, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

3 years ago
Reproduce step:

1.phone start with 12 hours monkey test.

Ideal result:

Phone stay at Contacts or other apps, couldn't back to homescreen.

Actual result:

Phone could back to homescreen.

Reproduce rate: 2/9
(Reporter)

Comment 1

3 years ago
Dear Alive,Luke,

After analysis the problem, I find the origin of this problem is activityWindow load at wrong parent appWindow.

I could reproduce it manually,reproduce step as below:

1.Open Messages app, and open new message window.

2.Click home button and during backing to homescreen we click select contact button to open Contacts activityWindow.

3.After Contacts activityWindow opened, click new contact button to open Add contact window quickly.

4.In this window,click Add Picture button to open Gallery activityWindow.

5.Now click home button to back to homescreen.You would find phone could not back to homescreen.

Thanks.
blocking-b2g: --- → 2.1S?
Flags: needinfo?(vchen)
Flags: needinfo?(sku)
Flags: needinfo?(lchang)
Flags: needinfo?(alive)
(In reply to ben.song from comment #1)
> Dear Alive,Luke,
> 
> After analysis the problem, I find the origin of this problem is
> activityWindow load at wrong parent appWindow.
> 
> I could reproduce it manually,reproduce step as below:
> 
> 1.Open Messages app, and open new message window.
> 
> 2.Click home button and during backing to homescreen we click select contact
> button to open Contacts activityWindow.
> 
> 3.After Contacts activityWindow opened, click new contact button to open Add
> contact window quickly.

How can you new contact while pick contact?
Flags: needinfo?(alive)
Hi Ben Song -

Could you record a video for this issue to clarify things out?
Flags: needinfo?(vchen) → needinfo?(ben.song)
(Reporter)

Comment 4

3 years ago
(In reply to Alive Kuo [:alive][NEEDINFO!] from comment #2)
> (In reply to ben.song from comment #1)
> > Dear Alive,Luke,
> > 
> > After analysis the problem, I find the origin of this problem is
> > activityWindow load at wrong parent appWindow.
> > 
> > I could reproduce it manually,reproduce step as below:
> > 
> > 1.Open Messages app, and open new message window.
> > 
> > 2.Click home button and during backing to homescreen we click select contact
> > button to open Contacts activityWindow.
> > 
> > 3.After Contacts activityWindow opened, click new contact button to open Add
> > contact window quickly.
> 
> How can you new contact while pick contact?

Dear Alive,

For during the step of picking contact, the buttons of Contacts activityWindow would change from new contact button and setting button to back button. So we have a little rate to new contact.

Thanks.
Flags: needinfo?(ben.song)
(Reporter)

Comment 5

3 years ago
(In reply to Vance Chen [:vchen][vchen@mozilla.com] from comment #3)
> Hi Ben Song -
> 
> Could you record a video for this issue to clarify things out?

Dear Vance,

For the reproduce manually is difficult, I'm afraid I couldn't apply a video for it, it need twice or more quick-click.

Thanks.
(In reply to ben.song from comment #4)
> (In reply to Alive Kuo [:alive][NEEDINFO!] from comment #2)
> > How can you new contact while pick contact?
> 
> For during the step of picking contact, the buttons of Contacts
> activityWindow would change from new contact button and setting button to
> back button. So we have a little rate to new contact.

On v2.1/flame, I can't see the "add" button in the activity window even in a short period.

Therefore, I remove some code in contact app [1] so that I can see the button then. However, I still can't reproduce this issue.

[1] https://github.com/mozilla-b2g/gaia/blob/v2.1/apps/communications/contacts/js/activities.js#L102-L103
Flags: needinfo?(lchang)
(Reporter)

Comment 7

3 years ago
(In reply to Luke Chang [:lchang] from comment #6)
> (In reply to ben.song from comment #4)
> > (In reply to Alive Kuo [:alive][NEEDINFO!] from comment #2)
> > > How can you new contact while pick contact?
> > 
> > For during the step of picking contact, the buttons of Contacts
> > activityWindow would change from new contact button and setting button to
> > back button. So we have a little rate to new contact.
> 
> On v2.1/flame, I can't see the "add" button in the activity window even in a
> short period.
> 
> Therefore, I remove some code in contact app [1] so that I can see the
> button then. However, I still can't reproduce this issue.
> 
> [1]
> https://github.com/mozilla-b2g/gaia/blob/v2.1/apps/communications/contacts/
> js/activities.js#L102-L103

Dear Luke, Alive,

I have checked the code, and I find the problem be brought by removing switch animation in sprd. I would analysis why did it appears.

If I have any questions I would need your help.Thanks a lot.
Flags: needinfo?(sku)
Hi Song Ben -

Since in order to enhance the performance, SPRD did lots of the modification. I would suggest next time if you run into any window management issues, you can benchmark with Flame 2.1 first, maybe that can help us to identify problem more quickly?

Thanks
Flags: needinfo?(ben.song)
(Reporter)

Comment 9

3 years ago
(In reply to Vance Chen [:vchen][vchen@mozilla.com] from comment #8)
> Hi Song Ben -
> 
> Since in order to enhance the performance, SPRD did lots of the
> modification. I would suggest next time if you run into any window
> management issues, you can benchmark with Flame 2.1 first, maybe that can
> help us to identify problem more quickly?
> 
> Thanks

Dear Vance,

OK, I would do it next time, thanks.
Flags: needinfo?(ben.song)
remove the blocking nomination since this one is caused by partner's own patch
blocking-b2g: 2.1S? → ---

Comment 11

4 months ago
Firefox OS is not being worked on
Status: NEW → RESOLVED
Last Resolved: 4 months ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.