Closed Bug 1128497 Opened 5 years ago Closed 5 years ago

[Tablet] No scroll bar in portrait mode in Tab Panel

Categories

(Firefox for Android :: General, defect)

All
Android
defect
Not set

Tracking

()

VERIFIED FIXED
Firefox 38
Tracking Status
firefox38 --- verified

People

(Reporter: u421692, Assigned: mhaigh)

References

Details

Attachments

(1 file)

1. Open lots of tabs(more tabs open than will fit on a single screen)
2. Tap on tab number to open Tab Panel
3. Put tablet in portrait mode and scroll tab thumbnails

Expected result:
Tabs are easily scrolled, and scroll bar is present in the right side of the Tab panel

Actual result:
Scroll bar is not present in the right side of the Tab panel

Note: 
*Scroll bar available in landscape mode.
*I believe that this is not a regression, and was never implemented ok since new tablet UI.
*Needs to be addressed in the new-tablet-v1?
Curious - any ideas, Martyn?
Assignee: nobody → mhaigh
Flags: needinfo?(mhaigh)
Flags: needinfo?(mhaigh)
Attachment #8561494 - Flags: review?(michael.l.comella)
Comment on attachment 8561494 [details] [diff] [review]
Bug 1128497 - [Tablet] No scroll bar in portrait mode in Tab Panel

Review of attachment 8561494 [details] [diff] [review]:
-----------------------------------------------------------------

If this works, then it works for me.

However, edification question: how does the style inheritance work here? Does TabsGridLayout inherit both TabsLayout and TabsGridLayout (via R.attr.tabsGridLayoutViewStyle in the constructor)? I would assume TabsLayout is overridden by explicitly defining R.attr.tabsGridLayoutViewStyle, but if this patch works, then I guess not.
Attachment #8561494 - Flags: review?(michael.l.comella) → review+
> However, edification question: how does the style inheritance work here?
> Does TabsGridLayout inherit both TabsLayout and TabsGridLayout (via
> R.attr.tabsGridLayoutViewStyle in the constructor)? I would assume
> TabsLayout is overridden by explicitly defining
> R.attr.tabsGridLayoutViewStyle, but if this patch works, then I guess not.

I would assume that TabsGridLayout does inherit both styles (one through the tabs_panel_default.xml / private_tabs_panel.xml file and one through the argument in the constructor that you pointed out) and that these combine, although I don't know off the top of my head which takes priority.
https://hg.mozilla.org/mozilla-central/rev/0c61e565d418
Status: NEW → RESOLVED
Closed: 5 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 38
Keywords: verifyme
Verified as fixed on latest Nightly on Sony Xperia Z2(Android 4.4.4), and Nexus 7(Android 5.0.2)
Status: RESOLVED → VERIFIED
Keywords: verifyme
You need to log in before you can comment on or make changes to this bug.