keyboard loses focus and gets hidden when typing character into rocketbar/searchbar after using backspace key

RESOLVED DUPLICATE of bug 1129344

Status

RESOLVED DUPLICATE of bug 1129344
4 years ago
4 years ago

People

(Reporter: aryx, Assigned: daleharvey)

Tracking

({regression})

unspecified
ARM
Gonk (Firefox OS)
regression

Firefox Tracking Flags

(b2g-v2.2 unaffected, b2g-master affected)

Details

(Whiteboard: [systemsfe])

B2G 3.0.0.0-prerelease 20150201160230 on Flame (v188 base image)

The keyboard loses focus and gets hidden when typing a character into the rocketbar/searchbar after using the backspace key.

Steps to reproduce:
1. Tap on global search bar.
2. Type 'c'.
3. Tap backspace key.
4. Type 'c'.
Actual result:
Keyboard gets hidden.
Expected result:
Keyboard remains open

Further information: Tapping the 'x' button to empty the searchbar doesn't have the effect.
Flags: needinfo?(nhirata.bugzilla)
Component: Gaia::System::Browser Chrome → Gaia::Search
[Blocking Requested - why for this release]: Usability issue/Regression.

Probably a regression from the recent changes to e.me?
Dale, could you take a look please?  or direct it to the appropriate person?
blocking-b2g: --- → 3.0?
status-b2g-v2.2: --- → unaffected
status-b2g-master: --- → affected
Flags: needinfo?(nhirata.bugzilla) → needinfo?(dale)
(Assignee)

Comment 2

4 years ago
Yeh have noticed this, shouldnt be caused by any e.me changes but will take a look
Assignee: nobody → dale
Flags: needinfo?(dale)
Hrm, maybe something else on master.

Note : I tested on 3.0 (latest) and 2.2 (latest):
Build ID               20150204002509
Gaia Revision          a4c4cc86303a554facb8f45b7e764e5c4473c3de
Gaia Date              2015-02-04 00:41:59
Gecko Revision         https://hg.mozilla.org/releases/mozilla-b2g37_v2_2/rev/8669c26fd4a5
Gecko Version          37.0a2
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150204.035929
Firmware Date          Wed Feb  4 03:59:40 EST 2015
Bootloader             L1TC000118D0
Whiteboard: [systemsfe]
(Assignee)

Comment 4

4 years ago
I vaguely remember this being a problem before since a click went through the keyboard and hit something on the search app behind it

Tim I am looking into the search app to see if anything could be stealing focus, but do you know of any keyboard issues that may cause this?
Flags: needinfo?(timdream)
(Assignee)

Comment 5

4 years ago
So if the search app does nothing at all, this still happens. I remember someone putting a .focus() conditional around somewhere, this bug happens when you enter the first characters in the rocketbar, during that time the search app gets displayed so I think when we show the search window it is getting a .focus called somewhere
(Assignee)

Comment 6

4 years ago
If I remove the |this.results.classList.remove('hidden');| from https://github.com/mozilla-b2g/gaia/blob/master/apps/system/js/rocketbar.js#L365. Then this issue goes away. Switching needinfo from Tim to Alive since it looks like its a window management issue.

If this isnt on 2.2, then it seems like its possibly a gecko issue?
Flags: needinfo?(timdream) → needinfo?(alive)
This would be a dup of bug 1129344 if it only happens on Rocket bar.
(Assignee)

Comment 8

4 years ago
Yeh that has the same reproduction steps as I was investigating
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Flags: needinfo?(alive)
Resolution: --- → DUPLICATE
Duplicate of bug: 1129344
blocking-b2g: 3.0? → ---
You need to log in before you can comment on or make changes to this bug.