Link Text field in link properties does not allow for editing

VERIFIED INVALID

Status

SeaMonkey
Composer
--
minor
VERIFIED INVALID
17 years ago
14 years ago

People

(Reporter: TucsonTester1, Assigned: Charles Manske)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

17 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Macintosh; U; PPC Mac OS X; en-US; rv:0.9.6+)
Gecko/20011126 Netscape6/6.1b1
BuildID:    2001112608

In the Link Properties window, the field named Link text is not acting,
therefore not allowing the text (or the name of the link) to be edited except
for manually in the Composer Window.

Reproducible: Always
Steps to Reproduce:
1.Open Navigator
2.Open Composer
3.Type some text
4.Highlight that text
5.Click on Link Button
6.Use the Link Properties to create that highlighted text into a link.
7.Click on Ok
8.Save file
9.Double click on the underlined link.


Actual Results:  The Link Text field is a greyed out field, not allowing for
editing in the Link Properties Window.

Expected Results:  I expect to be able to edit the text of the link in the Link
Properties window.

Comment 1

17 years ago
WorksForMe using Fizzilla/2001113008, although since 0.9.6 I've noticed linked text has no 
color or underline.

Comment 2

17 years ago
Tucson/Michael, please verify if this is still happening..if so mark it
RESOLVED-WFM.
(Reporter)

Comment 3

17 years ago
on the 2001113008 build for Mac OS X, when you create a link and go into Link
Properties, the Link Text Field (ie where the link name is, no the actual url
location (the field I am referring to in the Mac build is labeled Link Text and
is the topmost box in the window) still is greyed out. It is using the text
entered when you created the link, not allowing for modifications unless you
simply backspace and retype the link in Composer. This is a simple workaround,
but I think the properties screen should also have an option to do that as well.
(Reporter)

Comment 4

17 years ago
This is still happening on build 2001120308.

Comment 5

17 years ago
Confirming on build 2001120708 I am seeing the same issue on Win 2k using build
2001120703.  

I am confirming this bug and switching the Platform and OS to all.
Status: UNCONFIRMED → NEW
Ever confirmed: true
OS: MacOS X → All
Hardware: Macintosh → All

Comment 6

17 years ago
Over to charles
Assignee: syd → cmanske
(Assignee)

Comment 7

17 years ago
Definitely not! The link text is shown in the dialog just as a convenience.
The text in the document is HTML and can have all kinds of inline style associated
with it. There's no need to support editing it in the dialog, you can edit it in
the page directly.
Status: NEW → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → INVALID

Comment 8

17 years ago
Verified.
Status: RESOLVED → VERIFIED
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.