Closed Bug 11288 Opened 21 years ago Closed 21 years ago

Nested blockquote with assigned display: inline is not working

Categories

(Core :: DOM: HTML Parser, defect, P3)

All
Windows 95
defect

Tracking

()

VERIFIED WONTFIX

People

(Reporter: christinehoff4, Assigned: rickg)

Details

Attachments

(1 file)

Using 8/2 Apprunner on Win 95, Win NT, Win 98, Mac8.5 and Linux.

Open attached test case.

Expected result: Text in the nested blockquote with a 'display: inline' value
should continue inline in the paragraph.

Actual result: There is a line break before the blockquote and a large space
after the blockquote
Assignee: peterl → rickg
Component: Style System → Parser
The problem is that the paragraph is not containing the blockquote (I'm not sure
that it should, I don't think so). The trailing space is caused (correctly) by
the margins asigned to the blockquote in ua.css.
QA Contact: chrisd → janc
Status: NEW → RESOLVED
Closed: 21 years ago
Resolution: --- → WONTFIX
<P> doesn't contain <BLOCKQUOTE> and we appear to behave like IE and Nav.
(Although we do something interesting with margins.)
Status: RESOLVED → VERIFIED
that's correct -- a BLOCKQUOTE within a P element is illegal HTML. Marking
verified.
Oops! How soon one forgets their HTML principles.....
You need to log in before you can comment on or make changes to this bug.