[RTL][Camera] When attaching image from Camera only half of the image is shown in image preview while using RTL language

VERIFIED FIXED in 2.2 S6 (20feb)

Status

defect
P1
normal
VERIFIED FIXED
5 years ago
4 years ago

People

(Reporter: bzumwalt, Assigned: dmarcos)

Tracking

unspecified
2.2 S6 (20feb)
ARM
Gonk (Firefox OS)
Dependency tree / graph
Bug Flags:
in-moztrap +

Firefox Tracking Flags

(blocking-b2g:2.2+, feature-b2g:2.2+, b2g-v2.2 verified, b2g-master verified)

Details

()

Attachments

(6 attachments)

Posted image Screenshot
Description:
When attaching image from Camera in Email, Messages, or Contacts apps, the image preview only shows half of the image. Only the right half of the image is shown, with the left half off of the screen. Where the right half of the image should be positioned, the screen is black. The image itself is taken correctly, and will send correctly if accepted, it is only the image preview that is affected.

Repro Steps:
1) Update a Flame to 20150203055641
2) Launch Messages app
3) Create new message thread and tap attach icon
4) Select Camera from list
5) Take picture

Actual:
The left half of the image is off the screen and only the right half of the image is visible in the image preview after taking picture.

Expected:
The entire picture is visible in image preview.

Environmental Variables:
Device: Flame 3.0
Build ID: 20150203055641
Gaia: ae5a1580da948c3b9f93528146b007fc4f6a712b
Gecko: ae5d04409cd9
Gonk: e7c90613521145db090dd24147afd5ceb5703190
Version: 38.0a1 (3.0)
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:38.0) Gecko/38.0 Firefox/38.0

Repro frequency: 3/3, 100%
See attached: screenshot & logcat
Posted file Logcat
Corrected steps to reproduce:

Steps must be performed while language is set to Arabic.

Repro Steps:
1) Update a Flame to 20150203055641
2) Set language to Arabic
3) Launch Messages app
4) Create new message thread and tap attach icon
5) Select Camera from list
6) Take picture


Video of issue: http://youtu.be/3GIqbafrkKY


Issue DOES reproduce on Flame 2.2

The left half of the image is off the screen and only the right half of the image is visible in the image preview after taking picture.

Device: Flame 2.2
Build ID: 20150203002504
Gaia: cd62ff9fe199fb43920ba27bd5fdbc5c311016fc
Gecko: 11d93135c678
Gonk: e7c90613521145db090dd24147afd5ceb5703190
Version: 37.0a2 (2.2)
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:37.0) Gecko/37.0 Firefox/37.0
QA Whiteboard: [QAnalyst-Triage?][rtl-impact]
Flags: needinfo?(ktucker)
Nominating this 2.2? since the user can only see half of the picture preview.
blocking-b2g: --- → 2.2?
QA Whiteboard: [QAnalyst-Triage?][rtl-impact] → [QAnalyst-Triage+][rtl-impact]
Flags: needinfo?(ktucker)
Blocking Reason: Preview is messed up with only partial image seen.

Diego, please fix this! Assigning to you.

Thanks
Hema
Assignee: nobody → dmarcos
blocking-b2g: 2.2? → 2.2+
Target Milestone: --- → 2.2 S6 (20feb)
feature-b2g: --- → 2.2+
Priority: -- → P1
Posted file Pull Request
.confirm-media-frame > img style in confirm.css is outdated since MediaFrame doesn't use an img element anymore (change made in bug 1068986). It now uses a background-image to display photos. The style above is not applied and the global rule "direction: rtl" is inherited making the positioning calculations of MediaFrame incorrect (done in setPosition in media_frame.js)
Attachment #8562893 - Flags: review?(dflanagan)
Attachment #8562893 - Flags: feedback?(bzumwalt)
Comment on attachment 8562893 [details] [review]
Pull Request

r+ Please request uplift for this as well.

Punam fixed this issue for the camera preview gallery in bug 1087058, but missed this confirm case.
Attachment #8562893 - Flags: review?(dflanagan) → review+
Actually, I just noticed that you only have a PR to fix this on 2.2. It also needs to be fixed on master, doesn't it?
Same patch applies on master
Comment on attachment 8562893 [details] [review]
Pull Request

Patch works great. On today's unmodified Flame 2.2 and 3.0 the issue still occurs, but when your gaia change is applied (manually applied to gaia repo before you landed) the issue no longer reproduces.

When taking a picture from camera to attach to MMS, the preview is centered and no part is cut off while language is set to Arabic.

Device: Flame 2.2
Build ID: 20150211002505
Gaia: ca726d8f4136596adce98ae5dd2498389c3823cf
Gecko: e614443583e7
Version: 37.0a2 (2.2)
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:37.0) Gecko/37.0 Firefox/37.0

Device: Flame 3.0
Build ID: 20150211010216
Gaia: 30b7c18fc00e55485d0beef01a6f08d0042c89a5
Gecko: ee093ca70666
Version: 38.0a1 (3.0)
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:38.0) Gecko/38.0 Firefox/38.0
Flags: needinfo?(ktucker)
Attachment #8562893 - Flags: feedback?(bzumwalt)
QA Whiteboard: [QAnalyst-Triage+][rtl-impact] → [QAnalyst-Triage?][rtl-impact]
Per the Landing Policy, all patches require approval to land on v2.2. Why wasn't it followed here?
https://wiki.mozilla.org/Release_Management/B2G_Landing#Landing_Procedure_6
Status: NEW → RESOLVED
Closed: 5 years ago
Flags: needinfo?(dmarcos)
Flags: needinfo?(bbajaj)
Resolution: --- → FIXED
It's a P1 2.2+ blocker that is one line CSS change so I assumed it was ok. The changed was requested by Hema Koka, reviewed by David Flanagan and confirmed that fixed the issue by QA.
Flags: needinfo?(dmarcos)
QA Whiteboard: [QAnalyst-Triage?][rtl-impact] → [QAnalyst-Triage+][rtl-impact]
Flags: needinfo?(ktucker)
(In reply to Diego Marcos [:dmarcos] from comment #16)
> It's a P1 2.2+ blocker that is one line CSS change so I assumed it was ok.
> The changed was requested by Hema Koka, reviewed by David Flanagan and
> confirmed that fixed the issue by QA.

Nevertheless, should have gone through approval.
Flags: needinfo?(bbajaj)
This issue has been verified successfully on Flame 2.2/3.0.
Reproduce rate:0/5.
Attachment:Verify_RTL_Camera.png

Flame 3.0 build:

Build ID               20150214010227
Gaia Revision          f0b93e0668ef9565bd6f050b15b4f794d59feb65
Gaia Date              2015-02-13 13:13:27
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/a7c177546ca0
Gecko Version          38.0a1
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150214.043959
Firmware Date          Sat Feb 14 04:40:10 EST 2015
Bootloader             L1TC000118D0


Flame 2.2:

Build ID               20150214002504
Gaia Revision          ea64caf6d4ab03fc4472eca9f41f20d651d55fa9
Gaia Date              2015-02-13 05:27:43
Gecko Revision         https://hg.mozilla.org/releases/mozilla-b2g37_v2_2/rev/6de30e6bbc84
Gecko Version          37.0a2
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150214.044811
Firmware Date          Sat Feb 14 04:48:22 EST 2015
Bootloader             L1TC000118D0
Status: RESOLVED → VERIFIED
QA Whiteboard: [QAnalyst-Triage+][rtl-impact] → [QAnalyst-Triage+][rtl-impact], [MGSEI-Triage+]
Test case has been added in moztrap:

https://moztrap.mozilla.org/manage/case/15923/
Flags: in-moztrap+
You need to log in before you can comment on or make changes to this bug.