Last Comment Bug 1129094 - [Error: ics-service doesn't recognize own tzid: floating] [TypeError: aComponent is null] in calTimezoneService.js
: [Error: ics-service doesn't recognize own tzid: floating] [TypeError: aCompon...
Status: RESOLVED FIXED
:
Product: Calendar
Classification: Client Software
Component: Internal Components (show other bugs)
: Lightning 4.0.0.1
: x86_64 Windows 7
-- normal (vote)
: 4.0.0.1
Assigned To: Geoff Lankow (:darktrojan)
:
:
Mentors:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2015-02-03 12:00 PST by Stefan Sitter
Modified: 2015-02-08 19:25 PST (History)
2 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---


Attachments
1129094-1.diff (1.06 KB, patch)
2015-02-04 15:04 PST, Geoff Lankow (:darktrojan)
philipp: review+
Details | Diff | Splinter Review
1129094-2.diff (4.54 KB, patch)
2015-02-04 16:59 PST, Geoff Lankow (:darktrojan)
philipp: review+
Details | Diff | Splinter Review

Description User image Stefan Sitter 2015-02-03 12:00:03 PST
Lightning 4.0a1 (Build ID 20150203030316) with Mozilla/5.0 (Windows NT 6.1; WOW64; rv:38.0) Gecko/20100101 Thunderbird/38.0a1

Steps to reproduce:
1) create new Thunderbird profile
2) install Lightning extension
3) restart Thunderbird and check error console

Console shows:
Error: ics-service doesn't recognize own tzid: floating
TypeError: aComponent is null
Source File: file:///[...]/components/calTimezoneService.js
Line: 722
Comment 1 User image Geoff Lankow (:darktrojan) 2015-02-04 14:15:08 PST
Related question: why are we even getting to line 722? We must be failing to get the information from the registry.
Comment 2 User image Geoff Lankow (:darktrojan) 2015-02-04 15:04:02 PST
Created attachment 8559439 [details] [diff] [review]
1129094-1.diff

Turns out the timezoneIds enumerator shouldn't have UTC and floating in it:
https://hg.mozilla.org/comm-central/file/61dd7dc61dc4/calendar/base/src/calTimezoneService.js#l279
Comment 3 User image Geoff Lankow (:darktrojan) 2015-02-04 16:59:02 PST
Created attachment 8559516 [details] [diff] [review]
1129094-2.diff

Windows stopped using localized strings in this part of the registry in Vista. Fortunately they also added a new value with exactly the information we want.
Comment 4 User image Philipp Kewisch [:Fallen] 2015-02-08 06:00:43 PST
Comment on attachment 8559516 [details] [diff] [review]
1129094-2.diff

Review of attachment 8559516 [details] [diff] [review]:
-----------------------------------------------------------------

I will be holding my hand in front of my eyes with that timezone guessing code. I wish we could just use libicu's timezone detection, which even gives us an olson name cross platform. Maybe we need to provide access to that in core.

Note You need to log in before you can comment on or make changes to this bug.