Status

Marketing
Design
RESOLVED FIXED
3 years ago
3 years ago

People

(Reporter: sandra, Assigned: Sean Martell)

Tracking

Details

Attachments

(2 attachments)

(Reporter)

Description

3 years ago
Print each of the GDC booth panel designs (4 of the colorful panels) on front of the card, with url https://games.mozilla.org on back of the card.

Need high res jpegs of four panel art.

Considering using moo.com (rounded corners business cards in gloss laminate) to print (fast, economical, high quality)
(Reporter)

Comment 1

3 years ago
Created attachment 8559909 [details]
Screen Shot 2015-02-05 at 9.18.23 AM.png

one of each panel. mocked up by non creative me in moo.com

Updated

3 years ago
Assignee: jbalaco → smartell

Updated

3 years ago
Status: NEW → ASSIGNED
(Reporter)

Comment 2

3 years ago
standard business card size 3.5" X 2"
(Assignee)

Comment 3

3 years ago
Finishing these up today, do you want 4 different cards or all the panel art on one card design?

Thanks!
Flags: needinfo?(spersing)
(Reporter)

Comment 4

3 years ago
Thanks Sean - 4 different cards.
Could we also add "press@mozilla.com" (this was discussed at the 8am GDC PR training meeting).
Thank you
Sandra
Flags: needinfo?(spersing)
(Assignee)

Comment 5

3 years ago
http://cl.ly/image/3w1h0j0f0q3N

How do you need these saved out for Moo? 8 individual files? 300dpi JPG? Png?

Thanks.
Flags: needinfo?(spersing)
(Reporter)

Comment 6

3 years ago
Thanks Sean.
Just a couple of questions seeing the design now:
1) Was it decided not to include the "Get Involved" information from the landing page? 
And this info was dependent on this bug thread being confirmed with information: https://bugzilla.mozilla.org/show_bug.cgi?id=1122671

irc - irc://irc.mozilla.org:6697/games
twitter - https://twitter.com/hashtag/GDC15%20Mozilla
github - https://github.com/mozilla/
mdn - https://developer.mozilla.org/en-US/docs/Games

2) I am informed that the landing page must have: https://games.mozilla.org

And to answer your question - 8 individual files please as 300dpi JPGs.

Thank you
Sandra
Flags: needinfo?(spersing) → needinfo?(smartell)

Comment 7

3 years ago
(In reply to spersing from comment #6)
> Thanks Sean.
> Just a couple of questions seeing the design now:
> 1) Was it decided not to include the "Get Involved" information from the
> landing page? 
> And this info was dependent on this bug thread being confirmed with
> information: https://bugzilla.mozilla.org/show_bug.cgi?id=1122671
> 
> irc - irc://irc.mozilla.org:6697/games
> twitter - https://twitter.com/hashtag/GDC15%20Mozilla
> github - https://github.com/mozilla/
> mdn - https://developer.mozilla.org/en-US/docs/Games

I really think that's going to make the card very busy. And that information is all on the website, which we're pointing them to.


> 2) I am informed that the landing page must have: https://games.mozilla.org

Are you specifically asking for the "https://" to be added? I don't think we can reasonably expect someone to type that in. It's also our style not to include it on printed materials.
(Reporter)

Comment 8

3 years ago
Thanks Matej!
"I really think that's going to make the card very busy. And that information is all on the website, which we're pointing them to."

The purpose of the CTA cards is to drive traffic to the URL. 
Then, the CTA cards should still have a phrase that asks the recipient to "Check out more" or "View Demos" or something (I look to you for the best phrase) that drives them to the games.mozilla.org site.
Can we add one more like prior to the URL to explicitly state this call to action?
Thank you
Sandra
Flags: needinfo?(matej)

Comment 9

3 years ago
what happens if I type games.mozilla.org into the URL without the https://?  Does it auto redirect to https:// or does it try to go to http:// and fail?
(In reply to spersing from comment #8)
> Thanks Matej!
> "I really think that's going to make the card very busy. And that
> information is all on the website, which we're pointing them to."
> 
> The purpose of the CTA cards is to drive traffic to the URL. 
> Then, the CTA cards should still have a phrase that asks the recipient to
> "Check out more" or "View Demos" or something (I look to you for the best
> phrase) that drives them to the games.mozilla.org site.
> Can we add one more like prior to the URL to explicitly state this call to
> action?

We can add it, I just wish we had clear direction on exactly what needed to be on these cards from the beginning.

I can come up with the right words, but it depends on why you want someone to visit the site. Is it specifically to check out the demos, with the hopes that they'll find other info if they're looking for it? Or should it be more of a general "learn more" type of message?

Do we still need the press email as well? If so, it could be something like this:

See the demos: games.mozilla.org

Get in touch: press@mozilla.com

I feel like the added CTA language is unnecessary here as presumably anyone who gets one of these cards would have interacted with someone at the booth. The card should just be a reminder of the URL (and potentially email address), but we shouldn't be relying on it to drive someone there on its own.
Flags: needinfo?(matej)
(In reply to Martin Best (:mbest) from comment #9)
> what happens if I type games.mozilla.org into the URL without the https://? 
> Does it auto redirect to https:// or does it try to go to http:// and fail?

I think that's a question for Jen B.

Jen, can you advise or point Martin in the right direction?
Flags: needinfo?(jbertsch)
(In reply to Matej Novak [:matej] from comment #11)
> (In reply to Martin Best (:mbest) from comment #9)
> > what happens if I type games.mozilla.org into the URL without the https://? 
> > Does it auto redirect to https:// or does it try to go to http:// and fail?
> 
> I think that's a question for Jen B.
> 
> Jen, can you advise or point Martin in the right direction?

Cvan should ask IT in the bug where he asked them to set up the gaming subdomain.  Sorry - I can't easily find the link right now.
Flags: needinfo?(jbertsch)
(In reply to Jennifer Bertsch [:jbertsch] from comment #12)
> (In reply to Matej Novak [:matej] from comment #11)
> > (In reply to Martin Best (:mbest) from comment #9)
> > > what happens if I type games.mozilla.org into the URL without the https://? 
> > > Does it auto redirect to https:// or does it try to go to http:// and fail?
> > 
> > I think that's a question for Jen B.
> > 
> > Jen, can you advise or point Martin in the right direction?
> 
> Cvan should ask IT in the bug where he asked them to set up the gaming
> subdomain.  Sorry - I can't easily find the link right now.

Thanks, Jen.

Cvan, please see above.
Flags: needinfo?(cvan)
The goal of the cards is to get people to go to the GDC landing page.  From there they will be redirected to all other locations.  I would simply include the minimum amount of information to get them to this URL.  It is a bonus to add in more information that could be relevant during the show such as twitter hash tags.  I like the card design as they are but just want to minimize the clutter.
(In reply to Martin Best (:mbest) from comment #14)
> The goal of the cards is to get people to go to the GDC landing page.  From
> there they will be redirected to all other locations.  I would simply
> include the minimum amount of information to get them to this URL.  It is a
> bonus to add in more information that could be relevant during the show such
> as twitter hash tags.  I like the card design as they are but just want to
> minimize the clutter.

I think URL + hashtag is a smart way to go.

Do you have a Firefox-at-GDC hashtag we could use?
I am not aware of what that is, but if we have not already, we should identify it.  Let's me email the group and find out where we are with the hashtag.
#GDC2015 and #Firefox are the two hashtags that will be used most for this event.  There isn't a single tag.
(In reply to Martin Best (:mbest) from comment #17)
> #GDC2015 and #Firefox are the two hashtags that will be used most for this
> event.  There isn't a single tag.

I would stick with the GDC one for this.

Sean is out sick today, but I'll chat with him about it tomorrow and we'll get you new files.

Thanks.
Channel marketing suggested 1 GDC specific and 1 Firefox Specific. #FirefoxGaming is a no-go but #FirefoxGames or #FxGames could work. Matej, FYI. We're not wanting to over-rotate on this so we're good with what you + Sean land on.
Matej, https://games.mozilla.org/ will be registered and valid. For the next few days, it will remain http://games.mozilla.org/ (which will soon house the GDC content).
Flags: needinfo?(cvan)
(In reply to Erin Lancaster [:elan] from comment #19)
> Channel marketing suggested 1 GDC specific and 1 Firefox Specific.
> #FirefoxGaming is a no-go but #FirefoxGames or #FxGames could work. Matej,
> FYI. We're not wanting to over-rotate on this so we're good with what you +
> Sean land on.

I like #FirefoxGames. Would it be OK to include just the URL and that hashtag?
(In reply to Christopher Van Wiemeersch [:cvan] from comment #20)
> Matej, https://games.mozilla.org/ will be registered and valid. For the next
> few days, it will remain http://games.mozilla.org/ (which will soon house
> the GDC content).

Martin, does that answer your question?
Here is what I think after reading this thread:

For URL: games.mozilla.org
For hastags to use we want: #GDC2015, #FirefoxGames

and that's it content wise.  If the URL when you type games.mozilla.org does not redirect to the right spot, then let's add the extra https:// info but better not to include that.  Sounds like that the default should work so it sounds better to leave it out.

Martin
One more note, let's make sure that the URL on the t-shirt lines up with what's on the card.
(Assignee)

Comment 25

3 years ago
Hey all,

It's just games.mozilla.org on the tshirt, so if that needs to change I need to know asap to update the artwork.

Thanks!
Flags: needinfo?(smartell)
games.mozilla.org it is.  That's exactly what I was hoping you would say.  so I think that makes things solid:

URL: games.mozilla.org
Twitter: #GDC2015, #FirefoxGames
(Assignee)

Comment 27

3 years ago
*nods*

Will get the revised card files on here later today. Thanks all.
(Assignee)

Comment 28

3 years ago
Hey all,

I'm going to have to tweak resize all of these as Moo.com is not standard business card size as asked. I'll rework and upload finals tomorrow.

---

Bleed Area: 3.46” x 2.32”

Make sure that your background extends to fill the bleed to avoid your Business Cards having white edges when trimmed.
Trim: 3.3” x 2.16”

This is where we aim to cut your cards.
Safe Area: 3.14” x 2.02”

Make sure any important aspects of your design such as text and logos are inside of the safe area, otherwise they may be cut off.
(Assignee)

Comment 29

3 years ago
Created attachment 8566788 [details]
Screen Shot 2015-02-19 at 5.03.10 PM.png

Preview of the final artwork, will resize in the morning
Nice job, looks great.
(Assignee)

Comment 31

3 years ago
Sandra - Just want to confirm before resizing these to the non-standard sizes used by MOO that we are in fact using them to print these.

Thanks
Flags: needinfo?(spersing)
(Reporter)

Comment 32

3 years ago
Hi Sean, yes - they have a 2 business day turnaround time, which works well for us. Thanks so much.
Sandra
Flags: needinfo?(spersing)
(Assignee)

Comment 33

3 years ago
Cards done, tested in the MOO card generator: http://cl.ly/image/0h0V1E1l3p1O

- Please use the standard business card generator, not the rounded edges
- as seen in the above screenshot, ensure that it's set to vertical orientation

ZIP of files: https://people.mozilla.org/~smartell/GDC/2015/mozilla-gdc2015_cards.zip

side note: I'm going to be in SF the week of GDC so someone needs to sneak me in to see the booth + swag. :)

Enjoy!!
(Assignee)

Comment 34

3 years ago
You'll note in the above screenshot of the MOO generator, there is actually a white border that appears. The dimensions they give for their templates does not match what the generator uses. It is very frustrating and you may have to play around with the card art to get it to be edge to edge color.

They're saved in the proper ratio, but that card generator tool is a pain in the butt.
(Reporter)

Comment 35

3 years ago
Thanks Sean! I will call MOO to make sure the files will be full bleed.

Comment 36

3 years ago
Going to resolve this bug, since these were hopefully sent to the printer last week.
Status: ASSIGNED → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.