html5 drag and drop broken on latest nightly

RESOLVED DUPLICATE of bug 936092

Status

()

Firefox
Untriaged
RESOLVED DUPLICATE of bug 936092
3 years ago
3 years ago

People

(Reporter: bgstandaert, Unassigned)

Tracking

Trunk
x86
Mac OS X
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

(Reporter)

Description

3 years ago
Created attachment 8558743 [details]
nightly-doesn't work.mov

User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10_9_5) AppleWebKit/600.3.18 (KHTML, like Gecko) Version/7.1.3 Safari/537.85.12

Steps to reproduce:

On latest nightly, html5 drag and drop no longer works. Example is http://www.html5rocks.com/en/tutorials/dnd/basics/ (scroll down to what is labeled final product just before the conclusion). 


Actual results:

The drag event starts, and the square moves inwards. However, the square does not move with the mouse, and the drop event never occurs. Another example is google drive - if you start to drag a file into a folder, the file cannot be dragged. 

Apparently you can't attach multiple files to a bug. I've attached a video of the incorrect behavior - I'll try to add a video of the correct behavior soon.


Expected results:

This should work like it does in Firefox 35 - the draggable box moves with the mouse and the drop event occurs.
(Reporter)

Comment 1

3 years ago
Created attachment 8558744 [details]
firefox 35 - works.mov

video of correct behavior in firefox 35
It should work in the nightly build if you disable the multiprocess feature (preferences/general/e10s)
Status: UNCONFIRMED → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 936092
You need to log in before you can comment on or make changes to this bug.