[Flame] "@" remains if you return to the digit keyboard right after

RESOLVED WORKSFORME

Status

Firefox OS
Gaia::Keyboard
RESOLVED WORKSFORME
3 years ago
3 years ago

People

(Reporter: hellosct1, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

244.96 KB, application/x-zip-compressed
Details
(Reporter)

Description

3 years ago
Created attachment 8558749 [details]
bug-keypad.zip

User Agent: Mozilla/5.0 (X11; Ubuntu; Linux x86_64; rv:30.0) Gecko/20100101 Firefox/30.0
Build ID: 20140608211457

Steps to reproduce:

problem to display the numeric keypad


Actual results:

I want to send an email including letters and numbers, as name1@url.com
here's what I do

I type name1 (ex1-1.png file)
when I type @, I return to the alphabet keyboard
and when I return on the numeric keypad, I have the @ that hides buttons 1 and 2 (ex1-2.png file)

I have the same problem with the application note by typing @ hellosct1
ex2-1.png, ex2-2.png, ex2-3.png

Ditto for texting ex3.png

--------------------------------------------------------------------------------------------------
je veux envoyer un email comprenant des lettres et des chiffres, comme name1@url.com
voici ce que je fais

je tape name1 (fichier ex1-1.png)
quand je tape @, je reviens au clavier alphabétique
et quand je reviens sur le clavier numérique, j'ai le @ qui cache les touches 1 et 2 (fichier ex1-2.png)

J'ai le même probleme avec l'application note en tapant @hellosct1
ex2-1.png, ex2-2.png, ex2-3.png

Idem pour envoyer des SMS ex3.png


Expected results:

view the keypad
(Reporter)

Updated

3 years ago
blocking-b2g: --- → 2.2?
(Reporter)

Comment 1

3 years ago
There was a ticket that I had done in 2014
and it had been corrected
but returned a few days ago
Thank you for filing this bug.

I am not able to reproduce this issue on yesterday's 2.2 Flame[1]. Can you run this script[2] to know which revision you're working with? You'll need Python 2.7 and the Android dev tools installed on your computer. Feel free to email me if you need any help with this. 

Clearing the blocking-b2g flag while we get confirmation on the Flame. 

[1] Gaia-Rev        cd62ff9fe199fb43920ba27bd5fdbc5c311016fc
Gecko-Rev       https://hg.mozilla.org/releases/mozilla-b2g37_v2_2/rev/11d93135c678
Build-ID        20150203002504
Version         37.0a2
Device-Name     flame
FW-Release      4.4.2
FW-Incremental  eng.cltbld.20150203.041704
FW-Date         Tue Feb  3 04:17:15 EST 2015
Bootloader      L1TC000118D0

[2] https://raw.githubusercontent.com/Mozilla-TWQA/B2G-flash-tool/master/check_versions.py
blocking-b2g: 2.2? → ---
Component: General → Gaia::Keyboard
Flags: needinfo?(hellosct1)
Summary: view keypad → "@" remains if you return to the digit keyboard right after
Tried on master too but can't reproduce either.
(Reporter)

Comment 4

3 years ago
hi,

despite the different updates
the bug is still present

I am next to Mozilla Paris and I can bring the show if necessary


Christophe
Flags: needinfo?(hellosct1)
I remember you have an OpenC, right (if not, do not hesitate to change the summary of this bug)? The resolution of the screen is smaller than the Flame. That might explain why you see this issue but not the other people. 

Gerry, what kind of logs can hellosct1 get to highlight the issue?
Status: UNCONFIRMED → NEW
Ever confirmed: true
Flags: needinfo?(gchang)
Summary: "@" remains if you return to the digit keyboard right after → [OpenC] "@" remains if you return to the digit keyboard right after
(Reporter)

Comment 6

3 years ago
(In reply to Johan Lorenzo [:jlorenzo] (QA) from comment #5)
> I remember you have an OpenC, right (if not, do not hesitate to change the
> summary of this bug)? The resolution of the screen is smaller than the
> Flame. That might explain why you see this issue but not the other people. 
> 
> Gerry, what kind of logs can hellosct1 get to highlight the issue?

hi,

The bug has been always on a Flame in 2.2
I never had this problem with my openC 1.x

Christophe
(In reply to hellosct1 from comment #6)
> The bug has been always on a Flame in 2.2
> I never had this problem with my openC 1.x

Could you provide the version numbers of gecko and gaia that you're using? Or at least the build id so we can find them out.
(Reporter)

Comment 8

3 years ago
(In reply to Gabriele Svelto [:gsvelto] from comment #7)
> (In reply to hellosct1 from comment #6)
> > The bug has been always on a Flame in 2.2
> > I never had this problem with my openC 1.x
> 
> Could you provide the version numbers of gecko and gaia that you're using?
> Or at least the build id so we can find them out.


modele : qcom
plateforme : 35.0a1
identifiant version : 20141008040203
canal mise à jour : nightly
infos des commits Git : 2014-10-07 20:43:36 0bc74ce5




file : 2015-02-13-13-26-34proc-version.log
-------------------------------------------
Linux version 3.4.0-gbbf5f38a-00002-g74e9f4b (android-bld@Moon) (gcc version 4.7 (GCC) ) #1 SMP PREEMPT Fri Jun 27 16:09:39 CST 2014


file : 2015-02-13-13-26-34dev-__properties__.log
------------------------------------------------
ro.boot.console: ttyHSL0
ro.boot.hardware: qcom
ro.boot.bootloader: L1TC00011230
ro.boot.emmc: true
ro.boot.serialno: f03f4003
ro.boot.baseband: msm
ro.serialno: f03f4003
ro.bootmode: unknown
ro.baseband: msm
ro.bootloader: L1TC00011230
ro.hardware: qcom
ro.revision: 0
ro.factorytest: 0
ro.secure: 0
ro.allow.mock.location: 0
ro.debuggable: 0
persist.sys.strict_op_enable: false
persist.sys.whitelist: /system/etc/whitelist_appops.xml
persist.sys.usb.config: diag,serial_smd,serial_tty,rmnet_bam,mass_storage,adb
init.svc.ueventd: running
ro.crypto.state: unencrypted
vold.post_fs_data_done: 1
ro.build.id: JLS36C
ro.build.display.id: JLS36C
ro.build.version.incremental: 110
ro.build.version.sdk: 18
ro.build.version.codename: REL
ro.build.version.release: 4.3
ro.build.date: Fri Jun 27 15:57:58 CST 2014
ro.build.date.utc: 1403855878
ro.build.type: user
ro.build.user: android-bld
ro.build.host: Moon
ro.build.tags: dev-keys
ro.product.model: Flame
ro.t2m.model.name: Flame
ro.t2m.hardware.info: 01
ro.moz.ril.subscription_control: true
ro.moz.ril.0.network_types: gsm,wcdma
ro.moz.ril.1.network_types: gsm
ro.moz.ril.numclients: 2
persist.radio.multisim.config: dsds
ro.product.brand: qcom
ro.product.name: msm8610
ro.product.device: flame
ro.product.board: MSM8610
ro.product.cpu.abi: armeabi-v7a
ro.product.cpu.abi2: armeabi
ro.product.manufacturer: unknown
ro.product.locale.language: en
ro.product.locale.region: US
ro.wifi.channels: 
ro.board.platform: msm8610
ro.build.product: msm8610
ro.build.description: msm8610-user 4.3 JLS36C 110 dev-keys
ro.build.fingerprint: qcom/msm8610/msm8610:4.3/JLS36C/110:user/dev-keys
ro.build.characteristics: default
rild.libpath: /vendor/lib/libril-qc-qmi-1.so
rild.libargs: -d /dev/smd0
persist.rild.nitz_plmn: 
persist.rild.nitz_long_ons_0: 
persist.rild.nitz_long_ons_1: 
persist.rild.nitz_long_ons_2: 
persist.rild.nitz_long_ons_3: 
persist.rild.nitz_short_ons_0: 
persist.rild.nitz_short_ons_1: 
persist.rild.nitz_short_ons_2: 
persist.rild.nitz_short_ons_3: 
ril.subscription.types: NV,RUIM
DEVICE_PROVISIONED: 1
persist.radio.msgtunnel.start: false
persist.radio.atfwd.start: false
ro.telephony.default_network: 5
debug.sf.fb_always_on: 1
debug.composition.type: gpu
debug.gralloc.map_fb_memory: 0
debug.hwc.dynThreshold: 1.5
dalvik.vm.heapsize: 256m
dev.pm.dyn_samplingrate: 1
ro.hdmi.enable: true
tunnel.decode: true
tunnel.audiovideo.decode: false
lpa.decode: false
lpa.use-stagefright: true
media.stagefright.enable-player: true
media.stagefright.enable-http: true
media.stagefright.enable-aac: true
media.stagefright.enable-qcp: true
media.stagefright.enable-fma2dp: true
media.stagefright.enable-scan: true
mmp.enable.3g2: true
media.aac_51_output_enabled: true
mm.enable.qcom_parser: 37491
vidc.debug.level: 1
persist.gralloc.cp.level3: 1
ro.use_data_netmgrd: true
persist.timed.enable: true
ro.opengles.version: 196608
telephony.lteOnCdmaDevice: 1
persist.fuse_sdcard: true
ro.qc.sdk.audio.ssr: false
ro.qc.sdk.audio.fluencetype: none
ro.sys.fw.bg_apps_limit: 20
ro.qualcomm.cabl: 1
persist.dash.max.rep.resolution: 1280*720
persist.dash.max.rep.bandwidth: 4000000
persist.dash.avsync.window.msec: 100
tunnel.audio.encode: false
ro.fm.transmitter: false
rm.audio.exceptions: true
ro.sys.umsdirtyratio: 10
ro.moz.wifi.unloaddriver: 1
ro.qc.sdk.izat.service_mask: 0x9
diag.reset_handler: true
keyguard.no_require_sim: true
ro.com.android.dataroaming: true
ro.com.android.dateformat: MM-dd-yyyy
ro.config.ringtone: Ring_Synth_04.ogg
ro.config.notification_sound: pixiedust.ogg
ro.carrier: unknown
ro.config.alarm_alert: Alarm_Classic.ogg
ro.vendor.extension_library: /vendor/lib/libqc-opt.so
dalvik.vm.heapstartsize: 8m
dalvik.vm.heapgrowthlimit: 96m
dalvik.vm.heaptargetutilization: 0.75
dalvik.vm.heapminfree: 2m
dalvik.vm.heapmaxfree: 8m
ro.display.colorfill: 1
ro.moz.ril.emergency_by_default: true
org.bluez.device.conn.type: array
ro.moz.devinputjack: 1
ro.moz.omx.hw.max_width: 1280
ro.moz.omx.hw.max_height: 720
ro.moz.nfc.enabled: true
net.bt.name: Android
net.change: net.dnschange
dalvik.vm.stack-trace-file: /data/anr/traces.txt
ro.assisted_gps_enabled: 0
ro.qc.sdk.izat.premium_enabled: 1
persist.gps.qc_nlp_in_use: 0
ro.gps.agps_provider: 1
persist.radio.adb_log_on: 0
persist.radio.eons.enabled: false
persist.radio.dont_use_dsd: true
persist.sys.timezone: Europe/Paris
persist.radio.nitz_lons_0_0: Free
persist.radio.nitz_lons_1_0: 
persist.radio.nitz_lons_2_0: 
persist.radio.nitz_lons_3_0: 
persist.radio.nitz_sons_0_0: 
persist.radio.nitz_sons_1_0: 
persist.radio.nitz_sons_2_0: 
persist.radio.nitz_sons_3_0: 
persist.radio.nitz_plmn_0: 208 01
persist.radio.clir: 0
ro.sf.lcd_density: 240
ro.alarm_boot: false
wlan.driver.ath: 0
wlan.driver.config: /data/misc/wifi/WCNSS_qcom_cfg.ini
qcom.audio.init: complete
ro.nfc.port: I2C
net.tcp.buffersize.default: 4096,87380,110208,4096,16384,110208
net.tcp.buffersize.wifi: 524288,2097152,4194304,262144,524288,1048576
net.tcp.buffersize.lte: 524288,1048576,2097152,262144,524288,1048576
net.tcp.buffersize.umts: 4094,87380,110208,4096,16384,110208
net.tcp.buffersize.hspa: 4094,87380,1220608,4096,16384,1220608
net.tcp.buffersize.hsupa: 4094,87380,1220608,4096,16384,1220608
net.tcp.buffersize.hsdpa: 4094,87380,1220608,4096,16384,1220608
net.tcp.buffersize.hspap: 4094,87380,1220608,4096,16384,1220608
net.tcp.buffersize.edge: 4093,26280,35040,4096,16384,35040
net.tcp.buffersize.gprs: 4092,8760,11680,4096,8760,11680
net.tcp.buffersize.evdo: 4094,87380,262144,4096,16384,262144
system_init.startsurfaceflinger: 0
init.svc.servicemanager: running
init.svc.vold: running
init.svc.qcom-c_core-sh: stopped
init.svc.rfs_access: running
init.svc.config_bluetooth: stopped
init.svc.qcom-usb-sh: stopped
init.svc.swapping: stopped
init.svc.netd: running
init.svc.debuggerd: running
init.svc.ril-daemon: running
init.svc.media: running
init.svc.dbus: running
init.svc.keystore: running
init.svc.nfcd: running
init.svc.fakeperm: running
init.svc.gonksched: running
init.svc.b2g: running
init.svc.qcom-c_main-sh: stopped
init.svc.ril-qmi: stopped
init.svc.irsc_util: stopped
init.svc.ptt_socket_app: stopped
init.svc.qcomsysd: running
init.svc.thermal-engine: running
init.svc.qrngd: running
init.svc.adsprpcd: running
wifi.interface: wlan0
ro.telephony.call_ring.multiple: false
ro.qualcomm.bluetooth.opp: true
init.svc.qcom-sh: stopped
init.svc.ppd: running
init.svc.time_daemon: running
init.svc.qcamerasvr: running
init.svc.wcnss-service: running
init.svc.trace_util: running
init.svc.mverproxy: stopped
init.svc.ril-daemon1: running
sys.usb.config: diag,serial_smd,serial_tty,rmnet_bam,mass_storage,adb
ro.qualcomm.bluetooth.hfp: true
init.svc.atfwd: stopped
t2m.sw.version: B1TC00011230
init.svc.rmt_storage: running
init.svc.qmuxd: running
hw.cabl.version: 1.1.20130401
hw.cabl.yuv: 0
init.svc.adbd: running
sys.usb.state: diag,serial_smd,serial_tty,rmnet_bam,mass_storage,adb
ro.qualcomm.bluetooth.hsp: true
init.svc.netmgrd: running
ro.qualcomm.bluetooth.pbap: true
ro.qualcomm.bluetooth.ftp: true
ro.qualcomm.bluetooth.nap: true
ro.bluetooth.sap: true
init.svc.location_mq: running
ro.bluetooth.dun: false
init.svc.xtwifi_inet: running
ro.qualcomm.bluetooth.map: true
init.svc.xtwifi_client: running
ro.bluetooth.hfp.ver: 1.5
ro.qualcomm.bt.hci_transport: smd
init.svc.lowi-server: running
ro.qc.bluetooth.stack: bluez
init.svc.charger_monitor: running
ril.qcril_pre_init_lock_held: 0
dolby.audio.sink.info: speaker
ro.ril.svlte1x: false
ro.ril.svdo: false
ril.ecclist: 911,112
ril.ecclist1: 911,112
gsm.version.ril-impl: Qualcomm RIL 1.0
hw.pp.cfg: /data/pp_data.cfg
bluetooth.isEnabled: false
sys.boot_completed: 1
init.svc.qcom-post-boot: stopped
init.svc.qrngp: stopped
init.svc.mpdecision: running
net.rmnet0.dns1: 212.27.40.240
net.rmnet0.dns2: 212.27.40.241
net.rmnet0.gw: 10.174.147.241
net.dns1: 212.27.40.240
net.dns2: 212.27.40.241
net.dnschange: 39
wlan.driver.status: unloaded
init.svc.wpa_supplicant: stopped
dhcp.wlan0.result: ok
init.svc.dhcpcd_wlan0: stopped
dhcp.wlan0.pid: 8968
dhcp.wlan0.reason: REBOOT
dhcp.wlan0.dns1: 192.168.0.1
dhcp.wlan0.dns2: 
dhcp.wlan0.dns3: 
dhcp.wlan0.dns4: 
dhcp.wlan0.domain: neuros.lan
dhcp.wlan0.ipaddress: 192.168.0.103
dhcp.wlan0.gateway: 192.168.0.1
dhcp.wlan0.mask: 255.255.255.0
dhcp.wlan0.leasetime: 604800
dhcp.wlan0.server: 192.168.0.1
dhcp.wlan0.vendorInfo: 
net.wlan0.dns1: 192.168.0.1
net.wlan0.dns2: 0.0.0.0
net.wlan0.gw: 192.168.0.1



thank's
(Reporter)

Updated

3 years ago
blocking-b2g: --- → 2.2?
Summary: [OpenC] "@" remains if you return to the digit keyboard right after → [Flame] "@" remains if you return to the digit keyboard right after
I can't repro in latest 2.2 in flame. 
Can you attach the log by using adb logcat?
Flags: needinfo?(gchang)
Hellosct1, per comment 8, your 2.2 version is dated from last october (See identifiant version/Build ID : 20141008040203). 2.2 has changed a lot for the past 4 months. Could you please try again on a more recent build?
blocking-b2g: 2.2? → ---
Flags: needinfo?(hellosct1)
(Reporter)

Comment 11

3 years ago
After update...
everything works
thank you
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Flags: needinfo?(hellosct1)
Resolution: --- → WONTFIX
The issue is actually solved but we don't know by which commit, WORKS FOR ME is the most suited resolution here.
Resolution: WONTFIX → WORKSFORME
You need to log in before you can comment on or make changes to this bug.