Failure to load source mapped sources on nytimes.com

RESOLVED WORKSFORME

Status

DevTools
Debugger
RESOLVED WORKSFORME
4 years ago
a month ago

People

(Reporter: fitzgen, Unassigned)

Tracking

(Blocks: 1 bug)

Firefox Tracking Flags

(Not tracked)

Details

STR:

Load nytimes.com

Open debugger

Click on one of the sources

--------------------

In the source map, they have some relative paths like this:

  "../../../../../../../../../vendor/nytimes/shared/Ad/js/src/models/ad.js"

I have a feeling that we are resolving the relative path to the wrong thing.

Chrome loads the source just fine.
I feel that this problem is reproduced by the source map which is generated by node-browserify (https://github.com/substack/node-browserify) and use relative path to require modules.

But I have not created a definite minimum testcase yet...
This works for me (tested on dev edition 42), likely fixed by bug 1166048 so should be fixed in 40+.
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → WORKSFORME

Updated

a month ago
Product: Firefox → DevTools
You need to log in before you can comment on or make changes to this bug.