[Homescreen] App Icon Hitboxes can be reached while App is off top of screen

VERIFIED WONTFIX

Status

Firefox OS
Gaia::Homescreen
VERIFIED WONTFIX
3 years ago
3 years ago

People

(Reporter: oliverthor, Unassigned)

Tracking

unspecified
ARM
Gonk (Firefox OS)

Firefox Tracking Flags

(b2g-v2.0 affected, b2g-v2.1 affected, b2g-v2.2 affected, b2g-master affected)

Details

(Whiteboard: [3.0-Daily-Testing], URL)

Attachments

(2 attachments)

(Reporter)

Description

3 years ago
Created attachment 8558790 [details]
logcat_20150203_1452.txt

Description:
If the user has reached the bottom of their homescreen with app icons in panning distance above, but off screen, the user will notice that they may tap the top of the screen directly below the rocketbar to access them blindly. This may present itself as an odd user experience on unexpected app openings.
* Easily observable when tapping between groups, as show in video.

Repro Steps:
1) Update a Flame to 20150203055641
2) Scroll towards bottom of homescreen, allowing a row of icons to just pass Search Bar.
3) Tap directly under 'Search Bar' at blank canvas.

Actual:
Apps may be accessed while offscreen from their hitbox size.

Expected:
Apps that may be accessed are on screen and visible to the user.

Environmental Variables:
--------------------------------------------------
Device: Flame 3.0
Build ID: 20150203055641
Gaia: ae5a1580da948c3b9f93528146b007fc4f6a712b
Gecko: ae5d04409cd9
Gonk: e7c90613521145db090dd24147afd5ceb5703190
Version: 38.0a1 (3.0)
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:38.0) Gecko/38.0 Firefox/38.0

--------------------------------------------------
Issue REPROES on flame 2.2 devices:
Results: Apps may be accessed while offscreen from their hitbox size.

Device: Flame 2.2
BuildID: 20150203002504
Gaia: cd62ff9fe199fb43920ba27bd5fdbc5c311016fc
Gecko: 11d93135c678
Gonk: e7c90613521145db090dd24147afd5ceb5703190
Version: 37.0a2 (2.2) 
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:37.0) Gecko/37.0 Firefox/37.0
--------------------------------------------------

Repro frequency: 5/5
See attached: 
video- http://youtu.be/-HRx5H0io80
logcat
(Reporter)

Updated

3 years ago
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(pbylenga)
Whiteboard: [3.0-Daily-Testing]
(Reporter)

Comment 1

3 years ago
This issue REPROES on flame 2.1 and 2.0 devices:
Results: Apps may be accessed while offscreen from their hitbox size.


Environmental Variables:
--------------------------------------------------
Device: Flame 2.1
BuildID: 20150203001532
Gaia: 17bf14f12e43043654498330d610d469b8b55e64
Gecko: 014f57033b8a
Gonk: e7c90613521145db090dd24147afd5ceb5703190
Version: 34.0 (2.1) 
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:34.0) Gecko/34.0 Firefox/34.0
--------------------------------------------------
Device: Flame 2.0
BuildID: 20150203000206
Gaia: 2989f2b2bd12fcc0e9c017d2db766e76a55873b8
Gecko: 1ebfb977fa67
Gonk: e7c90613521145db090dd24147afd5ceb5703190
Version: 32.0 (2.0) 
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:32.0) Gecko/32.0 Firefox/32.0
--------------------------------------------------
Results: 5/5
status-b2g-v2.0: --- → affected
status-b2g-v2.1: --- → affected
NI on component owner for nomination decision and assignment.
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(pbylenga) → needinfo?(hcheng)
I think the reason is that tapping an app's located square would trigger 'click' event to launch this app.
Flags: needinfo?(hcheng) → needinfo?(chrislord.net)
Created attachment 8559577 [details]
screen shot

Comment 5

3 years ago
(In reply to Hermes Cheng[:hermescheng] from comment #3)
> I think the reason is that tapping an app's located square would trigger
> 'click' event to launch this app.

Indeed, the hit-box of the icon has some padding - The problem is, we need the padding or tapping on the edge of icons could easily miss, which would be a lot more annoying.

We can't easily selectively add the padding only when the app is visible and I don't think the time it would take to implement that is worth the benefit of the situation that tapping at the very edge of the screen is occasionally, slightly better.

Given that you pretty much have to purposefully aim to trigger this, marking this as WONTFIX for now - if I've misunderstood the problem, please reopen.
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Flags: needinfo?(chrislord.net)
Resolution: --- → WONTFIX
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.