activating API key results in error

RESOLVED INVALID

Status

()

RESOLVED INVALID
4 years ago
4 years ago

People

(Reporter: florijn.peter, Unassigned)

Tracking

Details

(Reporter)

Description

4 years ago
User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.10; rv:35.0) Gecko/20100101 Firefox/35.0
Build ID: 20150122214805

Steps to reproduce:

I tried to activate a API key ( Preferences).

When I submit Bugzilla gives this error. 


Actual results:

An unexpected error occurred. This could be a temporary problem, or some code is behaving incorrectly. If this problem persists, please email this page to [removed].com with details of what you were doing at the time this message appeared.

URL: http://localhost/bugzilla/
There was an error sending mail from 'bugzilla-daemon' to 'removed@gmail.com': no sender

Traceback:

 at Bugzilla/Mailer.pm line 181.
	Bugzilla::Mailer::MessageToMTA(...) called at Bugzilla/Mailer.pm line 222
	Bugzilla::Mailer::send_staged_mail(...) called at Bugzilla/DB.pm line 1223
	Bugzilla::DB::bz_commit_transaction(...) called at Bugzilla/Object.pm line 540
	Bugzilla::Object::update(...) called at Bugzilla/User.pm line 220
	Bugzilla::User::update(...) called at Bugzilla/Auth/Verify.pm line 123
	Bugzilla::Auth::Verify::create_or_update_user(...) called at Bugzilla/Auth/Verify/Stack.pm line 71
	Bugzilla::Auth::Verify::Stack::create_or_update_user(...) called at Bugzilla/Auth.pm line 67
	Bugzilla::Auth::login(...) called at Bugzilla.pm line 311
	Bugzilla::login(...) called at /Library/WebServer/Documents/bugzilla/index.cgi line 21




Expected results:

API key should have been mailed.
(Reporter)

Updated

4 years ago
Component: Bugzilla-General → Installation & Upgrading
> There was an error sending mail from 'bugzilla-daemon' to 'removed@gmail.com': no sender

this is a configuration issue with regards to your MTA.
some MTAs require a full-formed email address as the sender; you need to updates your 'mailfrom' parameter.
see http://bugzilla.readthedocs.org/en/latest/administering/parameters.html#email
Status: UNCONFIRMED → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → INVALID
(Reporter)

Comment 2

4 years ago
@glob: I assumed this, but I can't even correct this because this error persist when I try to login.

when I run checksetuo.pl I get :

Removing existing compiled templates...
Precompiling templates...done.
Fixing file permissions...
There was an error sending mail from 'bugzilla-daemon' to
'user.peter@gmail.com': no sender
odd; checksetup doesn't generate emails.  have you installed any bugzilla extensions, such as testopia?
if so, try running checksetup with those extensions disabled (create an empty "disabled" file in their directory).

note: if you can't successfully run checksetup, bugzilla may not be working.
(Reporter)

Comment 4

4 years ago
Yes I have Testopia installed. Disabled this with empty disabled file.

Results are the same:
There was an error sending mail from 'bugzilla-daemon' to
'user.peter@gmail.com': no sender

Looks there is a mail stuck somewhere in a queue ?


Can I try to set mailfrom in params.json ?
(Reporter)

Comment 5

4 years ago
1. scratch my database (my test environment)
2. added smtp settings to data/params.json
3. run checksetup.pl again
4. login to bugzilla succeeded again
5. created API key (succesful, without errors)


I did not receive a confirmation mail, but this is probably due to incorrect smtp settings.
You need to log in before you can comment on or make changes to this bug.