Keyboard hides randomly at Rocketbar input

VERIFIED FIXED in 2.2 S6 (20feb)

Status

defect
VERIFIED FIXED
4 years ago
4 years ago

People

(Reporter: mnjul, Assigned: alive)

Tracking

({regression})

unspecified
2.2 S6 (20feb)
ARM
Gonk (Firefox OS)

Firefox Tracking Flags

(blocking-b2g:2.2+, b2g-v2.2 verified, b2g-master verified)

Details

(Whiteboard: [FT:System-Platform])

Attachments

(2 attachments)

See video: https://www.youtube.com/watch?v=pC4o8SZ8m8U
Five tries,
"bad" results at 0m10s, 0m16s, and 0m20s
"good" results at 0m4s and 0m28s

STR:
1. From home screen, go to rocket bar.
2. Press a key on keyboard to input a character.

Expected result:
3. Keyboard stays and you can press more keys to input more characters.

Actual result:
3. Keyboard hides.

Repro rate: 3/5

Probably a regression.

On Flame, v18D, 1GB RAM.
Gaia-Rev        dfebaaa8aab43470f482d09d71137bab840c3ae9
Gecko-Rev       https://hg.mozilla.org/mozilla-central/rev/0c2f7434c325
Build-ID        20150203160231
This is a regression, let's mark qawanted for branch check and do regression-window afterwards.
Keywords: qawanted
[Blocking Requested - why for this release]: Basic phone usage is broken.
blocking-b2g: --- → 3.0?
Whiteboard: [FT:System-Platform]
I don't think this bug should be in our component, but let's move it after we found the regressed bug.
Keywords: qaurgent
QA Contact: pcheng
(In reply to John Lu [:mnjul] [MoCoTPE] from comment #1)
> This is a regression, let's mark qawanted for branch check and do
> regression-window afterwards.

This issue occurs on Flame 3.0. Typing a letter on Rocket bar hides keyboard. Repro rate is 4/5.

Device: Flame 3.0 Master
BuildID: 20150204053527
Gaia: 7b965db30278e46aaaa2a78555c187a041ab7864
Gecko: b7c8165d691e
Version: 38.0a1 (3.0 Master) 
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:38.0) Gecko/38.0 Firefox/38.0

-----

This issue does NOT occur on Flame 2.2. Typing a letter on Rocketbar does not hide the keyboard. Repro rate: 0/10.

Device: Flame 2.2
BuildID: 20150204032027
Gaia: b29f3ae643d57f3fb24ed7e9fb6884d7f2fc533d
Gecko: b495919a27f9
Version: 37.0a2 (2.2) 
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:37.0) Gecko/37.0 Firefox/37.0

------

Working on getting the window now.
Flags: needinfo?(ktucker)
Flags: needinfo?(ktucker)
b2g-inbound regression window:

Last Working Environmental Variables:
Device: Flame
BuildID: 20150129194440
Gaia: 0630174909e47e6c62a6a92e07cee1a901d97028
Gecko: e539715710f6
Version: 38.0a1 (3.0 Master)
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:38.0) Gecko/38.0 Firefox/38.0

First Broken Environmental Variables:
Device: Flame
BuildID: 20150129205239
Gaia: 21829dd3fcf7b107bf16e798aa39a17c42d66fef
Gecko: a66f5d17e9cf
Version: 38.0a1 (3.0 Master)
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:38.0) Gecko/38.0 Firefox/38.0

Last Working Gaia & First Broken Gecko - issue does NOT repro
Gaia: 0630174909e47e6c62a6a92e07cee1a901d97028
Gecko: a66f5d17e9cf

Last Working Gecko & First Broken Gaia - issue DOES repro
Gaia: 21829dd3fcf7b107bf16e798aa39a17c42d66fef
Gecko: e539715710f6

Gaia pushlog:
https://github.com/mozilla-b2g/gaia/compare/0630174909e47e6c62a6a92e07cee1a901d97028...21829dd3fcf7b107bf16e798aa39a17c42d66fef

Caused by the patch for Bug 1124816.
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(ktucker)
Alive, can you take a look at this please? Looks like the landing for bug 1124816 might have caused this.
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(ktucker) → needinfo?(alive)
Thanks!
Assignee: nobody → alive
Flags: needinfo?(alive)
Comment on attachment 8559635 [details] [review]
[PullReq] alivedise:bugzilla/1129344/search-window-lose-focus to mozilla-b2g:master

It's because we are focusing all window correctly when it is opened, but this is not expected by searchWindow - the input is put inside system app so the focus will steal the input then cause the keyboard to hide.

I am not sure if we should move the input into Search app? But let's build a special rule for search window right now :/ (And no more!)
Attachment #8559635 - Flags: review?(kgrandon)
Attachment #8559635 - Flags: review?(etienne)
Comment on attachment 8559635 [details] [review]
[PullReq] alivedise:bugzilla/1129344/search-window-lose-focus to mozilla-b2g:master

The change makes sense but I'm still reproducing the bug with this patch applied :/
Attachment #8559635 - Flags: review?(etienne)
Usually after 
- clearing the rocketbar input
- leaving the rocketbar
- entering again

-> the keyboard will hide after the first letter
Comment on attachment 8559635 [details] [review]
[PullReq] alivedise:bugzilla/1129344/search-window-lose-focus to mozilla-b2g:master

:/ Checking
Attachment #8559635 - Flags: review?(kgrandon)

Comment 13

4 years ago
Triage: regression blocking
blocking-b2g: 3.0? → 3.0+
Duplicate of this bug: 1128512
Duplicate of this bug: 1131674
Comment on attachment 8559635 [details] [review]
[PullReq] alivedise:bugzilla/1129344/search-window-lose-focus to mozilla-b2g:master

So the problem of the previous one is Search instead of SearchWindow :/
Attachment #8559635 - Flags: review?(etienne)
Comment on attachment 8559635 [details] [review]
[PullReq] alivedise:bugzilla/1129344/search-window-lose-focus to mozilla-b2g:master

\o/
Attachment #8559635 - Flags: review?(etienne) → review+
Component: Gaia::System::Input Mgmt → Gaia::System::Window Mgmt
https://github.com/mozilla-b2g/gaia/commit/21dc7cb99eeef24c63d814f6d27d1f9a28ae202d
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → FIXED
See Also: → 1133635
Keywords: verifyme
This issue does NOT occur on Flame 3.0
repro rate: 0/15

When the user first starts typing in the rocketbar, the rocketbar will not be dismissed. It will remain active for the user to finish typing their query

Environmental Variables:
Device: Flame 3.0 (319mb)(Kitkat)(Full Flash)
Build ID: 20150217074222
Gaia: ae02fbdeae77b2002cebe33c61aedeee4b9439fd
Gecko: 4bb425001d8a
Gonk: e7c90613521145db090dd24147afd5ceb5703190
Version: 38.0a1 (3.0)
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:38.0) Gecko/38.0 Firefox/38.0
Status: RESOLVED → VERIFIED
QA Whiteboard: [QAnalyst-Triage+] → [QAnalyst-Triage?]
Flags: needinfo?(pbylenga)
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(pbylenga)
Keywords: verifyme
I'm actually seeing this today on 2.2, from a local build I flashed last Friday (Flame, 18D). Bug 1133635 also indicates it is present there. Can we uplift this please?
See comment 20.
Flags: needinfo?(alive)
Duplicate of this bug: 1135443
This might be 2.2 affecting because the patch landed after the 1/12 merge date.  KevinT, can you have someone check please on 2.2 we'll probably want this blocking 2.2 and uplifted if that is the case.
Comment on attachment 8559635 [details] [review]
[PullReq] alivedise:bugzilla/1129344/search-window-lose-focus to mozilla-b2g:master

It also happens on 2.2 20150222162501

[Approval Request Comment]
[Bug caused by] (feature/regressing bug #): bug 1124816
[User impact] if declined: Keyboard gets hidden when the user types
[Testing completed]: Has baked a week and been verified fixed
[Risk to taking this patch] (and alternatives if risky): low
[String changes made]: none
Flags: needinfo?(ktucker)
Attachment #8559635 - Flags: approval-gaia-v2.2?
This issue reproduces on today's Flame 2.2 nightly build.

Result: The keyboard disappears after entering a letter in the rocket bar.

Result: Device: Flame 2.2 (KK, 319mb, full flash)
Build ID: 20150223002503
Gaia: 389542b71c89253c0d176d3b0bfb54e275c19bf1
Gecko: 9fd3441c8983
Gonk: e7c90613521145db090dd24147afd5ceb5703190
Version: 37.0a2 (2.2)
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:37.0) Gecko/37.0 Firefox/37.0
Requesting uplift and 2.2+
blocking-b2g: 3.0+ → 2.2?
Duplicate of this bug: 1135459
See Also: → 1135938
Clearing ni since the lost piece is just asking approval.
Flags: needinfo?(alive)
blocking-b2g: 2.2? → 2.2+
Attachment #8559635 - Flags: approval-gaia-v2.2? → approval-gaia-v2.2+
Posted video verify2.2.3gp
This bug has been verified as "pass" on latest build of Flame v2.2,Nexus5 v2.2 by the STR in comment 0.

Actually result: Keyboard stays and you can press more keys to input more characters.
Reproduce rate: 0/10
See attachment: verify2.2.3gp

Device: Flame 2.2 (pass):
Build ID               20150705162505
Gaia Revision          ea11f422b687a982f0a961c9aea7858066561707
Gaia Date              2015-07-02 23:37:50
Gecko Revision         https://hg.mozilla.org/releases/mozilla-b2g37_v2_2/rev/c0214b4c1ea0
Gecko Version          37.0
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150705.200108
Firmware Date          Sun Jul  5 20:01:20 EDT 2015
Bootloader             L1TC000118D0

Device: Nexus 5_2.2 (pass):
Build ID               20150705002505
Gaia Revision          ea11f422b687a982f0a961c9aea7858066561707
Gaia Date              2015-07-02 23:37:50
Gecko Revision         https://hg.mozilla.org/releases/mozilla-b2g37_v2_2/rev/c0214b4c1ea0
Gecko Version          37.0
Device Name            hammerhead
Firmware(Release)      5.1
Firmware(Incremental)  eng.cltbld.20150705.041046
Firmware Date          Sun Jul  5 04:11:05 EDT 2015
Bootloader             HHZ12f
QA Whiteboard: [QAnalyst-Triage+] → [QAnalyst-Triage+][MGSEI-Triage+]
You need to log in before you can comment on or make changes to this bug.