[Settings] Not able to change the default SIM card (outgoing calls, messages, data) when accessing to SIM Manager

RESOLVED DUPLICATE of bug 1129329

Status

RESOLVED DUPLICATE of bug 1129329
4 years ago
4 years ago

People

(Reporter: noemi, Unassigned)

Tracking

({regression})

unspecified
ARM
Gonk (Firefox OS)
regression

Firefox Tracking Flags

(b2g-v2.1 unaffected, b2g-v2.2 affected, b2g-master affected)

Details

(URL)

(Reporter)

Description

4 years ago
Description: Not able to change the default SIM card (outgoing calls, messages, data) when accessing to Settings->SIM Manager

STRs:
1- Insert SIM1 and SIM2
2- Install today's (2/4) master build; during FTE SIM1 is set as the default SIM card
3- Access to Settings->SIM Manager; it is possible to set SIM2 as the default SIM card for outgoing calls, messages, data -> OK
4- Open Browser app and navigate (generate some traffic)
5- Access to Settings->SIM Manager; it is not possible to set SIM2 as the default SIM card for outgoing calls, messages or data -> KO (the error persists even closing and launching Settings again)

Actual result:
It is not possible to set SIM2 as the default SIM card for outgoing calls, messages or data. The SIM card selection menu is not launched.

Expected result:
It is possible to set SIM2 as the default SIM card for outgoing calls, messages or data. The SIM card selection menu is properly launched showing SIM1 (pre-selected) and SIM2.

Environmental variables:
Flame 3.0 device
Build Id: 20150204070907
Gecko: 54f71a0
Gaia: 360bb0f
Platform version: 38.0a1

setting qawanted flag to see if 2.2 and/or 2.1 branches are affected
(Reporter)

Updated

4 years ago
status-b2g-master: --- → affected
I was unable to reproduce this issue on the latest Flame Master. If you provide us the build you found the issue on, we can try to reproduce.

Environmental Variables:
Device: Flame 3.0
BuildID: 20150204053527
Gaia: 7b965db30278e46aaaa2a78555c187a041ab7864
Gecko: b7c8165d691e
Version: 38.0a1 (3.0) 
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:38.0) Gecko/38.0 Firefox/38.0
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(ktucker)
QA Contact: bzumwalt
Issue DOES occur on Flame 2.2 and 3.0

SIM Card selection menu not launched after accessing selection menu once, then browsing on cell data before returning to settings page.

Device: Flame 2.2
Build ID: 20150204002509
Gaia: a4c4cc86303a554facb8f45b7e764e5c4473c3de
Gecko: 8669c26fd4a5
Gonk: e7c90613521145db090dd24147afd5ceb5703190
Version: 37.0a2 (2.2)
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:37.0) Gecko/37.0 Firefox/37.0

Device: Flame 3.0 Master
Build ID: 20150204010225
Gaia: dfebaaa8aab43470f482d09d71137bab840c3ae9
Gecko: 0c2f7434c325
Gonk: e7c90613521145db090dd24147afd5ceb5703190
Version: 38.0a1 (3.0)
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:38.0) Gecko/38.0 Firefox/38.0



Issue does NOT occur on Flame 2.1

SIM Card selection menu accessible at all times.

Device: Flame 2.1
Build ID: 20150204002437
Gaia: 17bf14f12e43043654498330d610d469b8b55e64
Gecko: bdebcc47ec7a
Gonk: e7c90613521145db090dd24147afd5ceb5703190
Version: 34.0 (2.1)
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:34.0) Gecko/34.0 Firefox/34.0
status-b2g-v2.1: --- → unaffected
status-b2g-v2.2: --- → affected
Keywords: qawanted → regression
Nominating 2.2?, the user should be able to switch which SIM is used without issue.
blocking-b2g: --- → 2.2?
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(ktucker)
Keywords: regressionwindow-wanted
Regression Window:

Last working B2G-Inbound build:
Device:  Flame 3.0 Master
BuildID: 20150202201825
Gaia: 18e3f2f8f7c254e3b08a45e14ec8e5940bd46884
Gecko: f65d3ccbe8a2
Version: 38.0a1 (3.0)
Firmware: V18D-1
User Agent: Mozilla/5.0 (Mobile; rv:38.0) Gecko/38.0 Firefox/38.0

First broken B2G-Inbound build:
Device: Flame 3.0 Master
Build ID: 20150202203724
Gaia: 17f26246ee75f8eae1399ad78630c9556aaecd75
Gecko: 354e89010328
Version: 38.0a1 (3.0)
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:38.0) Gecko/38.0 Firefox/38.0


Working Gaia with Broken Gecko issue does NOT reproduce:
Gaia: 18e3f2f8f7c254e3b08a45e14ec8e5940bd46884
Gecko: 354e89010328

Working Gecko with Broken Gaia issue DOES reproduce:
Gaia: 17f26246ee75f8eae1399ad78630c9556aaecd75
Gecko: f65d3ccbe8a2


B2G-Inbound Pushlog:
https://github.com/mozilla-b2g/gaia/compare/18e3f2f8f7c254e3b08a45e14ec8e5940bd46884...17f26246ee75f8eae1399ad78630c9556aaecd75


Issue may have been caused by bug 1124216
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(ktucker)
Keywords: regressionwindow-wanted
Alive, can you look at this please? Looks like the work done on bug 1124216 might have caused this issue to occur.
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(ktucker) → needinfo?(alive)
Dupe, thanks!
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Flags: needinfo?(alive)
Resolution: --- → DUPLICATE
Duplicate of bug: 1129329

Updated

4 years ago
blocking-b2g: 2.2? → ---
You need to log in before you can comment on or make changes to this bug.