Slow down, hang, then browser window disappears

RESOLVED WORKSFORME

Status

()

Core
Widget: Gtk
--
critical
RESOLVED WORKSFORME
3 years ago
3 years ago

People

(Reporter: Manuel Strehl, Unassigned)

Tracking

({hang})

35 Branch
x86_64
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(crash signature)

Attachments

(1 attachment)

2.12 KB, application/x-compressed-tar
Details
(Reporter)

Description

3 years ago
I have a strange behavior on two separate Linux machines (one running Linux Mint/Mate w/ Intel graphics card, the other Kubuntu/KDE w/ AMD card), both 64 bit.

After a random amount of time, usually shortly after focusing a tab previously opened in the background, the browser becomes slow, then quickly unresponsive. After 3 to 5 seconds the browser window completely disappears. That is, it seems as if Firefox was ended. The window manager removes the Firefox window.

In the process list, however, the firefox process is still alive and kicking, and shows no strange behavior (like 100% CPU or such).

Killing it regularly with

    $ kill <fx-pid>

works perfectly, and then starting Firefox again works as if nothing happened.

The bug is (as far as I can tell) independent of the visited site.

I apologize for this rather vague report. If I can provide any other metrics, just ask. I'll gladly try to get those. The bug appears roughly every third day.

Plugin situation: All plugins including Flash (but not OpenH264) are deactivated. Add-ons are just:

Name: Digraphen
ID: digraphs__at__boldewyn.de

Name: Disable Ctrl-Q Shortcut
ID: dcqs__at__moongiraffe.net

Name: Dummy Lipsum
ID: dummylipsum__at__sogame.cat

Name: Flashblock
ID: {3d7eb24f-2740-49df-8937-200b1cc08f8a}

Name: Html Validator
ID: {3b56bcc7-54e5-44a2-9b44-66c3ef58c13e}

Name: JSONView
ID: jsonview__at__brh.numbera.com

Name: Rainbow
ID: rainbow__at__colors.org

Name: Send Link in context menu
ID: sendlinkincontextmenu__at__jasnapaka.com
There is nothing that we can do here unless we can reproduce the issue. 
You can try to disable the hardware acceleration in options/advanced/general and as next step without addons
(Reporter)

Comment 2

3 years ago
Yes, I feared so. I've disabled hardware acceleration now and report back, if anything changes (or not).
(Reporter)

Comment 3

3 years ago
So, I can rule out hardware acceleration. Disabled for a week, and three times the behavior appeared. Next stop is disabling plugins.
(Reporter)

Comment 4

3 years ago
Here I am again. Add-ons were disabled, and yet the issue occurs. Any idea, what I could check? Perhaps anything, that I could query via the CLI? Because, as said above, the process is still there albeit w/o visible window.
Sorry but I don't know how to proceed at this point if it still happens without addons+hwa and without reliable steps to reproduce :-(

Comment 6

3 years ago
Try crashing the hung Firefox as described in https://developer.mozilla.org/en-US/docs/How_to_Report_a_Hung_Firefox or with kill/killall/pkill -ILL
(Reporter)

Comment 7

3 years ago
Thanks for the hint! I didn't have to wait long, though: https://crash-stats.mozilla.com/report/index/8de13dd1-a18f-4e07-ba91-0cdfa2150311

The (still running) firefox process was killed with kill -n SIGABRT.

Note, that this crash appeared on a file: page, but usually it's just regular https?: pages, so that has most likely nothing to say.

Comment 9

3 years ago
Thanks.
Severity: normal → critical
Crash Signature: [@ libc-2.17.so@0xdd95d ]
Component: Untriaged → Widget: Gtk
Keywords: crashreportid, hang
Product: Firefox → Core
Summary: Browser window disappears unexpectedly → Slow down, hang, then browser window disappears
The stacks show the browser waiting for more input, but there's not going to be much input if there is no window.

Perhaps you can use xlsclients, xrestop, and xwininfo -tree -root to see whether there is still an X connection and what windows are still open, but I'm very short on ideas.
(Reporter)

Comment 11

3 years ago
Created attachment 8576592 [details]
output of X diagnosis tools

I've added the output of those three tools. Firefox is present in all three.

In xwininfo, one of the Firefox window entries has a geometry of 10x10+-100+-100, pushing it off the canvas, and none has a fullscreen geometry like Thunderbird's in line 110.
(Reporter)

Comment 12

3 years ago
For what it's worth, here is a crash report from my second machine (Kubuntu), where the same problem appears:

https://crash-stats.mozilla.com/report/index/2f1b2e60-8d99-49dd-bd52-6d7ad2150327
(Reporter)

Comment 13

3 years ago
OK, so I hadn't had crashes since updating to v38. Seems by whatever strange coincidence to be fixed. Should I just close the bug?

Comment 14

3 years ago
closing per comment 3
Status: UNCONFIRMED → RESOLVED
Last Resolved: 3 years ago
Keywords: crashreportid
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.