Link properties and spelling dialogs - listbox (tree) height is not set correctly from "rows" or "min-height" style attribute settings

VERIFIED FIXED in mozilla0.9.8

Status

SeaMonkey
Composer
VERIFIED FIXED
16 years ago
13 years ago

People

(Reporter: andreww, Assigned: Charles Manske)

Tracking

Trunk
mozilla0.9.8

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments, 1 obsolete attachment)

(Reporter)

Description

16 years ago
if you have many anchors in a page, the listbox text overflows the area 
allocated to it in the link properties dialog.
(Reporter)

Comment 1

16 years ago
Created attachment 59923 [details]
creen shot of problem

screen shot of problem
(Assignee)

Comment 2

16 years ago
Thanks for filing this for me! I've been distracted and forgot to do it since we
talked.
(Reporter)

Comment 3

16 years ago
cc'ing some folks who might know more about what's going on.
(Reporter)

Updated

16 years ago
Target Milestone: --- → mozilla0.9.9
(Assignee)

Comment 4

16 years ago
*** Bug 112895 has been marked as a duplicate of this bug. ***
(Assignee)

Comment 5

16 years ago
*** Bug 103621 has been marked as a duplicate of this bug. ***
(Reporter)

Comment 6

16 years ago
note to self - construct a simpler test case xul file.
(Assignee)

Comment 7

16 years ago
Note: The XUL for the Link Properties dialog "listbox" is:
        <tree rows="4" class="list" id="NamedAnchorList"
onselect="SelectNamedAnchor()" style="min-height: 4em">
          <treecolgroup><treecol flex="1"/></treecolgroup>
The <treechildren> ... <treecell> members are added at runtime.
The basic issue is that neither the "rows" attribute nor the setting of
min-height by the style attribute seem to work. The actual height of the box 
around the entire tree seems to be about 2.5em (Modern skin), thus the last 2 
items in the list draw outside the enclosing box.
Note that the Spell Check dialog also has this problem (there, rows="8" and I 
also set min-height on the tree at 8em), this is a bugscape bug.
(Assignee)

Comment 8

16 years ago
improving the summary
Summary: link properties dialog - text overflows on anchors → link properties dialog - listbox (tree) height is not set correctly from "rows" or "min-height" style attribute settings

Comment 9

16 years ago
this was also reproduced on Mac OS X build 2001121805.80.
(Assignee)

Comment 10

16 years ago
Modified summary to add "Spelling" dialog, since that shows the same problem
Summary: link properties dialog - listbox (tree) height is not set correctly from "rows" or "min-height" style attribute settings → Link properties and spelling dialogs - listbox (tree) height is not set correctly from "rows" or "min-height" style attribute settings
(Assignee)

Comment 11

16 years ago
*** Bug 111312 has been marked as a duplicate of this bug. ***
(Reporter)

Comment 12

16 years ago
Setting dependancy. I belive this issue should disappear when  listbox is 
implemented.
Depends on: 110115

Comment 13

16 years ago
Bug 111312 for Mail Client is marked as duplicate of this one. This is just a
note not to forget to test Mail also when verify it from Browser.
(Assignee)

Comment 14

16 years ago
Correcting dependency bug number :)
Depends on: 110155
No longer depends on: 110115

Comment 15

16 years ago
There are old styles in EditorDialogs.css for tree.list which set borders and
dimensions. If you remove them then the dialog displays perfectly.
No longer depends on: 110155
(Assignee)

Comment 16

16 years ago
Thanks, Neil! While we should convert to the new "list" widget when available,
we have a fix now for this problem.
Assignee: andreww → cmanske
Target Milestone: mozilla0.9.9 → mozilla0.9.8
(Assignee)

Comment 17

16 years ago
Created attachment 63604 [details] [diff] [review]
Remove bad CSS rules and extra style attributes in dialogs

Note that in the spelling dialog, there's a problem with sizing the dialog
if we simply remove the CSS in editorDialog.css -- buttons on bottom are cut
off.
Changing number of rows to 6 fixes this (that is what we had originally
anyway).
(Assignee)

Comment 18

16 years ago
Neil: review please?
Status: NEW → ASSIGNED
Keywords: patch, review
OS: Mac System 9.x → All
Whiteboard: FIX IN HAND, need r=, sr=
(Assignee)

Comment 19

16 years ago
Created attachment 63605 [details] [diff] [review]
Updated patch: Remove style in both lists in EdLinkProps.xul
Attachment #63604 - Attachment is obsolete: true
(Reporter)

Comment 20

16 years ago
Comment on attachment 63605 [details] [diff] [review]
Updated patch: Remove style in both lists in EdLinkProps.xul

looks good to me. Removing inline styles is always a plus!

r=andreww
Attachment #63605 - Flags: review+
(Assignee)

Updated

16 years ago
Whiteboard: FIX IN HAND, need r=, sr= → FIX IN HAND, need sr=

Comment 21

16 years ago
Comment on attachment 63605 [details] [diff] [review]
Updated patch: Remove style in both lists in EdLinkProps.xul

sr=hewitt
Attachment #63605 - Flags: superreview+
(Assignee)

Comment 22

16 years ago
checked in
Status: ASSIGNED → RESOLVED
Last Resolved: 16 years ago
Keywords: patch, review
Resolution: --- → FIXED
Whiteboard: FIX IN HAND, need sr=

Comment 23

16 years ago
Verified on trunk build 2002013003.

If anyone is still seeing this problem, please reopen this bug.
Status: RESOLVED → VERIFIED
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.