Fix consumers in /mail and /mailnews that call Map/Set/WeakMap constructors without "new"

RESOLVED FIXED in Thunderbird 38.0

Status

defect
RESOLVED FIXED
4 years ago
4 years ago

People

(Reporter: philip.chee, Assigned: aryx)

Tracking

Trunk
Thunderbird 38.0

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

4 years ago
+++ This bug was initially created as a clone of Bug #1108930 +++

(similar to bug 980962)

Before fixing bug 1062075 and bug 1083752,
need to add "new" to all of those calls in tree.

Comment 1

4 years ago
I can see about 2 occurrences of var X = Map() in /mailnews and one in /suite.
Assignee: nobody → archaeopteryx
Status: NEW → ASSIGNED
Posted patch patch, v1Splinter Review
Attachment #8559946 - Flags: review?(mkmelin+mozilla)
Comment on attachment 8559946 [details] [diff] [review]
patch, v1

Review of attachment 8559946 [details] [diff] [review]:
-----------------------------------------------------------------

These look good to me! r=mkmelin
Attachment #8559946 - Flags: review?(mkmelin+mozilla) → review+
checkin-needed, or do you want to land it yourself?
Flags: needinfo?(archaeopteryx)
Duplicate of this bug: 1133412
Pushed as http://hg.mozilla.org/comm-central/rev/39f54c7e9e27 - had been waiting for greener XPCshell tests before.
Flags: needinfo?(archaeopteryx)
Status: ASSIGNED → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → FIXED
Target Milestone: --- → Thunderbird 38.0
You need to log in before you can comment on or make changes to this bug.