All users were logged out of Bugzilla on October 13th, 2018

Link to Adobe CDM's license page from Add-ons Manager

VERIFIED FIXED in Firefox 37

Status

()

VERIFIED FIXED
4 years ago
3 years ago

People

(Reporter: cpeterson, Assigned: spohl)

Tracking

unspecified
mozilla39
Points:
---
Dependency tree / graph
Bug Flags:
in-testsuite -

Firefox Tracking Flags

(firefox37 fixed, firefox38 fixed, firefox39 fixed)

Details

Attachments

(2 attachments, 1 obsolete attachment)

(Reporter)

Description

4 years ago
Adobe needs to give us the URL to their CDM license.
(Assignee)

Updated

4 years ago
See Also: → bug 624602
(Assignee)

Comment 1

4 years ago
Joe Steele confirmed in bug 1130682 that the EULA URL will be the following:

> EULA URL:  http://help.adobe.com/en_US/primetime/drm/HTML5_CDM_EULA/index.html

Joe, will you detect the user's locale on your end and redirect to a localized version of the EULA? Or do you need us to change the "en_US" in the URL and replace it with the correct locale?
Flags: needinfo?(steele)

Comment 2

4 years ago
Ah -- good point. If you can replace the "en_US" with the correct locale that would be great. I will let our tech ops know what to expect.
Flags: needinfo?(steele)
(Reporter)

Comment 3

4 years ago
Joe, do you know which languages Adobe will translate the EULA into?

Firefox is available in 90 locales [1] (including Esperanto :). I assume Adobe won't translate the EULA to 90 languages, so beware that your server should expect URL requests that are 404 and should be redirected to en_US or something appropriate.

[1] https://www.mozilla.org/en-US/firefox/all/
[2] http://ftp.mozilla.org/pub/mozilla.org/firefox/releases/36.0b8/win32/
Flags: needinfo?(steele)
Is the URL available at an https:// URL? I think we'd very much prefer to have links using secure connections whenever possible.

Unfortunately https://help.adobe.com/ just yields a browser error page, as the cert is sending is only valid for some Akamai domains. Perhaps that's fixable?

Comment 5

4 years ago
Asking both questions internally -- stay tuned.
Flags: needinfo?(steele)

Updated

4 years ago
Flags: needinfo?(steele)
(Assignee)

Comment 6

4 years ago
Georg correctly pointed out that we'll need the ability to localize the string for the link to the license in the addons manager, i.e. "License Information". I'll tackle this as part of this bug here.
(Reporter)

Comment 7

4 years ago
Joe says that Adobe does not usually localize their licenses, but the license landing page can be localized based. on the client locale.

Joe: would Adobe prefer to identify the client locale using the "Accept-Language" HTTP request header or a locale string in the license URL?
(Reporter)

Updated

4 years ago
Blocks: 1083662
OS: Mac OS X → Windows Vista
(Assignee)

Comment 8

4 years ago
Created attachment 8566500 [details] [diff] [review]
1. Add ability to localize license info and URL

This adds the ability to localize the license info text ("License information") in the addons manager as well as the actual license URLs. I don't know if OpenH264 will eventually host their licenses on a remote server, so I have to assume that we will support both localized (added to plugins.properties) and non-localized (embedded directly in GMPProvider.jsm) license URLs for now.

I will add the actual URL for Adobe EME in a subsequent patch once we get the answers to comment 3, comment 4 and comment 7.

There are many different ways to solve this. Georg, what do you think about this approach?
Attachment #8566500 - Flags: review?(gfritzsche)
(Assignee)

Comment 9

4 years ago
(In reply to Chris Peterson [:cpeterson])
> OS: Mac OS X → Windows Vista

Was this supposed to be "All" (same in bug 1130682)?
Flags: needinfo?(cpeterson)
(Reporter)

Updated

4 years ago
Flags: needinfo?(cpeterson)
OS: Windows Vista → All
Hardware: x86 → All
Comment on attachment 8566500 [details] [diff] [review]
1. Add ability to localize license info and URL

Review of attachment 8566500 [details] [diff] [review]:
-----------------------------------------------------------------

::: dom/locales/en-US/chrome/plugins.properties
@@ +27,5 @@
>  openH264_description=Play back web video and use video chats.
>  
>  eme-adobe_name=Primetime Content Decryption Module provided by Adobe Systems, Incorporated
>  eme-adobe_description=Play back protected web video.
> +eme-adobe_license_url=

I don't think we will need to localize the URL.
E.g. we can just submit the locale as part of the URL if needed, etc.

::: toolkit/mozapps/extensions/internal/GMPProvider.jsm
@@ +545,5 @@
> +    // localized license URL.
> +    let licenseURL = aPlugin.licenseURL;
> +    try {
> +      licenseURL = pluginsBundle.GetStringFromName(aPlugin.licenseURL);
> +    } catch (ex) { }

We should avoid always hitting the string bundle, but if we don't localize the URL that point is moot.
Attachment #8566500 - Flags: review?(gfritzsche)
(Assignee)

Comment 11

4 years ago
(In reply to Georg Fritzsche [:gfritzsche] from comment #10)
> Comment on attachment 8566500 [details] [diff] [review]
> 1. Add ability to localize license info and URL
> 
> Review of attachment 8566500 [details] [diff] [review]:
> -----------------------------------------------------------------
> 
> ::: dom/locales/en-US/chrome/plugins.properties
> @@ +27,5 @@
> >  openH264_description=Play back web video and use video chats.
> >  
> >  eme-adobe_name=Primetime Content Decryption Module provided by Adobe Systems, Incorporated
> >  eme-adobe_description=Play back protected web video.
> > +eme-adobe_license_url=
> 
> I don't think we will need to localize the URL.
> E.g. we can just submit the locale as part of the URL if needed, etc.


Okay, since we'll be uplifting things to FF 37 I've gone ahead and filed bug 1134831 to cover the "License information" string. We'll handle the license URL here, and will submit the locale as part of the URL if necessary.
(Assignee)

Updated

4 years ago
Attachment #8566500 - Attachment is obsolete: true
(Assignee)

Comment 12

4 years ago
Created attachment 8568077 [details] [diff] [review]
Patch
Attachment #8568077 - Flags: review?(gfritzsche)
Comment on attachment 8568077 [details] [diff] [review]
Patch

I don't see myself getting to other reviews before i leave, sorry.
Dave, can you maybe review this?
Attachment #8568077 - Flags: review?(gfritzsche) → review?(dtownsend)
Attachment #8568077 - Flags: review?(dtownsend) → review+
(Assignee)

Comment 15

4 years ago
Comment on attachment 8568077 [details] [diff] [review]
Patch

Approval Request Comment
[Feature/regressing bug #]: Adobe EME
[User impact if declined]: The addons manager will not display a link to the Adobe EME license.
[Describe test coverage new/current, TreeHerder]: This was a simple URL change. Successfully tested locally.
[Risks and why]: none
[String/UUID change made/needed]: none
Attachment #8568077 - Flags: approval-mozilla-beta?
Attachment #8568077 - Flags: approval-mozilla-aurora?
(Assignee)

Comment 16

4 years ago
Comment on attachment 8568077 [details] [diff] [review]
Patch

This will need a separate patch for beta. Clearing a?.
Attachment #8568077 - Flags: approval-mozilla-beta?
(Assignee)

Comment 17

4 years ago
Created attachment 8570649 [details] [diff] [review]
Patch for beta

Approval Request Comment
[Feature/regressing bug #]: Adobe EME
[User impact if declined]: The addons manager will not display a link to the Adobe EME license.
[Describe test coverage new/current, TreeHerder]: This was a simple URL change. Successfully tested locally.
[Risks and why]: none
[String/UUID change made/needed]: none
Attachment #8570649 - Flags: review+
Attachment #8570649 - Flags: approval-mozilla-beta?
Comment on attachment 8570649 [details] [diff] [review]
Patch for beta

Trivial change. Beta+
Attachment #8570649 - Flags: approval-mozilla-beta? → approval-mozilla-beta+
Attachment #8568077 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+
https://hg.mozilla.org/releases/mozilla-aurora/rev/4f4d508e1c7d
status-firefox38: --- → fixed
Flags: in-testsuite-
https://hg.mozilla.org/mozilla-central/rev/6e201e1c7102
Status: NEW → RESOLVED
Last Resolved: 4 years ago
status-firefox39: --- → fixed
Resolution: --- → FIXED
Target Milestone: --- → mozilla39
(Reporter)

Comment 22

4 years ago
Joe: the Primetime EULA page [1] is still 404. We will need a real web page here before we start public beta testing. Do you have an ETA from Adobe Legal?

[1] http://help.adobe.com/en_US/primetime/drm/HTML5_CDM_EULA/index.html

Comment 23

3 years ago
This has been working for some time now. Are you still seeing an issue?
(Reporter)

Comment 24

3 years ago
Thanks, Joe. The link works for me now. I'm resolving this bug as "verified fixed".
Status: RESOLVED → VERIFIED
Flags: needinfo?(steele)
You need to log in before you can comment on or make changes to this bug.