OSX: SVG graphic isn't recieving mouse events properly in a table (100 %) width

RESOLVED WORKSFORME

Status

P3
normal
RESOLVED WORKSFORME
17 years ago
9 years ago

People

(Reporter: chrispetersen, Assigned: peterl-bugs)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(3 attachments)

(Reporter)

Description

17 years ago
Build: 2001-11-30-08
Platform: Mac OS X
Expected results: Portions of SVG pie chart should highlight during a mouse over
event.

What I got: These events don't seem to be sent to plugin when mouse hovers over
the specified area. No highlighting of pie chart SVG takes place.

Steps to reproduce:
* You must have Adobe's svg 3.0 plug-in installed. Go to
http://www.adobe.com/svg/viewer/install/

1) Go to http://http://corda.com/d/

2) Pie chart appears on appears on Page "Food Sales for 2000"

3) Move mouse over the various regions of chart.

4) Each region should display popup text label and highlight. But, then isn't
happening in the current build.
(Reporter)

Comment 1

17 years ago
Created attachment 59960 [details]
Reduced test case of problem

SVG graphic inside a table that contains two TD elements.
(Reporter)

Comment 2

17 years ago
Created attachment 59962 [details]
Sample svg that is neeed for test case

Save this file with the test case
(Reporter)

Comment 3

17 years ago
Created attachment 59963 [details]
Same test case that removes a portion of the pctext in the first TD element

Removing additional text in the first TD element seems to solve this problem.
If you resize the window larger horizontally with this test, the svg plug-in
appears to recieve the mouse events.
(Reporter)

Comment 4

17 years ago
Changed URL

Comment 5

17 years ago
-->peterl
Assignee: av → peterl
Priority: -- → P3
Summary: SVG graphic isn't recieving mouse events properly in a table (100 %) width → OSX: SVG graphic isn't recieving mouse events properly in a table (100 %) width
Target Milestone: --- → mozilla1.0

Comment 6

17 years ago
Bugs targeted at mozilla1.0 without the mozilla1.0 keyword moved to mozilla1.0.1 
(you can query for this string to delete spam or retrieve the list of bugs I've 
moved)
Target Milestone: mozilla1.0 → mozilla1.0.1
(Reporter)

Comment 7

17 years ago
Looks like this problem has been resolved by a newer release of the Adode SVG
plugin (3.0x76). Works properly with Dec 3 build (2001-12-03-08) under Mac OS X
10.1.1.
Status: NEW → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → WORKSFORME

Updated

9 years ago
Component: Plug-ins → Other
Product: Core → Plugins
Target Milestone: mozilla1.0.1 → ---
Version: Trunk → unspecified
You need to log in before you can comment on or make changes to this bug.