Geolocation is disabled by default in FTU

VERIFIED FIXED

Status

VERIFIED FIXED
4 years ago
4 years ago

People

(Reporter: viorela, Unassigned)

Tracking

({qablocker, regression})

unspecified
ARM
Gonk (Firefox OS)
qablocker, regression

Firefox Tracking Flags

(blocking-b2g:2.5?, b2g-master verified)

Details

(Reporter)

Description

4 years ago
In FTU app the geolocation option is enabled by default. 
This behavior is reproducible manually, reproduction rate 5/5 

#STR:
1. open FTU app
2. tap next until you reach Geolocation section

#Expected result:
Geolocation is enabled 

#Actual result:
Geolocation is disabled

This is causing failure in test_ftu_skip_tour.py (smoketest): http://jenkins1.qa.scl3.mozilla.com/job/flame-kk-319.mozilla-central.nightly.ui.functional.smoke/5/HTML_Report/

Regression range, on b2g-inbound:
Last working build:
Device firmware (base) 	L1TC100118D0
Device firmware (date) 	04 Feb 2015 07:57:11
Device firmware (incremental) 	eng.cltbld.20150204.105700
Device firmware (release) 	4.4.2
Device identifier 	flame
Gaia date 	04 Feb 2015 04:58:34
Gaia revision 	70922d07e1de
Gecko build 	20150204065025
Gecko revision 	c09b015679b2
Gecko version 	38.0a1

First failing build:
Device firmware (base) 	L1TC100118D0
Device firmware (date) 	04 Feb 2015 07:57:11
Device firmware (incremental) 	eng.cltbld.20150204.105700
Device firmware (release) 	4.4.2
Device identifier 	flame
Gaia date 	04 Feb 2015 08:29:57
Gaia revision 	b9607aef7deb
Gecko build 	20150204085825
Gecko revision 	35be56b517c8
Gecko version 	38.0a1

Gaia changes: https://github.com/mozilla-b2g/gaia/compare/70922d07e1de...b9607aef7deb
Gecko changes: http://hg.mozilla.org/integration/b2g-inbound/pushloghtml?fromchangec09b015679b2=&tochange=35be56b517c8
(Reporter)

Comment 1

4 years ago
:sfoster, do you think your patch might have caused this? (https://github.com/mozilla-b2g/gaia/commit/bc412ba2f87dcd5e3bac96f448338d8ff0ba1ba7)

Is this change intended or is it a bug? Thanks!
Flags: needinfo?(sfoster)
(In reply to Viorela Ioia [:viorela] from comment #1)
> :sfoster, do you think your patch might have caused this?
> (https://github.com/mozilla-b2g/gaia/commit/
> bc412ba2f87dcd5e3bac96f448338d8ff0ba1ba7)
> 
> Is this change intended or is it a bug? Thanks!

First, no there was no intentional change to the initial geolocation value. My patch did touch the UI for representing and setting the geolocation preference so it sounds plausible that I broke this, but so far I don't see how. Also, I don't see this failure in the Gaia-Try run: https://treeherder.mozilla.org/#/jobs?repo=gaia-try&revision=4e6c62fce0fa
Flags: needinfo?(sfoster)
So I see why this is failing. In the disable_geolocation method at https://github.com/mozilla-b2g/gaia/blob/master/tests/python/gaia-ui-tests/gaiatest/apps/ftu/app.py#L264, we tap the control to disable it. The geolocation.enabled setting is initially true, but in the UI the checkbox is initially unchecked. So tapping it causes it to become checked and the test fails. 

What I'm trying to understand is how this was passing before my patch, as I don't yet see how my patch changed this. But I'm fighting a seperate issue which is impeding my ability to test this on my device to investigate further - to confirm that without my patch the geolocation checkbox appeared initially checked. 

We can certainly back out in the meantime.
(In reply to Sam Foster [:sfoster] from comment #3)
> So I see why this is failing. In the disable_geolocation method at
> https://github.com/mozilla-b2g/gaia/blob/master/tests/python/gaia-ui-tests/
> gaiatest/apps/ftu/app.py#L264, we tap the control to disable it. The
> geolocation.enabled setting is initially true, but in the UI the checkbox is
> initially unchecked. So tapping it causes it to become checked and the test
> fails. 
> 
> What I'm trying to understand is how this was passing before my patch, as I
> don't yet see how my patch changed this. But I'm fighting a seperate issue
> which is impeding my ability to test this on my device to investigate
> further - to confirm that without my patch the geolocation checkbox appeared
> initially checked. 
> 
> We can certainly back out in the meantime.

can you please back this out on master in that case ? Our next build for QA is set to trigger at 4pm PT, so either we need a forward fix or backout to happen before that.
Flags: needinfo?(sfoster)
Merged backout: https://github.com/mozilla-b2g/gaia/commit/94af4b42d2ace6c9f38f31de77240604fac68af1
The revert: 7cc494249ecfc3e629f281b846d03844057f8975
Flags: needinfo?(sfoster)
[Blocking Requested - why for this release]:
Fails automation smoketest, not an intended change in functionality.


setting resolved fixed due to the backout at Comment 5.  Please verify.
Status: NEW → RESOLVED
blocking-b2g: --- → 3.0?
Last Resolved: 4 years ago
Keywords: qablocker, qaurgent, regression, verifyme
Resolution: --- → FIXED
Keywords: qawanted
QA Contact: bzumwalt
Issue verified fixed on Flame 3.0

Geolocation is enabled by default in FTU

Device: Flame 3.0 Master
Build ID: 20150206010204
Gaia: 94af4b42d2ace6c9f38f31de77240604fac68af1
Gecko: 7c5f187b65bf
Gonk: e7c90613521145db090dd24147afd5ceb5703190
Version: 38.0a1 (3.0)
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:38.0) Gecko/38.0 Firefox/38.0
Status: RESOLVED → VERIFIED
QA Whiteboard: [QAnalyst-Triage?]
status-b2g-master: --- → verified
Flags: needinfo?(ktucker)
Keywords: qaurgent, qawanted, verifyme
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(ktucker)
See Also: → bug 1130927
You need to log in before you can comment on or make changes to this bug.