[Loop] If the room call is terminated by any reason, the user *isn't* notified about that.

RESOLVED FIXED

Status

Firefox OS
Gaia::Loop
RESOLVED FIXED
3 years ago
2 years ago

People

(Reporter: lolimartinezcr, Assigned: jaoo)

Tracking

unspecified
ARM
Gonk (Firefox OS)

Firefox Tracking Flags

(ux-b2g:-)

Details

(Whiteboard: [Room1.1.1_Regression2][Not in 1.1.1])

Attachments

(1 attachment)

(Reporter)

Description

3 years ago
Fire E 2.0
Loop 1.1.1/bd1a553

Prerequisites:
User A logged in Mobile Loop application with MobileID.
User B logged in Desktop Loop application.
User A has created a room and shared with User B

STRs:
1. User A joins to room.
2. User B joins to room.-> Connection is established.
3. After a few seconds, User B hasn't connection (wifi).

Actual result:
User  A *isn't* notified about that, counter is running, and  User A can't see the message "you are first user" 

Expected result:
User A is notified about that, counter isn't running and user A can see message "you are first user".
(Reporter)

Updated

3 years ago
Whiteboard: [Room1.1.1_Regression2]
(Assignee)

Comment 1

3 years ago
Once participant B loses the internet connection participant A's device is notified with a 'connectionDestroyed' event (with reason 'networkDisconnected') and participant B leaves the room. IIRC the event is received at A after a few seconds (up 10 seconds IIRC), how much time did you wait?
Flags: needinfo?(lolimartinezcr)
(Assignee)

Comment 2

3 years ago
Confirmed the 'connectionDestroyed' event arrives a few seconds later (more than 10 seconds I wait in the test I just ran) and participant B leaves the room. The downside of participant B leaves the room abruptly (because of the network disconnection) is that participant B is not able to notify the loop server that he leaves the room and we won't see the 'you are first user' message in participant A's device.

I have to question about what to do here, should we show a message for this use case in participant A's device?, and as participant B was not able to notify the server because of the network disconnection the 'you are first user' message won't show up and there is nothing we can do, are you guys ok with that? Thanks!
Flags: needinfo?(oteo)
(Reporter)

Comment 3

3 years ago
(In reply to José Antonio Olivera Ortega [:jaoo] from comment #1)
> Once participant B loses the internet connection participant A's device is
> notified with a 'connectionDestroyed' event (with reason
> 'networkDisconnected') and participant B leaves the room. IIRC the event is
> received at A after a few seconds (up 10 seconds IIRC), how much time did
> you wait?

In my case, I wait more than a minute. After 1 minute (more or less), user A is in room but can't see the message "You are first...".
Flags: needinfo?(lolimartinezcr)
(Assignee)

Updated

3 years ago
Assignee: nobody → josea.olivera
Status: NEW → ASSIGNED
(Assignee)

Comment 4

3 years ago
Created attachment 8560430 [details] [review]
Pointer to Github PR https://github.com/mozilla-b2g/firefoxos-loop-client/pull/565
Attachment #8560430 - Flags: review?(borja.bugzilla)
Attachment #8560430 - Flags: review?(borja.bugzilla) → review+
Patch is working as expected, after some time in Device A the counter disappears and the "you are first user" message is shown.

Just to be aware of the current situation, the patch does not fix the behavior in Device B and the counter is running with the video stream frozen in that device.
When both, user A and B, leave the Room, the Room is shown as busy in Device A (room icon in blue). Even restarting the devices, the icon does not change, and if a user C tries to join that Room, he's notified that the Rool is already full.
Flags: needinfo?(oteo)
(Assignee)

Comment 6

3 years ago
Comment on attachment 8560430 [details] [review]
Pointer to Github PR https://github.com/mozilla-b2g/firefoxos-loop-client/pull/565

Requesting review again at Borja since some more bits have been added. Thanks!
Attachment #8560430 - Flags: review+ → review?(borja.bugzilla)
Attachment #8560430 - Flags: review?(borja.bugzilla) → review+
(Assignee)

Comment 7

3 years ago
Landed on master branch at https://github.com/mozilla-b2g/firefoxos-loop-client/commit/5a82c2457c2409c6b67012a0ff19e4d291170448
Status: ASSIGNED → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → FIXED
Whiteboard: [Room1.1.1_Regression2] → [Room1.1.1_Regression2][Not in 1.1.1]
Comment hidden (spam)
blocking-b2g: 2.6? → ---
tracking-b2g: backlog → ---
You need to log in before you can comment on or make changes to this bug.