Closed Bug 1129955 Opened 6 years ago Closed 6 years ago

[AccessFu] Expose name changed event for currently focused accessible.

Categories

(Core :: Disability Access APIs, defect)

defect
Not set
normal

Tracking

()

RESOLVED FIXED
mozilla38
Tracking Status
firefox36 --- wontfix
firefox37 --- wontfix
firefox38 --- fixed
b2g-v2.2 --- fixed
b2g-master --- fixed

People

(Reporter: yzen, Assigned: yzen)

References

Details

Attachments

(1 file)

AccessFu should output the name change accessible event for the current virtual cursor position accessibles.
Attached patch 1129955 patch v1Splinter Review
Attachment #8559830 - Flags: review?(eitan)
Comment on attachment 8559830 [details] [diff] [review]
1129955 patch v1

Review of attachment 8559830 [details] [diff] [review]:
-----------------------------------------------------------------

Looks good!

::: accessible/tests/mochitest/jsat/doc_content_integration.html
@@ +87,5 @@
>      </div>
>      <div id="appframe"></div>
>    </div>
>    <button id="home">Home</button>
> +  <button id="toggle" aria-label="toggle"></button>

The name 'toggle'/'toggled' is a bit misleading. Maybe something more benign like fruit? This could be confusing with aria-checked/aria-pressed, and roles in general.
Attachment #8559830 - Flags: review?(eitan) → review+
https://hg.mozilla.org/mozilla-central/rev/d9f7bafe9b47
Status: NEW → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla38
Comment on attachment 8559830 [details] [diff] [review]
1129955 patch v1

NOTE: Please see https://wiki.mozilla.org/Release_Management/B2G_Landing to better understand the B2G approval process and landings.

[Approval Request Comment] This a screen reader fix that addressed bug 1069476
Bug caused by (feature/regressing bug #): improvement, not a bug
User impact if declined: The screen reader user will not know if description/text changes for the elements (such as buttons) that the screen reader is positioned on.
Testing completed: Added a11y mochitests + manual
Risk to taking this patch (and alternatives if risky): low risk
String or UUID changes made by this patch: None
Attachment #8559830 - Flags: approval-mozilla-b2g37?
Attachment #8559830 - Flags: approval-mozilla-b2g37? → approval-mozilla-b2g37+
You need to log in before you can comment on or make changes to this bug.