Mozmill test failure 'Notification popup state has been opened' in testPrivateBrowsing/testPrivateDownloadPanel.js due to small browser window size

RESOLVED FIXED

Status

Mozilla QA
Mozmill Tests
RESOLVED FIXED
3 years ago
3 years ago

People

(Reporter: Teodor Druta, Assigned: Teodor Druta)

Tracking

Version 2

Firefox Tracking Flags

(firefox38 fixed)

Details

(URL)

Attachments

(1 attachment)

(Assignee)

Description

3 years ago
This test is failing on Linux with Nightly because the downloads panel element is not visible, hence not clickable on smaller browser window sizes.
We'll fix this test by maximizing the window size in setupModule and then restoring it in teardownModule.
This should be fixed on all the platforms not just on Linux, because it can be reproduced on all the platforms locally.
(Assignee)

Comment 1

3 years ago
Created attachment 8559862 [details] [diff] [review]
fixprivatedownloadpanel.patch

This patch will fix this issue by maximizing() both private and non-private browser windows on test start.
Attachment #8559862 - Flags: review?(mihaela.velimiroviciu)
Attachment #8559862 - Flags: review?(andreea.matei)
Attachment #8559862 - Flags: review?(mihaela.velimiroviciu)
Attachment #8559862 - Flags: review?(andreea.matei)
Attachment #8559862 - Flags: review+
https://hg.mozilla.org/qa/mozmill-tests/rev/8396c41ae9fc (default)
Status: ASSIGNED → RESOLVED
Last Resolved: 3 years ago
status-firefox38: affected → fixed
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.