Closed Bug 1130056 Opened 10 years ago Closed 9 years ago

Right clicking in the search field brings up two menus one overlapping the other

Categories

(Firefox :: Search, defect)

35 Branch
x86_64
Linux
defect
Not set
normal

Tracking

()

RESOLVED DUPLICATE of bug 1103455

People

(Reporter: matt, Unassigned)

Details

Attachments

(2 files)

Attached image firefox bug.png
User Agent: Mozilla/5.0 (X11; Ubuntu; Linux x86_64; rv:35.0) Gecko/20100101 Firefox/35.0
Build ID: 20150125221831

Steps to reproduce:

Type in search term, select text, right click to perform text action (cut, copy, etc.) and two menus come up.


Actual results:

Two overlapping menus show up 


Expected results:

Just the text action menu showing up
Better screenshot
Mozilla/5.0 (X11; Ubuntu; Linux x86_64; rv:37.0) Gecko/20100101 Firefox/37.0
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:37.0) Gecko/20100101 Firefox/37.0

I can't reproduce this. Please check if you have the same problem in the latest version of Firefox, in a brand new profile.
https://support.mozilla.org/kb/profile-manager-create-and-remove-firefox-profiles
Component: Untriaged → Search
Flags: needinfo?(matt)
Flags: needinfo?(gtjacobson+bugzilla)
It appears to be fixed in the latest version. Thanks.
Flags: needinfo?(gtjacobson+bugzilla)
After using it a bit, I've managed to reproduce the bug. Have some text in the search input and rapidly left click then right click on it. The context menu loads faster than the search results so it appears first, then the search results appear on top of it.
(In reply to Gary from comment #4)
> Have some text in the search input and rapidly left click then right click on it.

I'd also tried that the first time around. Despite my best efforts, the search engine suggestions always disappear before the context menu pops up: the two menus never overlap.
I believe it's a race condition. Maybe your internet is too fast :) Could you try using a proxy to slow down the search engine suggestions?
(In reply to Gary from comment #3)
> It appears to be fixed in the latest version. Thanks.

Fixed by bug 1103455 most likely.

Comment 4 may be due to bug 1190311, and edge case of the first bug that isn't fixed yet.
Status: UNCONFIRMED → RESOLVED
Closed: 9 years ago
Resolution: --- → DUPLICATE
Flags: needinfo?(matt)
You need to log in before you can comment on or make changes to this bug.

Attachment

General

Creator:
Created:
Updated:
Size: