Let extensions discover the shared container identifier dynamically

RESOLVED DUPLICATE of bug 1124489

Status

()

Firefox for iOS
Build & Test
RESOLVED DUPLICATE of bug 1124489
3 years ago
3 years ago

People

(Reporter: st3fan, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

3 years ago
Currently we have ExtensionUtils.sharedContainerIdentifier() which returns a fixed string. Because we are now going to have different bundle identifiers based on the release channel, we should discover this identifier at runtime. This is easily done by looking at the current Bundle identifier and transforming it into a container identifier.
(Reporter)

Updated

3 years ago
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1124489
You need to log in before you can comment on or make changes to this bug.