right aligned text goes past edge of table

RESOLVED DUPLICATE of bug 110243

Status

()

Core
Layout: Tables
--
minor
RESOLVED DUPLICATE of bug 110243
16 years ago
16 years ago

People

(Reporter: Daniel Quinlan, Assigned: karnaze (gone))

Tracking

({testcase})

Trunk
x86
All
testcase
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

(Reporter)

Description

16 years ago
About half of the last character in the first TD element of this table spills
over the right edge of the table.  Some of the table elements are included
because they make the problem much more visible (specifically, BORDER=0,
CELLSPACING=0, and a background color).

I first saw this on a much larger table, but this is a much more minimal test
case.

----------------------------------------------------------
<HTML>
<HEAD>
<TITLE>table test case</TITLE>
</HEAD>
<BODY BGCOLOR="#ffffff">
<P>
<TABLE BORDER=0 CELLSPACING=0 BGCOLOR="#99ccff">
<TR>
<TH ALIGN=RIGHT>test string
<TR>
<TD ALIGN=RIGHT>x
</TABLE>
</BODY
</HTML>
----------------------------------------------------------

If you want a screen shot or further settings needed to reproduce the
rendering error, please let me know.  (It looks the same under both
Galeon 1.0 and Mozilla 0.9.6.)

Comment 1

16 years ago
Created attachment 60004 [details]
reporter's HTML code

Comment 2

16 years ago
Reporter: Please always specify which "Build ID" you're using,
as found in the title bar.

I see a slight overflow to the right as well.
Build ID: 2001 11 29 03. Windows 2000.

Comment 3

16 years ago
I see it too, win98SE, 2001112903

confirming, adding testcase keyword, OS->all

further notes : for me, the text in the <td> stays within the table, but the
<th> overflows to the right.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Keywords: testcase
OS: Linux → All
(Reporter)

Comment 4

16 years ago
Created attachment 60071 [details]
additional test case

Additional test case: the rendering bug doesn't always happen in all TH
cells, doesn't have to be first element, etc.  See comments in HTML code
for additional explanation.
(Reporter)

Comment 5

16 years ago
I am using Mozilla Build ID: 2001112013 on Linux, using these RPMs downloaded
for Red Hat 6.x:

mozilla-0.9.6-0.i386.rpm  mozilla-psm-0.9.6-0.i386.rpm

Comment 6

16 years ago

*** This bug has been marked as a duplicate of 110243 ***
Status: NEW → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.