Task manager shrinking transition happens twice when long pressing home

RESOLVED WORKSFORME

Status

Firefox OS
Gaia::System::Window Mgmt
RESOLVED WORKSFORME
3 years ago
2 years ago

People

(Reporter: benfrancis, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [systemsfe])

(Reporter)

Description

3 years ago
STR:
* Long press the home button for about three seconds

Expected:
* The current window shrinks down to show a preview in the task manager

Actual:
* The window shrinking transition happens twice in quick succession

Reproduceability rate: ~50%

Tested on today's 2.2 build
Can QA reproduce?
Keywords: qawanted
Whiteboard: [systemsfe]
Unable to reproduce original issue on today's Flame 2.2 or 3.0, but am seeing something similar when opening apps from card view.

With Camera, Browser, and Marketplace open, going to card view from any of those apps and then expanding another app from task manager shows the opening animation, then card view again before actually expanding app.

Video of issue here when opening marketplace from card view: http://youtu.be/zoTWiBpMJrw

Without a video of the original issue, I can't confirm how similar the two are. Does this look similar to your issue Ben?

Reproduced opening from card view issue 3/10 tries

Reproduced original issue 0/20 tries


Device: Flame 2.2 (319mb)
Build ID: 20150407002501
Gaia: 5e09637414269728f6f1bc0152d0160f3b6b380e
Gecko: 245f37f44017
Gonk: ebad7da532429a6f5efadc00bf6ad8a41288a429
Version: 37.0 (2.2)
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:37.0) Gecko/37.0 Firefox/37.0

Device: Flame 3.0 Master (319mb)
Build ID: 20150407010204
Gaia: c710bac533b76635161315bf907d004e000549cb
Gecko: ab0490972e1e
Gonk: b83fc73de7b64594cd74b33e498bf08332b5d87b
Version: 40.0a1 (Master)
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:40.0) Gecko/40.0 Firefox/40.0
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(ktucker)
Flags: needinfo?(bfrancis)
Keywords: qawanted
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(ktucker)
(Reporter)

Comment 3

3 years ago
I think that's a separate issue, the issue I was seeing was playing the shrinking animation twice. I can't reproduce that any more on a recent 2.2 build.
Flags: needinfo?(bfrancis)
Have not seen this in some time, closing as WFM
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.