If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

build with musl libc: media/mtransport/third_party/nICEr/src/stun/addrs.c: sys/sysctl.h: No such file or directory

RESOLVED FIXED in Firefox 39

Status

()

Core
WebRTC
P5
normal
RESOLVED FIXED
3 years ago
3 years ago

People

(Reporter: Felix Janda, Assigned: Felix Janda)

Tracking

Trunk
mozilla39
Other
Other
Points:
---
Bug Flags:
firefox-backlog +

Firefox Tracking Flags

(firefox39 fixed)

Details

Attachments

(1 attachment)

(Assignee)

Description

3 years ago
User Agent: Mozilla/5.0 (X11; U; Unix; en-US) AppleWebKit/537.15 (KHTML, like Gecko) Chrome/24.0.1295.0 Safari/537.15 Surf/0.6

Steps to reproduce:

Try to build firefox on a musl libc based system. (http://musl-libc.org)


Actual results:

Build failure in media/mtransport/third_party/nICEr/src/stun/addrs.c because of missing <sys/sysctl.h>.


Expected results:

Successful compilation
(Assignee)

Comment 1

3 years ago
Created attachment 8560097 [details] [diff] [review]
Proposed fix

syscctl is only used in the '#if defined(BSD) || defined(DARWIN)' block so it can be only included there.
Attachment #8560097 - Flags: review?(blassey.bugs)
Status: UNCONFIRMED → NEW
Component: Untriaged → WebRTC
Ever confirmed: true
Product: Firefox → Core
Attachment #8560097 - Flags: review?(blassey.bugs) → review?(rjesup)
Comment on attachment 8560097 [details] [diff] [review]
Proposed fix

Review of attachment 8560097 [details] [diff] [review]:
-----------------------------------------------------------------

lateraling to ekr or bwc.  I don't see a problem with this, but this is upstream cross-platform code.
Attachment #8560097 - Flags: review?(rjesup)
Attachment #8560097 - Flags: review?(ekr)
Attachment #8560097 - Flags: review?(docfaraday)

Comment 3

3 years ago
I'm going to need to see a try push here, I think, since you're undoing part of the patch for bug 813918.

Comment 4

3 years ago
(In reply to Byron Campen [:bwc] from comment #3)
> I'm going to need to see a try push here, I think, since you're undoing part
> of the patch for bug 813918.


Indeed. I'm assuming that that conditional include is there for a reason.

Comment 5

3 years ago
Let's see what happens:

https://treeherder.mozilla.org/#/jobs?repo=try&revision=9b05683ff3a7

Comment 6

3 years ago
Well, the try build looks clean. Maybe we just don't build against that android version anymore?

Comment 7

3 years ago
So, I'm kinda confused as to why this patch would fix a build error of "sys/sysctl.h: No such file or directory". We still include that file.
Flags: needinfo?(felix.janda)
(Assignee)

Comment 8

3 years ago
With the patch the <sys/sysctl.h> include is in an "#if defined(BSD) || defined(DARWIN)" block and only in that block sysctl() is used. In particular, for linux systems it is not attempted to include <sys/sysctl.h>, which can fail when the file is missing.
Flags: needinfo?(felix.janda)

Comment 9

3 years ago
Comment on attachment 8560097 [details] [diff] [review]
Proposed fix

Review of attachment 8560097 [details] [diff] [review]:
-----------------------------------------------------------------

Ok, I'm satisfied.
Attachment #8560097 - Flags: review?(docfaraday) → review+

Updated

3 years ago
Flags: firefox-backlog+
Priority: -- → P5
(Assignee)

Updated

3 years ago
Keywords: checkin-needed
https://hg.mozilla.org/integration/mozilla-inbound/rev/af818fbea923
Assignee: nobody → felix.janda
Keywords: checkin-needed
https://hg.mozilla.org/mozilla-central/rev/af818fbea923
Status: NEW → RESOLVED
Last Resolved: 3 years ago
status-firefox39: --- → fixed
Resolution: --- → FIXED
Target Milestone: --- → mozilla39

Updated

3 years ago
Attachment #8560097 - Flags: review?(ekr)
You need to log in before you can comment on or make changes to this bug.