[CopyPaste] Prevent unwanted scrolling end event.

RESOLVED FIXED in Firefox 38

Status

()

defect
P2
normal
RESOLVED FIXED
4 years ago
4 years ago

People

(Reporter: mtseng, Assigned: mtseng)

Tracking

unspecified
mozilla38
x86
macOS
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(blocking-b2g:2.2+, firefox36 wontfix, firefox37 wontfix, firefox38 fixed, b2g-v2.2 fixed, b2g-master fixed)

Details

Attachments

(1 attachment)

Per bug 1105547 comment 15, there is 2 problem in existing code.

1. We should only send scroll start/end event only when carets are visible.
2. If we got blur event between scroll start and end. Scroll end event shouldn't be fired.
Status: NEW → ASSIGNED

Comment 4

4 years ago
blocking 2.2
blocking-b2g: --- → 2.2+
https://hg.mozilla.org/mozilla-central/rev/d892c2a1b1db
Status: ASSIGNED → RESOLVED
Closed: 4 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla38
Comment on attachment 8560259 [details] [diff] [review]
Prevent unwanted scrolling event.

NOTE: Please see https://wiki.mozilla.org/Release_Management/B2G_Landing to better understand the B2G approval process and landings.

[Approval Request Comment]
Bug caused by (feature/regressing bug #): 
User impact if declined: Copy/Paste bubble would dispear/appear randomly when scrolling.
Testing completed: on master
Risk to taking this patch (and alternatives if risky): low risk
String or UUID changes made by this patch: none
Attachment #8560259 - Flags: approval-mozilla-b2g37?
Attachment #8560259 - Flags: approval-mozilla-b2g37? → approval-mozilla-b2g37+
You need to log in before you can comment on or make changes to this bug.