Closed Bug 1130263 Opened 5 years ago Closed 5 years ago

MSE Compliance Test: Fail test 47: Seek

Categories

(Core :: Audio/Video, defect, P3)

x86
Windows 8
defect

Tracking

()

RESOLVED WORKSFORME

People

(Reporter: jya, Unassigned)

References

Details

Attachments

(1 file)

This tests never completes or fail.

TestRunner:  All tests are completed 
TestRunner:  Finished! 
TestRunner:  TestRunner.prototype.error@http://yt-dash-mse-test.commondatastorage.googleapis.com/unit-tests/js/harness/test-20150204153408.js:410:9
TestRunner.prototype.timeout@http://yt-dash-mse-test.commondatastorage.googleapis.com/unit-tests/js/harness/test-20150204153408.js:465:5
TimeoutManager/timeoutHandler@http://yt-dash-mse-test.commondatastorage.googleapis.com/unit-tests/js/harness/timeout-20150204153408.js:35:5
 
Seek:    0: (0, 80.015986) 
Seek:  sb1.buffered.length 1 
Seek:    1: (35.035, 75.075322) 
Seek:    0: (5.005, 25.025322) 
Seek:  sb0.buffered.length 2 
Seek:  ms.sb count = 2 
Seek:  video.networkState = 2 
Seek:  video.readyState = 1 
Seek:  video.currentTime = 7 
TestRunner:  Test Seek TIMED OUT! 
TestRunner:  checkEq passed: XHR length is (159087). 
TestRunner:  checkNE passed: request index is (0). 
TestRunner:  checkEq passed: XHR requestType is (GET). 
TestRunner:  checkEq passed: request index is (-1). 
TestRunner:  checkEq passed: XHR length is (158980). 
TestRunner:  checkNE passed: request index is (0). 
TestRunner:  checkEq passed: XHR requestType is (GET). 
TestRunner:  checkEq passed: request index is (-1). 
TestRunner:  checkEq passed: XHR length is (411469). 
TestRunner:  checkNE passed: request index is (0). 
TestRunner:  checkEq passed: XHR requestType is (GET). 
TestRunner:  checkEq passed: request index is (-1). 
TestRunner:  checkEq passed: XHR length is (337406). 
TestRunner:  checkNE passed: request index is (0). 
TestRunner:  checkEq passed: XHR requestType is (GET). 
TestRunner:  checkEq passed: request index is (-1). 
TestRunner:  checkEq passed: XHR length is (560289). 
TestRunner:  checkNE passed: request index is (0). 
TestRunner:  checkEq passed: XHR requestType is (GET). 
TestRunner:  checkEq passed: request index is (-1). 
TestRunner:  checkEq passed: XHR length is (686458). 
TestRunner:  checkNE passed: request index is (0). 
TestRunner:  checkEq passed: XHR requestType is (GET). 
TestRunner:  checkEq passed: request index is (-1). 
Seeking to segment index=0 time=7 start=0 length=10.00780045351474 
Seeking to segment index=1 time=7 start=5.005 length=5.005 
Seek:  Seek to 7s 
TestRunner:  checkGE passed: currentTime is (60.821224). 
TestRunner:  checkEq passed: XHR length is (158960). 
TestRunner:  checkNE passed: request index is (0). 
TestRunner:  checkEq passed: XHR requestType is (GET). 
TestRunner:  checkEq passed: request index is (-1). 
TestRunner:  checkEq passed: XHR length is (159069). 
TestRunner:  checkNE passed: request index is (0). 
TestRunner:  checkEq passed: XHR requestType is (GET). 
TestRunner:  checkEq passed: request index is (-1). 
TestRunner:  checkEq passed: XHR length is (158527). 
TestRunner:  checkNE passed: request index is (0). 
TestRunner:  checkEq passed: XHR requestType is (GET). 
TestRunner:  checkEq passed: request index is (-1). 
TestRunner:  checkEq passed: XHR length is (358541). 
TestRunner:  checkNE passed: request index is (0). 
TestRunner:  checkEq passed: XHR requestType is (GET). 
TestRunner:  checkEq passed: request index is (-1). 
TestRunner:  checkEq passed: XHR length is (494252). 
TestRunner:  checkNE passed: request index is (0). 
TestRunner:  checkEq passed: XHR requestType is (GET). 
TestRunner:  checkEq passed: request index is (-1). 
TestRunner:  checkEq passed: XHR length is (293731). 
TestRunner:  checkNE passed: request index is (0). 
TestRunner:  checkEq passed: XHR requestType is (GET). 
TestRunner:  checkEq passed: request index is (-1). 
TestRunner:  checkEq passed: XHR length is (382208). 
TestRunner:  checkNE passed: request index is (0). 
TestRunner:  checkEq passed: XHR requestType is (GET). 
TestRunner:  checkEq passed: request index is (-1). 
TestRunner:  checkEq passed: XHR length is (357762). 
TestRunner:  checkNE passed: request index is (0). 
TestRunner:  checkEq passed: XHR requestType is (GET). 
TestRunner:  checkEq passed: request index is (-1). 
TestRunner:  checkEq passed: XHR length is (296397). 
TestRunner:  checkNE passed: request index is (0). 
TestRunner:  checkEq passed: XHR requestType is (GET). 
TestRunner:  checkEq passed: request index is (-1). 
TestRunner:  checkEq passed: XHR length is (517569). 
TestRunner:  checkNE passed: request index is (0). 
TestRunner:  checkEq passed: XHR requestType is (GET). 
TestRunner:  checkEq passed: request index is (-1). 
TestRunner:  checkEq passed: XHR length is (513547). 
TestRunner:  checkNE passed: request index is (0). 
TestRunner:  checkEq passed: XHR requestType is (GET). 
TestRunner:  checkEq passed: request index is (-1). 
Seek:  Seek to 28s 
TestRunner:  checkGE passed: currentTime is (22.418842). 
TestRunner:  checkEq passed: XHR length is (158805). 
TestRunner:  checkNE passed: request index is (0). 
TestRunner:  checkEq passed: XHR requestType is (GET). 
TestRunner:  checkEq passed: request index is (-1). 
TestRunner:  checkEq passed: XHR length is (159162). 
TestRunner:  checkNE passed: request index is (0). 
TestRunner:  checkEq passed: XHR requestType is (GET). 
TestRunner:  checkEq passed: request index is (-1). 
TestRunner:  checkEq passed: XHR length is (158620). 
TestRunner:  checkNE passed: request index is (0). 
TestRunner:  checkEq passed: XHR requestType is (GET). 
TestRunner:  checkEq passed: request index is (-1). 
TestRunner:  checkEq passed: XHR length is (611704). 
TestRunner:  checkNE passed: request index is (0). 
TestRunner:  checkEq passed: XHR requestType is (GET). 
TestRunner:  checkEq passed: request index is (-1). 
TestRunner:  checkEq passed: XHR length is (616376). 
TestRunner:  checkNE passed: request index is (0). 
TestRunner:  checkEq passed: XHR requestType is (GET). 
TestRunner:  checkEq passed: request index is (-1). 
TestRunner:  checkEq passed: XHR length is (411469). 
TestRunner:  checkNE passed: request index is (0). 
TestRunner:  checkEq passed: XHR requestType is (GET). 
TestRunner:  checkEq passed: request index is (-1). 
onLoadedMetadata bypassed 
Seek:  Seek to 17s 
TestRunner:  checkEq passed: XHR length is (159087). 
TestRunner:  checkNE passed: request index is (0). 
TestRunner:  checkEq passed: XHR requestType is (GET). 
TestRunner:  checkEq passed: request index is (-1). 
TestRunner:  checkEq passed: XHR length is (158980). 
TestRunner:  checkNE passed: request index is (0). 
TestRunner:  checkEq passed: XHR requestType is (GET). 
TestRunner:  checkEq passed: request index is (-1). 
TestRunner:  checkEq passed: XHR length is (852). 
TestRunner:  checkNE passed: request index is (0). 
TestRunner:  checkEq passed: XHR requestType is (GET). 
TestRunner:  checkEq passed: request index is (-1). 
TestRunner:  checkEq passed: XHR length is (32768). 
TestRunner:  checkNE passed: request index is (0). 
TestRunner:  checkEq passed: XHR requestType is (GET). 
TestRunner:  checkEq passed: request index is (-1). 
TestRunner:  checkEq passed: XHR length is (337406). 
TestRunner:  checkNE passed: request index is (0). 
TestRunner:  checkEq passed: XHR requestType is (GET). 
TestRunner:  checkEq passed: request index is (-1). 
TestRunner:  checkEq passed: XHR length is (560289). 
TestRunner:  checkNE passed: request index is (0). 
TestRunner:  checkEq passed: XHR requestType is (GET). 
TestRunner:  checkEq passed: request index is (-1). 
TestRunner:  checkEq passed: XHR length is (686458). 
TestRunner:  checkNE passed: request index is (0). 
TestRunner:  checkEq passed: XHR requestType is (GET). 
TestRunner:  checkEq passed: request index is (-1). 
TestRunner:  checkEq passed: XHR length is (695313). 
TestRunner:  checkNE passed: request index is (0). 
TestRunner:  checkEq passed: XHR requestType is (GET). 
TestRunner:  checkEq passed: request index is (-1). 
TestRunner:  checkEq passed: XHR length is (1184). 
TestRunner:  checkNE passed: request index is (0). 
TestRunner:  checkEq passed: XHR requestType is (GET). 
TestRunner:  checkEq passed: request index is (-1). 
TestRunner:  checkEq passed: XHR length is (32768). 
TestRunner:  checkNE passed: request index is (0). 
TestRunner:  checkEq passed: XHR requestType is (GET). 
TestRunner:  checkEq passed: request index is (-1). 
Seek:  MS test started 
TestRunner:  Starting test 47:Seek with timeout 30000 
TestRunner:  Media Source and Encrypted Media Conformance Tests (version 20150204153408-HPzdT3AF64aLpML9)
Actually, this is intermittent. Just got it to passed just then...
Attached file log.txt.zip
Here is the log of running 47. Seek test twice in a row.
The first one succeeded.

The second one stalled after seeking to 7s.

You can tell that both sourcebuffer have data buffered in the required range.

In the log however, we see:
2066494208[1005481a0]: Decoder=11e85d0c0 Changed state to SEEKING (to 7000000)
Yet somehow the seek promise appears to be destroyed as a shutdown happens and seeking to the new position never occurs.

I don't have time to investigate right now, Bobby maybe you could have a look?
Flags: needinfo?(bobbyholley)
Luckily, the wife is out and there is nothing on TV.

I've found the problem.
After a seek, we wait for the decoder to provide a sample with mDiscontinuity set, all frames are dropped until the.
This is never set to true until there's a flush. So after a seek, we decode the entire buffer until there's nothing left.

This is also likely the cause on why seeking takes so long with MSE, even when we have data.
Flags: needinfo?(bobbyholley)
Depends on: 1125469
Priority: -- → P2
Priority: P2 → P3
This seems to be fixed.

TestRunner:  All tests are completed 
TestRunner:  Longest test is Seek, it takes 0.4745 of its timeout. 
TestRunner:  Finished! 
TestRunner:  New longest test Seek with timeout 30000 takes 14235 
TestRunner:  Test Seek succeeded. 
TestRunner:  checkGE passed: currentTime is (9.38746). 
Seeking to segment index=0 time=7 start=0 length=10.00780045351474 
Seeking to segment index=1 time=7 start=5.005 length=5.005 
Seek:  Seek to 7s 
TestRunner:  checkGE passed: currentTime is (60.021678). 
TestRunner:  checkEq passed: XHR length is (158960). 
TestRunner:  checkNE passed: request index is (0). 
TestRunner:  checkEq passed: XHR requestType is (GET). 
TestRunner:  checkEq passed: request index is (-1). 
TestRunner:  checkEq passed: XHR length is (159069). 
TestRunner:  checkNE passed: request index is (0). 
TestRunner:  checkEq passed: XHR requestType is (GET). 
TestRunner:  checkEq passed: request index is (-1). 
TestRunner:  checkEq passed: XHR length is (158527). 
TestRunner:  checkNE passed: request index is (0). 
TestRunner:  checkEq passed: XHR requestType is (GET). 
TestRunner:  checkEq passed: request index is (-1). 
TestRunner:  checkEq passed: XHR length is (158805). 
TestRunner:  checkNE passed: request index is (0). 
TestRunner:  checkEq passed: XHR requestType is (GET). 
TestRunner:  checkEq passed: request index is (-1). 
TestRunner:  checkEq passed: XHR length is (358541). 
TestRunner:  checkNE passed: request index is (0). 
TestRunner:  checkEq passed: XHR requestType is (GET). 
TestRunner:  checkEq passed: request index is (-1). 
TestRunner:  checkEq passed: XHR length is (494252). 
TestRunner:  checkNE passed: request index is (0). 
TestRunner:  checkEq passed: XHR requestType is (GET). 
TestRunner:  checkEq passed: request index is (-1). 
TestRunner:  checkEq passed: XHR length is (293731). 
TestRunner:  checkNE passed: request index is (0). 
TestRunner:  checkEq passed: XHR requestType is (GET). 
TestRunner:  checkEq passed: request index is (-1). 
TestRunner:  checkEq passed: XHR length is (382208). 
TestRunner:  checkNE passed: request index is (0). 
TestRunner:  checkEq passed: XHR requestType is (GET). 
TestRunner:  checkEq passed: request index is (-1). 
TestRunner:  checkEq passed: XHR length is (357762). 
TestRunner:  checkNE passed: request index is (0). 
TestRunner:  checkEq passed: XHR requestType is (GET). 
TestRunner:  checkEq passed: request index is (-1). 
TestRunner:  checkEq passed: XHR length is (296397). 
TestRunner:  checkNE passed: request index is (0). 
TestRunner:  checkEq passed: XHR requestType is (GET). 
TestRunner:  checkEq passed: request index is (-1). 
TestRunner:  checkEq passed: XHR length is (517569). 
TestRunner:  checkNE passed: request index is (0). 
TestRunner:  checkEq passed: XHR requestType is (GET). 
TestRunner:  checkEq passed: request index is (-1). 
TestRunner:  checkEq passed: XHR length is (513547). 
TestRunner:  checkNE passed: request index is (0). 
TestRunner:  checkEq passed: XHR requestType is (GET). 
TestRunner:  checkEq passed: request index is (-1). 
Seek:  Seek to 28s 
TestRunner:  checkGE passed: currentTime is (19.021995). 
TestRunner:  checkEq passed: XHR length is (159162). 
TestRunner:  checkNE passed: request index is (0). 
TestRunner:  checkEq passed: XHR requestType is (GET). 
TestRunner:  checkEq passed: request index is (-1). 
TestRunner:  checkEq passed: XHR length is (158620). 
TestRunner:  checkNE passed: request index is (0). 
TestRunner:  checkEq passed: XHR requestType is (GET). 
TestRunner:  checkEq passed: request index is (-1). 
TestRunner:  checkEq passed: XHR length is (611704). 
TestRunner:  checkNE passed: request index is (0). 
TestRunner:  checkEq passed: XHR requestType is (GET). 
TestRunner:  checkEq passed: request index is (-1). 
TestRunner:  checkEq passed: XHR length is (616376). 
TestRunner:  checkNE passed: request index is (0). 
TestRunner:  checkEq passed: XHR requestType is (GET). 
TestRunner:  checkEq passed: request index is (-1). 
TestRunner:  checkEq passed: XHR length is (411469). 
TestRunner:  checkNE passed: request index is (0). 
TestRunner:  checkEq passed: XHR requestType is (GET). 
TestRunner:  checkEq passed: request index is (-1). 
onLoadedMetadata bypassed 
Seek:  Seek to 17s 
TestRunner:  checkEq passed: XHR length is (159087). 
TestRunner:  checkNE passed: request index is (0). 
TestRunner:  checkEq passed: XHR requestType is (GET). 
TestRunner:  checkEq passed: request index is (-1). 
TestRunner:  checkEq passed: XHR length is (158980). 
TestRunner:  checkNE passed: request index is (0). 
TestRunner:  checkEq passed: XHR requestType is (GET). 
TestRunner:  checkEq passed: request index is (-1). 
TestRunner:  checkEq passed: XHR length is (852). 
TestRunner:  checkNE passed: request index is (0). 
TestRunner:  checkEq passed: XHR requestType is (GET). 
TestRunner:  checkEq passed: request index is (-1). 
TestRunner:  checkEq passed: XHR length is (32768). 
TestRunner:  checkNE passed: request index is (0). 
TestRunner:  checkEq passed: XHR requestType is (GET). 
TestRunner:  checkEq passed: request index is (-1). 
TestRunner:  checkEq passed: XHR length is (337406). 
TestRunner:  checkNE passed: request index is (0). 
TestRunner:  checkEq passed: XHR requestType is (GET). 
TestRunner:  checkEq passed: request index is (-1). 
TestRunner:  checkEq passed: XHR length is (560289). 
TestRunner:  checkNE passed: request index is (0). 
TestRunner:  checkEq passed: XHR requestType is (GET). 
TestRunner:  checkEq passed: request index is (-1). 
TestRunner:  checkEq passed: XHR length is (686458). 
TestRunner:  checkNE passed: request index is (0). 
TestRunner:  checkEq passed: XHR requestType is (GET). 
TestRunner:  checkEq passed: request index is (-1). 
TestRunner:  checkEq passed: XHR length is (695313). 
TestRunner:  checkNE passed: request index is (0). 
TestRunner:  checkEq passed: XHR requestType is (GET). 
TestRunner:  checkEq passed: request index is (-1). 
TestRunner:  checkEq passed: XHR length is (1184). 
TestRunner:  checkNE passed: request index is (0). 
TestRunner:  checkEq passed: XHR requestType is (GET). 
TestRunner:  checkEq passed: request index is (-1). 
TestRunner:  checkEq passed: XHR length is (32768). 
TestRunner:  checkNE passed: request index is (0). 
TestRunner:  checkEq passed: XHR requestType is (GET). 
TestRunner:  checkEq passed: request index is (-1). 
Seek:  MS test started 
TestRunner:  Starting test 47:Seek with timeout 30000 
TestRunner:  Media Source and Encrypted Media Conformance Tests (version 20150326133122-e5cOEaP8ocqTCH34)
Status: NEW → RESOLVED
Closed: 5 years ago
Resolution: --- → WORKSFORME
It happens again on Windows platform (windows 8 exactly), other platforms are ok.
Input an audio sample with time = 57980226, but the audio decoder outputs audio with time = 0.
That causes seeking can't finish on time.

I test on changeset: 254810:33dc8a83cfc0


2015-07-31 03:25:45.839000 UTC - 24228[69ec7d0]: MediaFormatReader(293c800)::mozilla::MediaFormatReader::OnVideoDemuxCompleted: 1 video samples demuxed (sid:0) dts(57390822) kf:1
2015-07-31 03:25:45.839000 UTC - 24228[69ec7d0]: MediaFormatReader(293c800)::mozilla::MediaFormatReader::ScheduleUpdate: SchedulingUpdate(Video)
2015-07-31 03:25:45.839000 UTC - 23948[69ec920]: MediaFormatReader(293c800)::mozilla::MediaFormatReader::Update: Processing update for Audio
2015-07-31 03:25:45.839000 UTC - 23948[69ec920]: MediaFormatReader(293c800)::mozilla::MediaFormatReader::Update: Update(Audio) ni=1 no=1 ie=1, in:0 out:0 qs=0 sid:0
2015-07-31 03:25:45.839000 UTC - 23948[69ec920]: MediaFormatReader(293c800)::mozilla::MediaFormatReader::EnsureDecodersInitialized: Init decoders: audio: 5dffdd0, audio init: 1, video: 29a05e0, video init: 1
2015-07-31 03:25:45.839000 UTC - 23948[69ec920]: MediaFormatReader(293c800)::mozilla::MediaFormatReader::DecodeDemuxedSamples: Giving Audio input to decoder
2015-07-31 03:25:45.839000 UTC - 23948[69ec920]: MediaFormatReader(293c800)::mozilla::MediaFormatReader::DecodeDemuxedSamples: Input:57980226 (dts:57980226 kf:1)
2015-07-31 03:25:45.840000 UTC - 23948[69ec920]: MediaFormatReader(293c800)::mozilla::MediaFormatReader::Update: Processing update for Video
2015-07-31 03:25:45.840000 UTC - 23948[69ec920]: MediaFormatReader(293c800)::mozilla::MediaFormatReader::Update: Update(Video) ni=1 no=1 ie=1, in:0 out:0 qs=0 sid:0
2015-07-31 03:25:45.840000 UTC - 23948[69ec920]: MediaFormatReader(293c800)::mozilla::MediaFormatReader::EnsureDecodersInitialized: Init decoders: audio: 5dffdd0, audio init: 1, video: 29a05e0, video init: 1
2015-07-31 03:25:45.840000 UTC - 23948[69ec920]: MediaFormatReader(293c800)::mozilla::MediaFormatReader::DecodeDemuxedSamples: Giving Video input to decoder
2015-07-31 03:25:45.840000 UTC - 23948[69ec920]: MediaFormatReader(293c800)::mozilla::MediaFormatReader::DecodeDemuxedSamples: Input:57432533 (dts:57390822 kf:1)
2015-07-31 03:25:45.840000 UTC - 24628[69edf70]: MediaFormatReader(293c800)::mozilla::MediaFormatReader::Output: Decoded Audio sample time=0 dur=23219
2015-07-31 03:25:45.840000 UTC - 24228[69ec7d0]: MediaFormatReader(293c800)::mozilla::MediaFormatReader::NotifyNewOutput: Received new Audio sample time:0 duration:23219
2015-07-31 03:25:45.840000 UTC - 24228[69ec7d0]: MediaFormatReader(293c800)::mozilla::MediaFormatReader::ScheduleUpdate: SchedulingUpdate(Audio)
2015-07-31 03:25:45.840000 UTC - 22700[69ecbc0]: MediaFormatReader(293c800)::mozilla::MediaFormatReader::NotifyInputExhausted: Decoder has requested more Audio data
2015-07-31 03:25:45.840000 UTC - 19764[69eca70]: MediaFormatReader(293c800)::mozilla::MediaFormatReader::NotifyInputExhausted: Decoder has requested more Video data





TestRunner:  All tests are completed 
TestRunner:  Finished! 
TestRunner:  TestRunner.prototype.error@http://yt-dash-mse-test.commondatastorage.googleapis.com/unit-tests/js/harness/test-20150729140035.js:411:9
TestRunner.prototype.timeout@http://yt-dash-mse-test.commondatastorage.googleapis.com/unit-tests/js/harness/test-20150729140035.js:466:5
TimeoutManager/timeoutHandler@http://yt-dash-mse-test.commondatastorage.googleapis.com/unit-tests/js/harness/timeout-20150729140035.js:35:5
 
Seek:    0: (0, 80.015986) 
Seek:  sb1.buffered.length 1 
Seek:    0: (0, 75.075322) 
Seek:  sb0.buffered.length 1 
Seek:  ms.sb count = 2 
Seek:  video.networkState = 2 
Seek:  video.readyState = 1 
Seek:  video.currentTime = 58 
TestRunner:  Test Seek TIMED OUT! 
TestRunner:  checkEq passed: XHR length is (158960). 
TestRunner:  checkNE passed: request index is (0). 
TestRunner:  checkEq passed: XHR requestType is (GET). 
TestRunner:  checkEq passed: request index is (-1). 
TestRunner:  checkEq passed: XHR length is (159069). 
TestRunner:  checkNE passed: request index is (0). 
TestRunner:  checkEq passed: XHR requestType is (GET). 
TestRunner:  checkEq passed: request index is (-1). 
TestRunner:  checkEq passed: XHR length is (158527). 
TestRunner:  checkNE passed: request index is (0). 
TestRunner:  checkEq passed: XHR requestType is (GET). 
TestRunner:  checkEq passed: request index is (-1). 
TestRunner:  checkEq passed: XHR length is (158805). 
TestRunner:  checkNE passed: request index is (0). 
TestRunner:  checkEq passed: XHR requestType is (GET). 
TestRunner:  checkEq passed: request index is (-1). 
TestRunner:  checkEq passed: XHR length is (358541). 
TestRunner:  checkNE passed: request index is (0). 
TestRunner:  checkEq passed: XHR requestType is (GET). 
TestRunner:  checkEq passed: request index is (-1). 
TestRunner:  checkEq passed: XHR length is (494252). 
TestRunner:  checkNE passed: request index is (0). 
TestRunner:  checkEq passed: XHR requestType is (GET). 
TestRunner:  checkEq passed: request index is (-1). 
TestRunner:  checkEq passed: XHR length is (293731). 
TestRunner:  checkNE passed: request index is (0). 
TestRunner:  checkEq passed: XHR requestType is (GET). 
TestRunner:  checkEq passed: request index is (-1). 
TestRunner:  checkEq passed: XHR length is (382208). 
TestRunner:  checkNE passed: request index is (0). 
TestRunner:  checkEq passed: XHR requestType is (GET). 
TestRunner:  checkEq passed: request index is (-1). 
TestRunner:  checkEq passed: XHR length is (357762). 
TestRunner:  checkNE passed: request index is (0). 
TestRunner:  checkEq passed: XHR requestType is (GET). 
TestRunner:  checkEq passed: request index is (-1). 
TestRunner:  checkEq passed: XHR length is (296397). 
TestRunner:  checkNE passed: request index is (0). 
TestRunner:  checkEq passed: XHR requestType is (GET). 
TestRunner:  checkEq passed: request index is (-1). 
TestRunner:  checkEq passed: XHR length is (517569). 
TestRunner:  checkNE passed: request index is (0). 
TestRunner:  checkEq passed: XHR requestType is (GET). 
TestRunner:  checkEq passed: request index is (-1). 
TestRunner:  checkEq passed: XHR length is (513547). 
TestRunner:  checkNE passed: request index is (0). 
TestRunner:  checkEq passed: XHR requestType is (GET). 
TestRunner:  checkEq passed: request index is (-1). 
Seek:  Seek to 28s 
TestRunner:  checkGE passed: currentTime is (20.279682). 
TestRunner:  checkEq passed: XHR length is (159162). 
TestRunner:  checkNE passed: request index is (0). 
TestRunner:  checkEq passed: XHR requestType is (GET). 
TestRunner:  checkEq passed: request index is (-1). 
TestRunner:  checkEq passed: XHR length is (158620). 
TestRunner:  checkNE passed: request index is (0). 
TestRunner:  checkEq passed: XHR requestType is (GET). 
TestRunner:  checkEq passed: request index is (-1). 
TestRunner:  checkEq passed: XHR length is (611704). 
TestRunner:  checkNE passed: request index is (0). 
TestRunner:  checkEq passed: XHR requestType is (GET). 
TestRunner:  checkEq passed: request index is (-1). 
TestRunner:  checkEq passed: XHR length is (616376). 
TestRunner:  checkNE passed: request index is (0). 
TestRunner:  checkEq passed: XHR requestType is (GET). 
TestRunner:  checkEq passed: request index is (-1). 
TestRunner:  checkEq passed: XHR length is (411469). 
TestRunner:  checkNE passed: request index is (0). 
TestRunner:  checkEq passed: XHR requestType is (GET). 
TestRunner:  checkEq passed: request index is (-1). 
onLoadedMetadata bypassed 
Seek:  Seek to 17s 
TestRunner:  checkEq passed: XHR length is (159087). 
TestRunner:  checkNE passed: request index is (0). 
TestRunner:  checkEq passed: XHR requestType is (GET). 
TestRunner:  checkEq passed: request index is (-1). 
TestRunner:  checkEq passed: XHR length is (158980). 
TestRunner:  checkNE passed: request index is (0). 
TestRunner:  checkEq passed: XHR requestType is (GET). 
TestRunner:  checkEq passed: request index is (-1). 
TestRunner:  checkEq passed: XHR length is (852). 
TestRunner:  checkNE passed: request index is (0). 
TestRunner:  checkEq passed: XHR requestType is (GET). 
TestRunner:  checkEq passed: request index is (-1). 
TestRunner:  checkEq passed: XHR length is (32768). 
TestRunner:  checkNE passed: request index is (0). 
TestRunner:  checkEq passed: XHR requestType is (GET). 
TestRunner:  checkEq passed: request index is (-1). 
TestRunner:  checkEq passed: XHR length is (337406). 
TestRunner:  checkNE passed: request index is (0). 
TestRunner:  checkEq passed: XHR requestType is (GET). 
TestRunner:  checkEq passed: request index is (-1). 
TestRunner:  checkEq passed: XHR length is (560289). 
TestRunner:  checkNE passed: request index is (0). 
TestRunner:  checkEq passed: XHR requestType is (GET). 
TestRunner:  checkEq passed: request index is (-1). 
TestRunner:  checkEq passed: XHR length is (686458). 
TestRunner:  checkNE passed: request index is (0). 
TestRunner:  checkEq passed: XHR requestType is (GET). 
TestRunner:  checkEq passed: request index is (-1). 
TestRunner:  checkEq passed: XHR length is (695313). 
TestRunner:  checkNE passed: request index is (0). 
TestRunner:  checkEq passed: XHR requestType is (GET). 
TestRunner:  checkEq passed: request index is (-1). 
TestRunner:  checkEq passed: XHR length is (1184). 
TestRunner:  checkNE passed: request index is (0). 
TestRunner:  checkEq passed: XHR requestType is (GET). 
TestRunner:  checkEq passed: request index is (-1). 
TestRunner:  checkEq passed: XHR length is (32768). 
TestRunner:  checkNE passed: request index is (0). 
TestRunner:  checkEq passed: XHR requestType is (GET). 
TestRunner:  checkEq passed: request index is (-1). 
Seek:  MS test started 
TestRunner:  Starting test 47:Seek with timeout 30000 
TestRunner:  Media Source and Encrypted Media Conformance Tests (version 20150729140035-uXMqKELDmjp4d9N5)
Status: RESOLVED → REOPENED
OS: Mac OS X → Windows 8
Resolution: WORKSFORME → ---
is this with bug 1189138 in ?
Flags: needinfo?(ayang)
could it be that the flush of the decoder didn't actually flush?
I've seen the flush log on MediaFormatReader.

2015-07-31 03:25:37.616000 UTC - 22700[69ecbc0]: MediaFormatReader(293c800)::mozilla::MediaFormatReader::ResetDecode:
2015-07-31 03:25:37.616000 UTC - 22700[69ecbc0]: MediaFormatReader(293c800)::mozilla::MediaFormatReader::Flush: Flush(Video) BEGIN
2015-07-31 03:25:37.678000 UTC - 22700[69ecbc0]: MediaFormatReader(293c800)::mozilla::MediaFormatReader::Flush: Flush(Video) END
2015-07-31 03:25:37.680000 UTC - 22700[69ecbc0]: MediaFormatReader(293c800)::mozilla::MediaFormatReader::Flush: Flush(Audio) BEGIN
2015-07-31 03:25:37.682000 UTC - 22700[69ecbc0]: MediaFormatReader(293c800)::mozilla::MediaFormatReader::Flush: Flush(Audio) END
2015-07-31 03:25:37.682000 UTC - 22700[69ecbc0]: MediaFormatReader(293c800)::mozilla::MediaFormatReader::Seek: aTime=(58000000)
2015-07-31 03:25:37.683000 UTC - 22700[69ecbc0]: MediaFormatReader(293c800)::mozilla::MediaFormatReader::DoVideoSeek: Seeking video to 58000000


I'll pull the latest m-c and try it again.
Flags: needinfo?(ayang)
You've seen that MediaFormatReader called WMF::Flush, but maybe it didn't flush.

is this with your new async init work?

I've never had an issue with this test anymore ; not since the new MSE has been activated
No, it doesn't apply the async init patches.
It works fine after updating to changeset: 255486:888e8026ed60.
Status: REOPENED → RESOLVED
Closed: 5 years ago5 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.