[RTL][Settings]The menu button is mirrored in Downloads.

VERIFIED FIXED in 2.2 S6 (20feb)

Status

P3
normal
VERIFIED FIXED
4 years ago
4 years ago

People

(Reporter: lulu.tian, Assigned: eragonj)

Tracking

unspecified
2.2 S6 (20feb)
ARM
Gonk (Firefox OS)
Bug Flags:
in-moztrap +

Firefox Tracking Flags

(b2g-v2.2 verified, b2g-master verified)

Details

Attachments

(3 attachments)

(Reporter)

Description

4 years ago
Created attachment 8560351 [details]
menu.png

[1.Description]:
[RTL][Settings]When you go to Settings -> Downloads, the menu button is mirrored.
See attachment:menu.png

[2.Testing Steps]: 
Prerequisite: Set system language as Arabic.
1. Launch Settings app.
2. Select Downloads and observe the menu button at top right.

[3.Expected Result]: 
2. The menu button should not be mirrored.

[4.Actual Result]: 
2. The menu button is mirrored.

[5.Reproduction build]: 
Flame 2.2 build:
Build ID               20150205002503
Gaia Revision          c2047a46e29696238e9b4c9caaba47736421449a
Gaia Date              2015-02-04 20:34:04
Gecko Revision         https://hg.mozilla.org/releases/mozilla-b2g37_v2_2/rev/adfba0a07e9b
Gecko Version          37.0a2
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150205.045043
Firmware Date          Thu Feb  5 04:50:54 EST 2015
Bootloader             L1TC000118D0

[6.Reproduction Frequency]: 
Always Recurrence,5/5

[7.TCID]: 
Free Test
(Reporter)

Updated

4 years ago
QA Whiteboard: [rtl-impact]
triage: P3, valid but low impact, would take a fix for 2.2
Priority: -- → P3
Assignee: nobody → ejchen
Created attachment 8561165 [details] [review]
[PullReq] EragonJ:bug-1130307 to mozilla-b2g:master
Comment on attachment 8561165 [details] [review]
[PullReq] EragonJ:bug-1130307 to mozilla-b2g:master

Hi Arthur, can you help me review this simple patch ? Thanks !
Attachment #8561165 - Flags: review?(arthur.chen)
Comment on attachment 8561165 [details] [review]
[PullReq] EragonJ:bug-1130307 to mozilla-b2g:master

r=me, thanks.
Attachment #8561165 - Flags: review?(arthur.chen) → review+
Thanks Arthur ! 

This patch was merged into Gaia/master: https://github.com/mozilla-b2g/gaia/commit/a01f1b61ad89d76c4c0f8cca688116c3baed22a9
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → FIXED
status-b2g-master: --- → fixed
Comment on attachment 8561165 [details] [review]
[PullReq] EragonJ:bug-1130307 to mozilla-b2g:master

[Approval Request Comment]
[Bug caused by] (feature/regressing bug #): no
[User impact] if declined: the menu icon in download manager got mirrored in RTL languages.
[Testing completed]: no, only one-line CSS change
[Risk to taking this patch] (and alternatives if risky): low
[String changes made]: no
Attachment #8561165 - Flags: approval-gaia-v2.2?
Attachment #8561165 - Flags: approval-gaia-v2.2? → approval-gaia-v2.2+
v2.2: https://github.com/mozilla-b2g/gaia/commit/5ddfee8a895b7336cf26f886de639ce8efcdf8ac
status-b2g-v2.2: affected → fixed
Target Milestone: --- → 2.2 S6 (20feb)

Comment 8

4 years ago
This issue has been verified successfully on Flame 3.0.

Flame 3.0 build:

Build ID               20150210010523
Gaia Revision          0cf517083f7eb5fc269e1236edba50534f65e3cd
Gaia Date              2015-02-09 18:21:45
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/2cb22c058add
Gecko Version          38.0a1
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150210.050217
Firmware Date          Tue Feb 10 05:02:28 EST 2015
Bootloader             L1TC000118D0
QA Whiteboard: [rtl-impact] → [rtl-impact],[MGSEI-Triage+]
status-b2g-master: fixed → verified
(Reporter)

Comment 9

4 years ago
Created attachment 8563173 [details]
2015-02-12-09-42-17.png

This issue has been verified successfully on Flame v2.2
STR:
Prerequisite: Set system language as Arabic.
1. Launch Settings app.
2. Select Downloads and observe the menu button at top right.
**The menu button is not mirrored.
See attachment:2015-02-12-09-42-17.png
Rate:0/5

Flame 2.2 build:
Build ID               20150211002505
Gaia Revision          943be6fd146017dcd9d4c9d1027be1e43bad13eb
Gaia Date              2015-02-11 08:01:09
Gecko Revision         https://hg.mozilla.org/releases/mozilla-b2g37_v2_2/rev/e614443583e7
Gecko Version          37.0a2
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150211.040242
Firmware Date          Wed Feb 11 04:02:53 EST 2015
Bootloader             L1TC000118D0
(Reporter)

Updated

4 years ago
Status: RESOLVED → VERIFIED
status-b2g-v2.2: fixed → verified
Test case has been added in moztrap:
https://moztrap.mozilla.org/manage/case/15782/
Flags: in-moztrap+
You need to log in before you can comment on or make changes to this bug.