Thunderbird - Glacially slow response

RESOLVED INVALID

Status

Thunderbird
Filters
RESOLVED INVALID
3 years ago
3 years ago

People

(Reporter: Tim Thompson, Unassigned)

Tracking

({perf})

34 Branch
x86_64
Windows 7

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [addon:Stationery])

(Reporter)

Description

3 years ago
User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/40.0.2214.111 Safari/537.36

Steps to reproduce:

Created and maintained filters to sort email into folders.


Actual results:

Thunderbird completely freezes for tens of seconds, sometimes over a minute. When composing a new message text entered is missed, the main window switches to the foreground, and message text is interpreted as commands which wreaks havoc with the program.

I am guessing that filters or junk mail sorting are the cause of these delays.


Expected results:

Thunderbird should not be completely useless for so long and switch windows without notice when you are composing a message.

Comment 1

3 years ago
Any really big folders (10k to 100k messages) that frequently get new mail?

Also, see https://wiki.mozilla.org/Thunderbird:Testing:Memory_Usage_Problems to self diagnose common performance issues. Please post your results

Updated

3 years ago
Keywords: perf
(Reporter)

Comment 2

3 years ago
I have one folder with 10.3K messages, 4GB of mail and gets 2-10 new messages per day. My second largest folder (advertising) has 5K messages, 229MB of mail, and gets 10-30 new messages per day. My advertising filter has a growing number of entries. I cleaned out the filter list and deleted old entries, but the problem persists.

I have two extensions to Thunderbird: Google Docs Viewer 1.8.9 and Stationery 0.8.4. When they are disabled in Safe Mode I have still noticed freezes for a few seconds. I will continue running this way for a while to see if I can see a statistically significant difference.

Comment 3

3 years ago
My guess would be gloda indexing. You can try turning that off under Preferences | Advanced
My two colleagues seem to have had the same problem.
both of them said:

* happens 5 - 10 times per day.
* happens when plural composition windows are open
* no gloda indexing did not help
* happens since this April (version 31.6) (so it might be unrelated to this bug)

Now one of them has been starting to try version 31.5.

I will report back later.

Comment 5

3 years ago
A profile URL will be helpful in pinpointing the hot spot. See https://developer.mozilla.org/en-US/docs/Mozilla/Performance/Reporting_a_Thunderbird_Performance_Problem_with_G   (Might be difficult to get with TB being slow)

Tim, what are our long term results since comment 2?
Flags: needinfo?(tbt)
Flags: needinfo?(hiikezoe)
(Reporter)

Comment 6

3 years ago
Things definitely improved after disabling the Stationery add-on. I would no longer consider it "glacially" slow. That said, most other mail programs are faster. Connecting to GMail can be painfully slow and fails sometimes.
Flags: needinfo?(tbt)

Comment 7

3 years ago
Hiro...
(In reply to Hiroyuki Ikezoe (:hiro) from comment #4)
> My two colleagues seem to have had the same problem.
> both of them said:
> 
> * happens 5 - 10 times per day.
> * happens when plural composition windows are open
> * no gloda indexing did not help
> * happens since this April (version 31.6) (so it might be unrelated to this
> bug)
> 
> Now one of them has been starting to try version 31.5.
> 
> I will report back later.

what is their timer setting in minutes for autosave of drafts?
how big is drafts folder?
is this on windows?

Comment 8

3 years ago
This isn't the first report of issues with Stationery
Status: UNCONFIRMED → RESOLVED
Last Resolved: 3 years ago
Flags: needinfo?(hiikezoe)
Resolution: --- → INVALID
Whiteboard: [addon:Stationery]
You need to log in before you can comment on or make changes to this bug.