Closed Bug 1130496 Opened 6 years ago Closed 6 years ago

the "Learn more..." link in the ssl error reporting UI links to a page specific to pinning errors

Categories

(Firefox :: General, defect)

x86_64
Linux
defect
Not set
normal

Tracking

()

RESOLVED DUPLICATE of bug 1105704

People

(Reporter: keeler, Unassigned)

References

Details

If a user encounters a non-overridable error when connecting to an https url, we show a page that asks them to submit an SSL error report. The "Learn more..." link goes to https://support.mozilla.org/en-US/kb/certificate-pinning-reports which is specifically about pinning errors, not SSL errors in general. This is confusing, because the error may have had nothing to do with pinning (see e.g. bug 1130472 comment 4).
(In reply to David Keeler [:keeler] (use needinfo?) from comment #0)
> If a user encounters a non-overridable error when connecting to an https
> url, we show a page that asks them to submit an SSL error report. The "Learn
> more..." link goes to
> https://support.mozilla.org/en-US/kb/certificate-pinning-reports which is
> specifically about pinning errors, not SSL errors in general. This is
> confusing, because the error may have had nothing to do with pinning (see
> e.g. bug 1130472 comment 4).

I fixed this in the patch for bug 1105704 - should we, perhaps, change the content of the document until the fix for 1105704 is in release?
Oh, I see. Let's just dup this one to that and uplift it as far as we can.
Status: NEW → RESOLVED
Closed: 6 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1105704
(In reply to David Keeler [:keeler] (use needinfo?) from comment #3)
> The other issue is https://support.mozilla.org/en-US/kb/tls-error-reports
> should have its content approved.

Hey David, I just approved that article and it is live now. :) Sorry it wasn't approved sooner. In the future, joining #sumo and flagging down an admin can help expedite this. Hopefully one day a feature can be added to SUMO where articles created by users with @mozilla.com email addresses will have some kind of higher priority associated with their articles for faster review.
You need to log in before you can comment on or make changes to this bug.