the inspector pane can end up in an "empty" state after reload a failed page

RESOLVED DUPLICATE of bug 983386

Status

()

Firefox
Developer Tools: Inspector
RESOLVED DUPLICATE of bug 983386
3 years ago
3 years ago

People

(Reporter: pomax, Unassigned)

Tracking

37 Branch
x86_64
Windows 7
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

3 years ago
Seeing some interesting behaviour of the Inspector tab in FF Dev edition (v37), where the inspector pane will be blank when inspecting elements, despite the styling sidebar being populated correctly, and the "xpath" top bar showing the correct chain.

STR:

1) fire up a random localhost server on a random dir with an index.html and point FF dev to that server's location, then open the dev tools and pick the Inspector tab.
2) kill the localhost server, don't close the dev tools, and hit "reload" in FF dev. This will cause a page load failure, and a mostly blank inspector tab.
3) start the localhost server back up, and reload FF dev. This will load the appropriate page again, but the dev tools Inspector pane will remain empty.
4) use the context menu to "inspect element" any part of the page, the Inspector pane will still be empty, but show the correct "xpath" and styling rules.
(Reporter)

Comment 1

3 years ago
Note that closing the dev tools and then reopening them up as part of step (4) will restore the Inspector pane to a proper view with a DOM structure that can be interacted with.
Alternate (intermittent) STR:

1. Begin loading a webpage
2. Immediately open Inspector
3. Inspector pane will be blank as above #3
4. See above #4
Comment 0 describes the same problem as bug 983386. Comment 2 seems different though, please file a separate bug for this.
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 983386
You need to log in before you can comment on or make changes to this bug.