[Search] - The titles of the top search results overlap the History section header when viewing search results in landscape.

RESOLVED DUPLICATE of bug 1146825

Status

RESOLVED DUPLICATE of bug 1146825
4 years ago
4 years ago

People

(Reporter: jmitchell, Assigned: daleharvey)

Tracking

unspecified
ARM
Gonk (Firefox OS)

Firefox Tracking Flags

(b2g-v2.2 affected, b2g-master affected)

Details

(Whiteboard: [3.0-Daily-Testing][systemsfe], URL)

Attachments

(1 attachment)

(Reporter)

Description

4 years ago
Created attachment 8560688 [details]
2015-02-06-11-38-10.png

Description:
There are several apps that support landscape mode (Gallery, Browser, etc.) When you are in Landscape mode and open the search bar, the results will also appear in landscape mode. The results of the search is broken into 3 different sections: Apps, History, and Google Search. The titles of the results from apps (which appear underneath the icon) overlap the section separator line and History header of the second section when in landscape mode. 
Notes:
The icons seem abnormally large.
This may have some overlap with Bug 1074376 which is discussing landscape search results but seems to focus more on Keyboard and result grid (number of icons across). In an effort not to 'pile on' more aspects there I've opened this bug. 

Repro Steps:
1) Update a Flame to 20150206010204
2) Enter a landscape app (Browser, Gallery, Etc)
3) Tap the search bar and begin typing (Example: Goo)
4) Observe the search results

Actual:
App names overlap History section header and line separator. 

Expected:
Separate and distinct sections, appears as in portrait 

Environmental Variables:
Device: Flame 3.0
Build ID: 20150206010204
Gaia: 94af4b42d2ace6c9f38f31de77240604fac68af1
Gecko: 7c5f187b65bf
Gonk: e7c90613521145db090dd24147afd5ceb5703190
Version: 38.0a1 (3.0)
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:38.0) Gecko/38.0 Firefox/38.0

Repro frequency: 6/6
See attached: screenshot

-----------------------------------------------------------------------------------

Search results are different (don't contain History and google results)in 2.2 so not an applicable branch check.
(Reporter)

Updated

4 years ago
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(pbylenga)
NI on component owner for nomination decision and assignment.
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(pbylenga) → needinfo?(hcheng)
I cannot reproduce it. Could you please provide video?


(In reply to Joshua Mitchell [:Joshua_M] from comment #0)
> Created attachment 8560688 [details]
> 2015-02-06-11-38-10.png
> 
> Description:
> There are several apps that support landscape mode (Gallery, Browser, etc.)
> When you are in Landscape mode and open the search bar, the results will
> also appear in landscape mode. The results of the search is broken into 3
> different sections: Apps, History, and Google Search. The titles of the
> results from apps (which appear underneath the icon) overlap the section
> separator line and History header of the second section when in landscape
> mode. 
> Notes:
> The icons seem abnormally large.
> This may have some overlap with Bug 1074376 which is discussing landscape
> search results but seems to focus more on Keyboard and result grid (number
> of icons across). In an effort not to 'pile on' more aspects there I've
> opened this bug. 
> 
> Repro Steps:
> 1) Update a Flame to 20150206010204
> 2) Enter a landscape app (Browser, Gallery, Etc)
> 3) Tap the search bar and begin typing (Example: Goo)
> 4) Observe the search results
> 
> Actual:
> App names overlap History section header and line separator. 
> 
> Expected:
> Separate and distinct sections, appears as in portrait 
> 
> Environmental Variables:
> Device: Flame 3.0
> Build ID: 20150206010204
> Gaia: 94af4b42d2ace6c9f38f31de77240604fac68af1
> Gecko: 7c5f187b65bf
> Gonk: e7c90613521145db090dd24147afd5ceb5703190
> Version: 38.0a1 (3.0)
> Firmware Version: v18D-1
> User Agent: Mozilla/5.0 (Mobile; rv:38.0) Gecko/38.0 Firefox/38.0
> 
> Repro frequency: 6/6
> See attached: screenshot
> 
> -----------------------------------------------------------------------------
> ------
> 
> Search results are different (don't contain History and google results)in
> 2.2 so not an applicable branch check.
The reason is that those parches for rocketbar have not been landed to v2.2 yet.

*My env:
Build ID               20150208160205
Gaia Revision          994896b89ba10cad39a87f90eeaba9ae5e17c3a6
Gaia Date              2015-02-07 19:22:02
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/be65d1fde126
Gecko Version          38.0a1
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150208.194555
Firmware Date          Sun Feb  8 19:46:06 EST 2015
Bootloader             L1TC000118D0
Flags: needinfo?(hcheng)
Flags: needinfo?(jmitchell)
(Reporter)

Comment 3

4 years ago
Video added here: http://youtu.be/NlNh_zfRcvU

Issue still occurs in today's newest 3.0 and might actually be worse today - if you rotate from landscape back to portrait mode there is additional overlap and icons become truncated on the sides. 

Device: Flame 3.0
Build ID: 20150209010211
Gaia: 0d7b35f23402c4cb29bca6b98280fec48a196dec
Gecko: 3436787a82d0
Gonk: e7c90613521145db090dd24147afd5ceb5703190
Version: 38.0a1 (3.0)
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:38.0) Gecko/38.0 Firefox/38.0
Flags: needinfo?(jmitchell) → needinfo?(hcheng)
(Reporter)

Comment 4

4 years ago
Previous Video link was for the unedited cut - please see http://youtu.be/oCN4fOU-FKM instead
Thanks Joshua.
This problem occurs when trigger search app from an app with landscape mode, and I think its reason is similar with Bug 1130921 which will be solved later. 

Dale, does this bug result from Bug 1130921?
Flags: needinfo?(hcheng) → needinfo?(dale)
(Assignee)

Comment 6

4 years ago
No, its a result of https://bugzilla.mozilla.org/show_bug.cgi?id=1117967

Ben can you take a look at this please, the layout needs fixed for landscape and I think we should probably not be showing huge icons.

The easiest fix would be 4 normal sized icons middle aligned, or we could show more results in landscape mode, or we get the proper scrolling behaviour, may need a little back and forth with UX
Flags: needinfo?(dale) → needinfo?(bfrancis)
I think we've been showing the larger icons for quite a while now (since 2.1 rocketbar). It might be worth just pushing the content down a bit further when in landscape mode with a media query. Updating gaia-grid to change the size or center might be complex (though maybe you could just do it with a scale).
status-b2g-v2.2: --- → affected
Whiteboard: [3.0-Daily-Testing] → [3.0-Daily-Testing][systemsfe]
(Assignee)

Comment 8

4 years ago
This will likely be fixed along with https://bugzilla.mozilla.org/show_bug.cgi?id=1146825 so taking
Assignee: nobody → dale
(Assignee)

Updated

4 years ago
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1146825
(Assignee)

Comment 10

4 years ago
Clearing old needinfo
Flags: needinfo?(bfrancis)
You need to log in before you can comment on or make changes to this bug.