Closed Bug 1130654 Opened 5 years ago Closed 5 years ago

[Contacts][Export] Email and Messages contact share activity are erroneously placed under Bluetooth export selection.

Categories

(Firefox OS Graveyard :: Gaia::Contacts, defect)

ARM
Gonk (Firefox OS)
defect
Not set

Tracking

(blocking-b2g:2.2+, b2g-v2.2 verified, b2g-master verified)

VERIFIED FIXED
2.2 S6 (20feb)
blocking-b2g 2.2+
Tracking Status
b2g-v2.2 --- verified
b2g-master --- verified

People

(Reporter: Marty, Assigned: jmcf)

References

()

Details

(Whiteboard: [3.0-Daily-Testing])

Attachments

(2 files)

Description:
If the user chooses to export contacts to Bluetooth, they will be brought to a share activity list that includes 'Messages' and 'Email.'

The user will not expect these share selections to be behind a Bluetooth selection.

Repro Steps:
1) Update a Flame to 20150206010204
2) Open the Contacts app and create at least one contact.
3) Tap the Gear icon to open the Contacts Settings menu
4) Select 'Export Contacts'
5) Select 'Bluetooth'
6) Select one or more contacts and tap 'Export'

Actual:
'Email' and 'Messages' erroneously appear under Export Contacts > Bluetooth

Expected:
'Email' and 'Messages' share activity is not listed under Bluetooth

Environmental Variables:
Device: Flame 3.0
Build ID: 20150206010204
Gaia: 94af4b42d2ace6c9f38f31de77240604fac68af1
Gecko: 7c5f187b65bf
Gonk: e7c90613521145db090dd24147afd5ceb5703190
Version: 38.0a1 (3.0)
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:38.0) Gecko/38.0 Firefox/38.0

Repro frequency: 5/5
See attached: video clip (URL), logcat

---------------------------------------------------

This issue DOES occur on Flame 2.2.
'Email' and 'Messages' erroneously appear under Export Contacts > Bluetooth

Environmental Variables:
Device: Flame 2.2 (319MB)(Full Flash)
Build ID: 20150206002505
Gaia: a52999ce7f783177deb17e267bf003a53e6fde06
Gecko: 01446d5231ef
Gonk: e7c90613521145db090dd24147afd5ceb5703190
Version: 37.0a2 (2.2)
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:37.0) Gecko/37.0 Firefox/37.0

---------------------------------------------------

This issue does NOT occur on Flame 2.1
'Email' and 'Messages' were not available share activities in this branch.

Environmental Variables:
Device: Flame 2.1 (319MB)(Full Flash)
Build ID: 20150206001229
Gaia: 5d5163069da2c660261399002e88b4cbb9135f1e
Gecko: c2210e7a21a3
Gonk: e7c90613521145db090dd24147afd5ceb5703190
Version: 34.0 (2.1)
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:34.0) Gecko/34.0 Firefox/34.0
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(ktucker)
Nominating this 2.2? since this menu appearing when the user already selected bluetooth doesn't make sense and it is a regression.
blocking-b2g: --- → 2.2?
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(ktucker)
This is not a regression from 2.1 because there was not a share activity menu within a contact that included  email and messages. Removing regression and flipping the 2.1 flag.
QA Whiteboard: [QAnalyst-Triage+]
Jose Manuel, can you have a look at it? Thanks a lot
Flags: needinfo?(jmcf)
Oh yes, this is a bug
Flags: needinfo?(jmcf)
Assignee: nobody → jmcf
Attachment #8561406 - Flags: review?(francisco)
triage: we decided to block on this, so setting 2.2+ flag
blocking-b2g: 2.2? → 2.2+
Comment on attachment 8561406 [details] [review]
[PullReq] jmcanterafonseca:fix_bluetooth_export to mozilla-b2g:master

Thanks Jose!
Attachment #8561406 - Flags: review?(francisco) → review+
https://github.com/mozilla-b2g/gaia/pull/28074

Autolander could not land the pull request due to not having collaborator rights. This is possibly due to a tree closure. Please check the tree status and request checkin again once the tree is open.
Keywords: checkin-needed
Target Milestone: --- → 2.2 S6 (20feb)
Status: NEW → RESOLVED
Closed: 5 years ago
Resolution: --- → FIXED
Comment on attachment 8561406 [details] [review]
[PullReq] jmcanterafonseca:fix_bluetooth_export to mozilla-b2g:master

[Approval Request Comment]
[Bug caused by] (feature/regressing bug #): Contacts share functionality
[User impact] if declined: Very high, Bluetooth export will not be usable
[Testing completed]: Yes
[Risk to taking this patch] (and alternatives if risky): No risk patch. App Manifest changed only
[String changes made]: None
Attachment #8561406 - Flags: approval-gaia-v2.2?
Attachment #8561406 - Flags: approval-gaia-v2.2? → approval-gaia-v2.2+
Depends on: 1134447
This issue is verified fixed in the latest Nightly Flame 3.0 and 2.2 builds.

Actual Results:  The user is not shown another share activity window that erroneously has Messages and Email when trying to export through bluetooth.

Environmental Variables:
Device: Flame 3.0
BuildID: 20150325083046
Gaia: aebfbd998041e960cea0468533c0b5041b504850
Gecko: db0409de517a
Gonk: b83fc73de7b64594cd74b33e498bf08332b5d87b
Version: 39.0a1 (3.0) 
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:39.0) Gecko/39.0 Firefox/39.0

Environmental Variables:
Device: Flame 2.2
BuildID: 20150325002503
Gaia: aeee2a54caa8ffb875b96264b61d742b70689f22
Gecko: 556aca3e50ac
Gonk: ebad7da532429a6f5efadc00bf6ad8a41288a429
Version: 37.0 (2.2) 
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:37.0) Gecko/37.0 Firefox/37.0
QA Whiteboard: [QAnalyst-Triage+] → [QAnalyst-Triage?]
Flags: needinfo?(ktucker)
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(ktucker)
You need to log in before you can comment on or make changes to this bug.