[meta] crash in mozalloc_abort | NS_DebugBreak | mozilla::dom::ContentChild::ProcessingError

REOPENED
Assigned to

Status

()

P2
critical
REOPENED
4 years ago
2 years ago

People

(Reporter: jimm, Assigned: jimm)

Tracking

({crash, meta})

Trunk
mozilla38
All
Windows NT
crash, meta
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(e10s+, firefox38 fixed)

Details

(crash signature, URL)

Attachments

(1 obsolete attachment)

(Assignee)

Updated

4 years ago
See Also: → bug 1116884
(Assignee)

Updated

4 years ago
Depends on: 1130842
(Assignee)

Comment 2

4 years ago
Created attachment 8560999 [details] [diff] [review]
patch
Assignee: nobody → jmathies
(Assignee)

Updated

4 years ago
Attachment #8560999 - Flags: review?(wmccloskey)
(Assignee)

Comment 3

4 years ago
Comment on attachment 8560999 [details] [diff] [review]
patch

woops, wrong bug.
Attachment #8560999 - Attachment is obsolete: true
Attachment #8560999 - Flags: review?(wmccloskey)
(Assignee)

Comment 4

4 years ago
So far the reporting added in bug 1130842 isn't turning up much, first nine reports all match - 

MsgRouteError '(msgtype=0x840009,name=???) Route error: message sent to unknown actor ID'
MsgRouteError '(msgtype=0x840009,name=???) Route error: message sent to unknown actor ID'
MsgRouteError '(msgtype=0x840009,name=???) Route error: message sent to unknown actor ID'
MsgRouteError '(msgtype=0x840009,name=???) Route error: message sent to unknown actor ID'
MsgRouteError '(msgtype=0x840009,name=???) Route error: message sent to unknown actor ID'
MsgRouteError '(msgtype=0x840009,name=???) Route error: message sent to unknown actor ID'
MsgRouteError '(msgtype=0x840009,name=???) Route error: message sent to unknown actor ID'
MsgRouteError '(msgtype=0x840009,name=???) Route error: message sent to unknown actor ID'
MsgRouteError '(msgtype=0x840009,name=???) Route error: message sent to unknown actor ID'
(Assignee)

Comment 5

4 years ago
(In reply to Jim Mathies [:jimm] from comment #1)
> http://hg.mozilla.org/mozilla-central/
> pushloghtml?fromchange=0c2f7434c325&tochange=34a66aaaca81

backed out bug 1127378 to see if it helps reduce this.
https://hg.mozilla.org/mozilla-central/rev/bca7d6e77486
Status: NEW → RESOLVED
Last Resolved: 4 years ago
status-firefox38: --- → fixed
Resolution: --- → FIXED
Target Milestone: --- → mozilla38
(Assignee)

Updated

4 years ago
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
(Assignee)

Comment 7

4 years ago
Looks like that backout cleared these up.
Status: REOPENED → RESOLVED
Last Resolved: 4 years ago4 years ago
Resolution: --- → WORKSFORME
(Assignee)

Comment 8

4 years ago
A few of these have shown up in the 2-10 build, possibly in smaller numbers. Have to wait and see.
Status: RESOLVED → REOPENED
Resolution: WORKSFORME → ---
(Assignee)

Updated

4 years ago
tracking-e10s: ? → +
Keywords: meta
(Assignee)

Updated

4 years ago
Depends on: 1132874
I just reproduced this on Nightly 18/03 whilst trying to reproduce bug 1130838

https://crash-stats.mozilla.com/report/index/78a3e9f6-41f2-459e-a194-8a49b2150319

I reproduced this by opening about 20 tabs with http://twitch.tv/directory and then closing them. It can take a while, so keep opening tabs and closing them until a content process crash occurs.
(Assignee)

Updated

4 years ago
Summary: crash in mozalloc_abort(char const* const) | NS_DebugBreak | mozilla::dom::ContentChild::ProcessingError(mozilla::ipc::HasResultCodes::Result, char const*) → [meta] crash in mozalloc_abort(char const* const) | NS_DebugBreak | mozilla::dom::ContentChild::ProcessingError(mozilla::ipc::HasResultCodes::Result, char const*)
Is it really fixed? I still see SendGetCookieString in the report.
Flags: needinfo?(jmathies)
(Assignee)

Updated

4 years ago
Flags: needinfo?(jmathies)
(Assignee)

Updated

3 years ago
Depends on: 1196799

Updated

3 years ago
Crash Signature: [@ mozalloc_abort(char const* const) | NS_DebugBreak | mozilla::dom::ContentChild::ProcessingError(mozilla::ipc::HasResultCodes::Result, char const*)] → [@ mozalloc_abort(char const* const) | NS_DebugBreak | mozilla::dom::ContentChild::ProcessingError(mozilla::ipc::HasResultCodes::Result, char const*)] [@ mozalloc_abort | NS_DebugBreak | mozilla::dom::ContentChild::ProcessingError]
(Assignee)

Updated

3 years ago
Summary: [meta] crash in mozalloc_abort(char const* const) | NS_DebugBreak | mozilla::dom::ContentChild::ProcessingError(mozilla::ipc::HasResultCodes::Result, char const*) → [meta] crash in mozalloc_abort | NS_DebugBreak | mozilla::dom::ContentChild::ProcessingError

Comment 11

3 years ago
Ran into this today on current FF Nightly 64-bit on Windows 10. https://crash-stats.mozilla.com/report/index/9ecaed8a-59a1-4906-80fd-acf4b2160426.
Adding a Mac signature which showed up recently in Nightly.
Crash Signature: [@ mozalloc_abort(char const* const) | NS_DebugBreak | mozilla::dom::ContentChild::ProcessingError(mozilla::ipc::HasResultCodes::Result, char const*)] [@ mozalloc_abort | NS_DebugBreak | mozilla::dom::ContentChild::ProcessingError] → [@ mozalloc_abort(char const* const) | NS_DebugBreak | mozilla::dom::ContentChild::ProcessingError(mozilla::ipc::HasResultCodes::Result, char const*)] [@ mozalloc_abort | NS_DebugBreak | mozilla::dom::ContentChild::ProcessingError] [@ mozalloc_abort | A…
Priority: -- → P2

Updated

2 years ago
See Also: → bug 1333514
You need to log in before you can comment on or make changes to this bug.