Closed Bug 1130758 Opened 8 years ago Closed 8 years ago

gecko: Emulator/Phone builds should checkout gecko in addition to repo sources prior to calling mozharness

Categories

(Taskcluster :: General, defect)

x86
macOS
defect
Not set
normal

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 1131465

People

(Reporter: jlal, Unassigned)

References

Details

http://docs.taskcluster.net/tools/task-inspector/#M154hUI0TLuMorOxpxJ0vg/0

Looks like we do not run a hg update on our gecko cache prior to fetching the sources.xml... A potential workaround is to add an option to take a manifest (which tc-vcs will download) but using tc-vcs _before_ mozharness to checkout gecko should also fix this issue as the revision will then be correct in all cases.
Blocks: 1080265
Status: NEW → RESOLVED
Closed: 8 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1131465
Component: TaskCluster → General
Product: Testing → Taskcluster
Target Milestone: --- → mozilla41
Version: unspecified → Trunk
Resetting Version and Target Milestone that accidentally got changed...
Target Milestone: mozilla41 → ---
Version: Trunk → unspecified
You need to log in before you can comment on or make changes to this bug.