Pop-up ad appears WITHIN page and not in separate window

RESOLVED FIXED

Status

Tech Evangelism Graveyard
English US
P3
normal
RESOLVED FIXED
17 years ago
3 years ago

People

(Reporter: Luke deGruchy, Assigned: Susie Wyshak)

Tracking

({qawanted})

Details

(URL)

Attachments

(2 attachments)

(Reporter)

Description

17 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:0.9.6+)
Gecko/20011201
BuildID:    2001120108

When I open Mozilla to my home page, my.yahoo.com (automatically singed in). 
There is a large ad graphic that appears at the top of the page, making me
scroll down to see the content of the page.  In IE and Netscape, this ad appears
as a virtual window, and I can get rid of it permanently by clicking on the
"close ad" hyperlink within this virtual window.

Reproducible: Always
Steps to Reproduce:
1.  Go to my.yahoo.com 
(If you don't have a Yahoo! account that automatically logs you in to the
my.yahoo.com page)
2.  Login and check off "log me in automatically"

Actual Results:  A large and annoying ad for Oracle takes up a good deal of the
page that would normally display My Yahoo! content.  I have to scroll down
everytime I view the page to see what I would normally see immediately. 
Clicking the "close ad" hyperlink, which appear to invoke a JavaScript command,
does nothing no matter how many times I click it.

Expected Results:  The ad should not have appeared within the page, but as a
virtual separate window.  Also, clicking the "close ad" hyperlink should disable
the ad permanently.

You will need a Yahoo! account to verify this bug, because it does not manifest
itself if you log in to my.yahoo.com without having been automatically signed
in.  I've seen this bug in WinNT and WinXP.
(Reporter)

Comment 1

17 years ago
Created attachment 60048 [details]
A screenshot of the initial page I get at my.yahoo.com

This is a screenshot I'm adding to illustrate the bug that I submitted.

Comment 2

17 years ago
I'm not getting and window ads in 4.x nor mozilla. My guess is that your ad has
js that does not work with us. However, we need the code (ie a saved version of
the html of that page)
(Reporter)

Comment 3

17 years ago
Created attachment 60104 [details]
HTML & JS source for my.yahoo.com in TEXT format

Here's a text file with the HTML for the page that's causing the bug.  Sorry
for the lousy formatting.

Comment 4

17 years ago
I see this problem with buildid 2001120703 on Windows2k.

Comment 5

17 years ago
It looks like the js involved here is located at
http://us.a1.yimg.com/us.yimg.com/a/1-/flash/oracle/1129/oracle3.js
I can't tell what's wrong from this but maybe someone else can. Marcio, can you
take a look at this. it's one that you're group will probably care about if it
turns out to be a tech evange issue. 

Comment 6

17 years ago
->DOM
Assignee: asa → jst
Status: UNCONFIRMED → NEW
Component: Browser-General → DOM Level 0
Ever confirmed: true
QA Contact: doronr → desale

Comment 7

17 years ago
This is what gets executed for NS6:
document.write('<a href="' + red + (startr + 4) + '/*' + ORurl + '"><img
src="'+ORstatic+'" width="170" height="35" border="0" alt=""></a>');

None of the timeout stuff that opens the content of the layer etc in NS4/IE is
called.
They check for NS6 explicitely but do nothing good with it, and they don't check
for Mozilla which I suspect is fed some NS4 code which would be why we display
the content of the <ilayer> tag without all the dynamic stuff that goes with it.

Sounds like evangelism to me.



Comment 8

17 years ago
*** Bug 123857 has been marked as a duplicate of this bug. ***

Comment 9

17 years ago
Severity = LOW [No Crash, No severe functional failure, Results in Cosmetic 
failure]
Visibility = HIGH [Happens on yahoo.com, Gets one point of 
compatibility with other browsers since it works on other browsers. ] 

Priority = Visibility * Severity

Priority = p3

adding word "qawanted" because I'm setting this priority on available data & if 
someone feels otherwise then please investigate this more & feel free to change 
this priority.

NOTE: Like Fabian said.. I also feel thats this one goes to Evangelism.
Keywords: qawanted
Priority: -- → P3
(Assignee)

Comment 10

16 years ago
marking fixed.
This was due to a sniffing issue. They now detect Gecko and only a small ad
should appear. Assigning to me in case anyone sees this issue in the futur.e
Assignee: jst → susiew
Component: DOM Level 0 → US Ecommerce
Product: Browser → Tech Evangelism
Version: other → unspecified
(Assignee)

Comment 11

16 years ago
marking fixed
Status: NEW → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → FIXED
*** Bug 114625 has been marked as a duplicate of this bug. ***

Comment 13

15 years ago
tech evang june 2003 reorg
Component: US Ecommerce → English US
Product: Tech Evangelism → Tech Evangelism Graveyard
You need to log in before you can comment on or make changes to this bug.